1. psplova45's Avatar
    Got this in 2012, it was a "to repair" listing on eBay, I replaced the cracked glass and it served me well, I'm guessing it was around 2015 I had issues with the battery, it would not reach 100% then one day not turning on. After researching almost all forum posts about this issue over the past couple years, the most I could do was turn the playbook on but then it would remain at 0%. Many times I tried and failed, but every time I held the tablet, it reminded me why I loved it, possibly the physically best made tablet, the weight distribution is so perfect, the soft textured back. I know it's pretty much useless due to lack of apps but I'd love to read on it or watch 1080p videos on my commute.

    So currently I have 3 power adapters and all 3 produce 3 different behaviour:

    1) Playbook Yellow Micro USB Adapter (Output: 5V 2A)
    2) Standard Blackberry (8520?) Micro USB Adapter (Output 5V 0.7A)
    3) JBL Speaker USB Charger with the JBL supplied USB to Micro USB cable (Output 5V 2.3A)

    Behaviour:

    1) Red light -> Red empty battery with flash in the middle sign -> Yellow light -> Blank Screen for a minute or so -> Blackberry OS Loading Screen for a couple of minutes -> Screen Brightness dims but still on OS loading screen -> Blank Screen

    2) Red light for 10 or so seconds -> 10 seconds of nothing -> Repeat for an hour or so -> Nothingness -> If I swipe the screen down I get the OS Loading screen but the device shuts off within 10 seconds

    3) Red Light for 10 or so seconds -> 5 Flashes of Yellow Light -> Nothingness

    Lets try and start over this diagnostic, I know there are a lot of threads already about this but so much conflicting information.

    I have opened the device before and lifted the battery to reveal terminals to check the voltage via a multimeter so these are procedures I can perform if needed.
    01-12-19 03:21 PM
  2. psplova45's Avatar
    Two more chargers:

    1) Apple iPad 2017 USB Adapter (5.1V 2.3A)
    2) Apple iPhone 6 Plus USB Adapter (5V 1A)

    Behaviour of both: Red Light for 10 or so seconds -> 5 Flashes of Yellow Light -> Nothingness

    i.e. same as number 2) from OP
    01-12-19 03:49 PM
  3. bb10adopter111's Avatar
    If you haven't, make sure you charge the device fully before trying to turn it on. It discharges faster than it charges during the boot process. If you don't have at least 5% battery it may not complete the boot process.

    Try charging it overnight before trying again.

    Posted with my trusty Z10
    01-12-19 04:06 PM

Similar Threads

  1. SMS shows up in HUB, only! Not in my msgs :(
    By CrackBerry Question in forum Ask a Question
    Replies: 19
    Last Post: 02-09-19, 04:28 PM
  2. YAHOO problems again, old fixes don't work. Help! January 2019
    By biancafloyd in forum BlackBerry 10 OS
    Replies: 112
    Last Post: 02-03-19, 12:36 AM
  3. Gmail service on z30
    By bb92a5 in forum BlackBerry Z30
    Replies: 19
    Last Post: 01-31-19, 07:53 PM
  4. Replies: 1
    Last Post: 01-12-19, 10:18 AM
  5. How To Fix My Blackberry Can Anyone Help Me?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 01-11-19, 08:34 AM
LINK TO POST COPIED TO CLIPBOARD