28,446
May 24 2019 | 10:27 am EDT Bla1ze

No. Chrome requires minimum Android support of 4.0. The PlayBook only supports up to Android 2.3.