1. cheshirebumpkin's Avatar
    Hi All,

    As a new PB owner I'd be grateful for some help with a Gmail problem that's driving me crazy....

    I have a Gmail account that is set up to send email using my own domain's outgoing email server. So for example, whilst I log into gmail using me@gmail.com, email sent from the Gmail web portal or my Android phone shows as having come from me@mydomain.co.uk. I don't have any of the 'sent on behalf of' problems that some people have, as it's set up within my Gmail account to send via my domain's outgoing email server, rather than Google's.

    My Gmail account is all set up fine on the PB in terms of its ability to sync mail etc...

    However, the problem is that any email I send from the PB is being received from the me@gmail.com address, which is also appearing as the reply to address rather than my own domain email.

    I can't for the life of me work out why this is happening, as surely the PB is just 'channelling' the settings of my central Gmail account? When I set it up on the PB< I had to use the gmail username of course, but did put my own domain email in the email address field.

    It's driving me nuts, so if anyone can help I would be very grateful.

    Thanks,

    G.
    06-06-12 06:29 AM
  2. Haseleyman's Avatar
    Hi All,

    As a new PB owner I'd be grateful for some help with a Gmail problem that's driving me crazy....

    I have a Gmail account that is set up to send email using my own domain's outgoing email server. So for example, whilst I log into gmail using me@gmail.com, email sent from the Gmail web portal or my Android phone shows as having come from me@mydomain.co.uk. I don't have any of the 'sent on behalf of' problems that some people have, as it's set up within my Gmail account to send via my domain's outgoing email server, rather than Google's.

    My Gmail account is all set up fine on the PB in terms of its ability to sync mail etc...

    However, the problem is that any email I send from the PB is being received from the me@gmail.com address, which is also appearing as the reply to address rather than my own domain email.

    I can't for the life of me work out why this is happening, as surely the PB is just 'channelling' the settings of my central Gmail account? When I set it up on the PB< I had to use the gmail username of course, but did put my own domain email in the email address field.

    It's driving me nuts, so if anyone can help I would be very grateful.

    Thanks,

    G.

    I had exactly the same problem myself. The PB is not 'just channelling the settings', the native mail has no facility to send from the other address. This is not an unusual problem as you can't normally do this on an ipad either (almost).

    Here is a workaround for the iPad. It didn't work for the PB when I tried it BUT with the new beta release with supposed imap improvement it may now. In the end I just changed my email address to the Gmail one and set up Gmail to send any replies to my secondary address from the Gmail one, if you see what I mean.


    Solved: Gmail, iPad, iPhone, and multiple from addresses - Modern Nerd

    You could also use the browser but be aware that you can't send attachments from the mobile gmail site, the basic html one worked ok for me.

    Anyway good luck. Please let me know how you got on.
    cheshirebumpkin likes this.
    06-06-12 12:33 PM
  3. cheshirebumpkin's Avatar
    I can't thank you enough for that tip! It's actually much simpler than the workaround you suggested, and in hindsight I probably should have thought about it and tried it before.

    All I've done is set up a new email account as an IMAP account, using the server details in the link you provided. Unlike the dedicated Gmail setup, under IMAP setup there is a field for email address that seems to operate independently from the server usernames. I simply put my domain email address in here and it is working perfectly. It's syncing my email fine, but showing and replying to my domain email address from the recipients perspective.

    Brilliant - thanks again!
    06-06-12 05:34 PM
  4. Haseleyman's Avatar
    Excellent. Glad you got it sorted out but does it show all your Gmail mail folders and labels (plus contents) in the imap set up?
    06-06-12 05:47 PM
  5. cheshirebumpkin's Avatar
    Ah, I can't answer that as I don't use Gmail on my desktop and laptop, only as an email aggregator for mobile devices. Hence I don't have any folders beyond the default, and I don't use labels. Sorry to put a downer on it, but I suspect your hunch is right and it wouldn't.....
    06-06-12 05:55 PM
LINK TO POST COPIED TO CLIPBOARD