1. mikelcal's Avatar
    Not sure anyone else has encountered this issue before... But it looks like my back light sensor went berzerk. Its a bit comforting there is a new unit on the way, but I'm a little emotionally attached to this one since I got it the day it launched... Just yesterday, after receiving the good news my playbook screen started flickering. Like the light sensor is not working like it should...

    It's now past warranty, so should I try to get an rma or should I just add it to the pile of my trusty gadgets who lived a good life?
    05-30-12 11:10 AM
  2. twdawson's Avatar
    I think i get something like this when playing flash video online but i could be mistaken as my eyes are not the best these days.
    05-30-12 11:30 AM
  3. rustycooter's Avatar
    Happened me last month. Had to replace it.
    05-30-12 11:51 AM
  4. Chaddface's Avatar
    There is a member here that got a replacement just past the warranty period. It's sure worth a shot. I got one back today from RIM. The whole process was a good experience.

    Edit: If the light sensor was going bad, maybe turning off the auto backlight diming would help.
    You tried a restart?
    If all else fails you could try to reload the OS. RIM would probably have you do that anyway during the troubleshooting process.
    Last edited by Chaddface; 05-30-12 at 11:58 AM.
    05-30-12 11:55 AM
  5. FF22's Avatar
    As Chaddface suggested, reloading the OS is standard practice when you call Rim. But if you are close to the warranty expiration date (past), then calling sooner might get them to entertain an RMA and do the additional time-consuming reload on their time after they start thinking about whether to do it under warranty.

    Good luck.
    05-30-12 12:30 PM
  6. RWD's Avatar
    Mine has a day left in warranty. My camera stopped working last month, RIM issued a RMA but I haven't got a FedEx box yet, a month later. The backlight started flickering about 3 weeks ago, usually while I am using Simple Browser. It goes off completely for a couple seconds, then comes back. Good luck with the RMA. maybe when mine dies I can get a Windows 8 tablet...
    05-30-12 12:44 PM
  7. mikelcal's Avatar
    Thanks for chiming in... not only did I do a reboot, I actually wiped the os completely. Still no joy. Also I did try turning off the auto dim setting...Looks like i'll be on the phone with the RIM guys today.
    05-30-12 03:47 PM
  8. mikelcal's Avatar
    I think i'm on to something....does any one know where the light sensor is on the pb?

    Looks like I found a "sweet spot" where it stops flickering and messing with my eyes...I 'll do a video before I call rim and try to get an rma... it's quite strange....
    05-31-12 01:32 AM
  9. jiatern's Avatar
    Did you happen to have the problem similar to my case: something (probably connector of the backlight) is loose at the back cover lower left (pb held facing the LCD).

    when you press that lower left part the backlight is back to normal, when you dont, the back light flickers or totally goes off but you can still see the extremely dim screen.

    I sent back for RMA, receiving tomorrow. Hope they really solved it.
    05-31-12 02:04 AM
  10. mikelcal's Avatar
    Did you happen to have the problem similar to my case: something (probably connector of the backlight) is loose at the back cover lower left (pb held facing the LCD).

    when you press that lower left part the backlight is back to normal, when you dont, the back light flickers or totally goes off but you can still see the extremely dim screen.

    I sent back for RMA, receiving tomorrow. Hope they really solved it.
    Yep! that's the spot... Definitely calling RIM on this one. Its not that far off warranty... Crossing my fingers they will do it.. The spot for me is right over the HDMI micro connector..

    When it started like 3 days ago...
    [YT]http://www.youtube.com/watch?v=xrnOVJBy5lI[/YT]

    Most recently....
    [YT]http://www.youtube.com/watch?v=KQPhY2wIYBM[/YT]
    05-31-12 02:28 AM
  11. FF22's Avatar
    The second video says "private" and does not display.

    I am guessing this happens anywhere you carry your pb. That is the pb is NOT near a plasma tv or some other electronic device that might cause interference. The light sensor, I think, is located in the led window (left of camera).
    05-31-12 09:01 AM
  12. mikelcal's Avatar
    I'm on the phone with RIM Customer Care. I must say I love their hold music, I'd like that to be my ringtone... LOL I'll change the permissions on the vid, it shows my email on the screen so i don't want the whole world to know it.. LOL
    05-31-12 01:12 PM
  13. mikelcal's Avatar
    The second video says "private" and does not display.

    I am guessing this happens anywhere you carry your pb. That is the pb is NOT near a plasma tv or some other electronic device that might cause interference. The light sensor, I think, is located in the led window (left of camera).
    Yeah that's right...it happens when I'm in bed, at work, in the "john", absolutely everywhere...
    05-31-12 01:36 PM
  14. FF22's Avatar
    I hated their Kettle Drum hold-music! Clearly, something is loose inside.

    Good luck with the rma.
    05-31-12 03:27 PM
  15. mikelcal's Avatar
    RMA was approved, they are sending me a kit to send it back for repair. Its one of the first units to come to the Bay Area in California and it also has the recessed power button. I really hope they fix that too LOL.
    05-31-12 03:51 PM
  16. FF22's Avatar
    With luck you should have the shipping box by tomorrow and it will be in Tennessee on Monday if you get it off quickly.
    05-31-12 04:24 PM
  17. jiatern's Avatar
    Just watched the second video, yeah exactly my playbook's issue, more specifically the spot is at the back.

    yikesss I just got my playbook back from RMA, they said they cannot fix it so they gave me a new one. But my screen protector is gone (of course) and guess what, this is a pb with recessed power button

    I cannot wait another week to get another replacement, so I just accepted it. Since I seldom use the power button.

    good luck to you, remember to fully backup everything, they might just give you a 1 to 1 replacement if they can't fix it like my case.
    Last edited by jiatern; 05-31-12 at 11:34 PM.
    05-31-12 11:04 PM
  18. mikelcal's Avatar
    WOOOOOHOOOOOO I can't say enough good things about RIM. Not only did they fix my flickering screen, they did it Gratis, for Free, even though I was a few weeks out of warranty. On top of that, they replaced the housing, it still has the same serial number, but the housing is brand spanking new! no more recessed power button or wonky volume rocker...(vol up was weird to press, didn't "click" but i over looked that.) THANKS RIM!
    Harryl6134 likes this.
    06-08-12 12:02 PM
LINK TO POST COPIED TO CLIPBOARD