1. faheem24's Avatar
    Hey y'all. Well I've been at it for days in a row to no avail.

    Here's the problem. When I connect the drained PB to the RAPID CHARGER (yellow), the red led comes on for about 10-15 seconds.
    This is followed by the red battery with the lightning bolt icon popping up on the screen.
    The battery icon then fades away, and the green led starts pulsating for a few seconds.

    But here's the WORST part. The green light just disappears after 4-6 seconds and the whole cycle starts again, i.e, red led---->lightning bolt----->green pulse, and then BOOM. all over again.

    At any point in time, if i remove the charger from the port, pb jus goes off completely.

    I need HELP!
    08-18-13 10:16 PM
  2. Enyigma's Avatar
    Are you sure the PlayBook has not been so discharged that it needs a manual recharge with the PlayBook OFF?

    The red battery icon would tell me the battery is very much discharged and that the PlayBook is still on. I would have turned the PlayBook off at that point and recharged right away. If you are having the PlayBook stay on during these attempts, you could be draining the battery below the point at which the charging software will allow a normal charge. At that point, you have to manually keep reconnecting the PlayBook every minute or so for a number of cycles before there is enough of a charge for the charging software to work properly.
    Last edited by Enyigma; 08-19-13 at 10:22 PM.
    08-18-13 10:31 PM
  3. FF22's Avatar
    I don't have my text file so look up stack charging. basically, plug and u plug from the wall five or so seconds unplug and reat even up to half and hour. but as sugvested turn the pb off.
    08-18-13 11:19 PM
  4. faheem24's Avatar
    My Playbook is NOT turned on during these attempts... its discharged to a point of staying off... Please give me a suitable workaround...
    08-19-13 12:39 AM
  5. BCITMike's Avatar
    There are other threads on this subject going back to as far as when they were released and you will find a solution. IIRC, I held in the power button for like 30 seconds and then it started taking a charge. Did it as recently as a few weeks ago for a PB over a year old BNIB.

    http://forums.crackberry.com/blackbe...ry-fix-737797/
    Last edited by BCITMike; 08-19-13 at 02:26 AM. Reason: Link
    08-19-13 02:24 AM

Similar Threads

  1. my blackberry is not opening !! HELP !!
    By hissa in forum BlackBerry Bold 9930/9900
    Replies: 13
    Last Post: 05-18-14, 12:05 AM
  2. Whatsapp for BBOS 7 not working
    By Nilton Jeronimo in forum BlackBerry 7
    Replies: 3
    Last Post: 08-29-13, 07:13 PM
  3. Reboot cycle when restoring
    By JigzStar in forum BlackBerry Bold 9930/9900
    Replies: 2
    Last Post: 08-19-13, 03:39 AM
LINK TO POST COPIED TO CLIPBOARD