1. derelicte85's Avatar
    I downloaded three apps on my Playbook that just won't go away. i tried deleting them from the main screen, but everytime I restart the device the apps appear once again - except now the app icon isn't there - just the app name, and a shadow above it.

    2.0 also seemed to bump off my citrix. and now when I try to delete them from app world, I just get the busy green ring - and nothing.

    I don't want to do a security wipe, but its starting to look like i have no other choice. Thoughts?
    03-13-12 05:53 PM
  2. saudadeii's Avatar
    What apps? Did you download them from App World? Does App World show them as installed?

    Try refreshing the application list in App world.

    Meanwhile, get a good backup.
    03-13-12 06:00 PM
  3. Spencerdl's Avatar
    One of my apps did the same thing and reset would not work. I had to do a "HARD RESET" and everything worked out. HARD RESET is holding down the the power button and both volume controls at the same time for 15 seconds and let the playbook start up by itself
    03-13-12 06:02 PM
  4. merrymargaret's Avatar

    Well, I tried that three times. How in heck do you do that? Couldn't press hard enough. Am I a weakling?
    07-22-12 12:45 PM
  5. FF22's Avatar
    Press the Power Button (if flush or recessed, it can be hard to press) and then Press and hold the Vol Up/Down buttons (if you hear a shutter sound you may have taken a screen shot). It does take a bit of finger dexterity.
    07-22-12 01:15 PM