1. 0nyx175's Avatar
    Hi guys.

    I've tried everything and searched high and low and cannot come up with a solution. I am trying to mount a drive on my playbook. Here is my file structure

    • Books
    • Camera
    • Documents
    • Downloads
    • Misc (contains android and dosbox)
    • Music (contains media sync)
    • Photos
    • Print
    • Videos
    • Voice


    I'm trying to mount a drive in dosbox but having no luck. I've put theme hospital in a folder called "theme" in the dosbox folder. Can anyone suggest what i need to type to load a drive? For example it suggests typing "mount c ~/dosprogrogs" but when i do this it says

    directory //accounts/1000/appdata/a7omicapps.dosbox.gYaBgPLVPiKWfaMVQ8fm4FcArVg/data/dosprogs doesn't exist
    04-18-12 01:11 PM
  2. DAnklaud's Avatar
    try this:

    type- mount c /accounts/1000/shared/misc/dosbox --hit enter
    then:
    type- c:/ --hit enter
    then:
    type- cd theme --hit enter
    then:
    type the name of the game --hit enter again
    rosecity1980 likes this.
    04-18-12 02:20 PM
  3. 0nyx175's Avatar
    aha fantastic - do i have to do that every time?
    04-18-12 02:54 PM
  4. GreyGhostRos's Avatar
    Well..I don't know if it works on the Playbook port of Dosbox (i don't see why it shouldn't though)
    Try this:
    open up the dosbox.conf file and add the mount line (and anything else you want Dosbox to do at startup..) to the [autoexec] section in it.. The file should be under /misc/dosbox/
    Should work i guess..
    Last edited by GreyGhostRos; 04-18-12 at 03:33 PM.
    04-18-12 03:25 PM
  5. DAnklaud's Avatar
    An example (if you change the .txt to .conf it will work ,this is the one from my playbook)

    but i made it so it auto-mounts my C-folder in the misc folder,just change the c to dosbox at the end of the text
    04-18-12 03:56 PM
  6. FF22's Avatar
    It does work. Here's mine which mounts and runs the LIST program:


    [autoexec]
    # Lines in this section will be run at startup.
    # You can put your MOUNT lines here.

    mount c /accounts/1000/shared
    c:
    cd misc
    list
    04-18-12 04:00 PM
  7. sebecco's Avatar
    Hello!

    On my PB in the "books" folder I have subfolder with the program, unfortunately, I'm trying to mount c in this subfolder I get an error: "directory does not exist"

    I type: mount c /books/subfolder

    Please help, what to do? Is the program you want to launch the PB should upload to another directory ...?
    11-19-12 05:03 AM
  8. NoraMelua's Avatar
    You have to mount the full path as shown by DAnklaud and F2.
    The Playbook's media folders are subdirectories of /accounts/1000/shared/, thus the mount command should look like this in your case:

    mount c /accounts/1000/shared/books/subfolder
    11-19-12 06:11 AM
  9. DoctorNeutron's Avatar
    You have to mount the full path as shown by DAnklaud and F2.
    The Playbook's media folders are subdirectories of /accounts/1000/shared/, thus the mount command should look like this in your case:

    mount c /accounts/1000/shared/books/subfolder

    I keep trying with no joy. Give an exact,explicit example. You all are typing
    to DOSBOX directly, right? You are using THE virtual PB keyboard and not
    an external BT keyboard, right? Doc Neutron
    11-23-12 09:03 PM
  10. FF22's Avatar
    In my example, Post #6, I have the "mount" line in the autoexec file. That way it executes as dosbox loads. Then it actually, also runs the dos program LIST.

    Try just using:

    mount c /accounts/1000/shared

    Then navigate further down by typing
    c: (the drive specified by the MOUNT statement c above)
    cd one-you-want (misc or documents or ....)

    Do not place any extrnaeous colons : or / in the Mount statement. Keep lowercase.
    DoctorNeutron likes this.
    11-23-12 09:42 PM
  11. DoctorNeutron's Avatar
    F2. TY. Got tone this am directly from virtual KYBD with abbreviated command line.
    Could swear I tried similar yesterday. Oh well. Again, TY. Doc Neutron
    11-24-12 09:21 AM
  12. DoctorNeutron's Avatar
    More mechanics problems: (1) how to edit files from within dosbox, (2) type tilde character, (3) find DOSBOX in misc -
    none of Air Browser My File Manager, or dosbox sees anything in misc except Android and a pdf. Doc Neutron
    Aka The Tar Baby
    11-24-12 02:32 PM
  13. FF22's Avatar
    More mechanics problems: (1) how to edit files from within dosbox, (2) type tilde character, (3) find DOSBOX in misc -
    none of Air Browser My File Manager, or dosbox sees anything in misc except Android and a pdf. Doc Neutron
    Aka The Tar Baby
    What kind of editing? I just used an old dos program called Qedit. I was able to type.

    Re: Tilde - I could not get that or most of the other special characters (Press the 123-Number key and then that key with the two dots, one blue for special characters) to type. I got the letter "q" for most of them including the Tilde.

    I am not sure what Question 3 is about. I opened AirBrowser and can drill into the Misc folder. I see android, and dosbox and pdf (I created it) and TI (Texas Instruments calcs) in Misc. And in Doxbox I see 3 files including

    dosbox-0.74.conf
    dosbox-0.74.org
    dosbox-0.74mount.conf

    Those are my additional files or saves, the org=original conf and the mount one is another example I saved.

    I have to say, I am NOT a dosbox expert. There were a few old dos programs I wanted. Some folks have gotten old games and even early versions of Windows running in the emulations. There is an older doxbox thread in the apps subforum, I believe.
    11-24-12 04:11 PM
  14. DoctorNeutron's Avatar
    I remember qedit (now) ! Found a dosbox related txt file in downloads. Tilde is
    not a real problem if I just use Windows or AIR or what to rename files. Here is
    a bottom line for me: got one of my old DOS programs to run ! Woot ! Of course,
    similar programs will run only if they don't touch Windows. Now I am wondering
    if a W95 install will let some of my other programs to run ! Doc Neutron
    11-25-12 10:46 AM
  15. FF22's Avatar
    I still have a BIN folder on what is probably now my 5th version of Windows - some programs have never been duplicated well in the Windows environment but I use many of them less and less.

    As a general non-gamer, that aspect of Doxbox is not one I've explored much. But others have gone to great extents to get their old favorites running from what I've read.
    11-25-12 11:13 AM
  16. DoctorNeutron's Avatar
    Got a version of qedit loaded on c: which I had just mounted. When I then
    edit z:/autoexec.bat to place a mount command there, it looks good but then
    fails to save, reporting an open error. Is this because Doc has forgotten his
    dos rubrics or is it because this file or z: is write-locked?

    A BT KYBD is definitely a plus in this dos environment ! Doc Neutron
    11-29-12 04:09 PM
  17. FF22's Avatar
    Where/what is Z: drive? If it is the topmost or root folder on your pb, I don't think you can write or add anything ot it.

    My dosbox autoexec.bat file is located

    \\192.168.1.164\media\misc\dosbox\autoexec.bat
    11-29-12 04:50 PM
  18. DoctorNeutron's Avatar
    When I fire up Dosbox, it is at z:\, at which are many COM files and
    autoexec.bat. (See attached.) Doc NeutronDosbox mounting?-img_00000156.jpg
    11-29-12 05:25 PM
  19. FF22's Avatar
    Whoops, sorry.

    My "autoexec.bat" file actually is contained within

    dosbox-0.74.conf

    But when I use the TYPE command on the autoexec.bat file YOU referenced above, it contains the info that I provided in that xxx.conf configuration file. Those files might be read-only??

    Again, I'm far from a dosbox expert - so feeling me way through it!

    edited for clarity.
    Last edited by F2; 11-30-12 at 11:18 AM.
    11-29-12 05:38 PM
  20. sebecco's Avatar
    Thank you all for your help and attention. DosBox is launched.

    I tried to run an old game from 1994 year (Little Big Adventure). The game has started, but I can not make a move on the menu - and I can not play ... (I think the reason is prosaic game is not ready for touch screens).

    Regards
    and once again thank you.
    11-30-12 09:09 AM
  21. Poncherelly's Avatar
    I've written a basic bat file to do a couple of options and could of course be modified to list games instead of OSs but for some reason it doesn't work as expected. Anyone interested and reviewing and providing feedback?
    @echo off
    title please select an option

    :Clean
    cls

    :Options
    echo What would you like to run?
    echo 1 DOS 6.22
    echo 2 Windows 95
    echo 3 Windows 98
    echo 4 Windows XP
    echo 5 Windows 7
    echo 6 Back to DOSBox
    echo 7 EXIT

    :Select
    set/p input=[Choose an OS]
    if '%input%'=='1' goto a
    if '%input%'=='2' goto b
    if '%input%'=='3' goto f
    if '%input%'=='4' goto f
    if '%input%'=='5' goto f
    if '%input%'=='6' goto g
    if '%input%'=='7' goto h
    echo please enter a number only
    pause

    :a
    cd os
    imgmount a d622.img
    pause
    boot d622.img
    pause
    goto Clean

    :b
    cd os
    imgmount a w95.img
    boot w95.img
    pause
    goto Clean

    :c
    cd OS
    imgmount a w98.img
    boot w98.img
    pause
    goto Clean

    :d
    cd OS
    imgmount a xp.img
    boot xp.img
    pause
    CLS
    goto Clean

    :e
    cd OS
    imgmount a 7.img
    boot 7.img
    pause
    CLS
    goto Clean

    :f
    echo I'm sorry, That version of Windows is still being worked on
    pause
    goto Clean

    :g
    Options.bat

    :h
    echo Thank you for using DOSBox with Windows ... have a great day
    echo.
    pause
    exit
    01-25-13 11:36 AM
  22. jpash549's Avatar
    Confusing to me. There are two apps in Blackberry World: DosBox and DOSBox. Which one is preferred?
    01-25-13 04:42 PM
  23. Poncherelly's Avatar
    I have both installed but find DOSBox the one that allows me to modify the config code to launch my batch file.
    01-27-13 11:18 PM

Similar Threads

  1. Pearl case mounted on my visor?
    By jasonnet in forum BBOS Phone Accessories
    Replies: 2
    Last Post: 12-28-07, 03:27 PM
  2. Windshield mount for BB
    By KEyKeyDero in forum BBOS Phone Accessories
    Replies: 1
    Last Post: 10-16-07, 10:54 PM
  3. Seidio Case with Car Mount
    By smtesta in forum BBOS Phone Accessories
    Replies: 2
    Last Post: 09-30-07, 10:14 AM
  4. BMW mount
    By FlyingBB in forum BBOS Phone Accessories
    Replies: 3
    Last Post: 09-27-07, 03:54 PM
  5. Car Mount
    By Cellularamps in forum BBOS Phone Accessories
    Replies: 6
    Last Post: 04-11-07, 10:49 PM
LINK TO POST COPIED TO CLIPBOARD