1. koontzy65's Avatar
    my playbook was nice the first 6 month
    now its the 4th time I send it back for rma and its the 4th time they send me a refurb one with dead pixel or screen problems...
    1- problem was a faulty charging connector
    2- problem with dead pixel right in the middle of the screen
    3- problems with the color of the screen (like a shade around the screen
    4- 8-9 dead pixels near the top
    everytime its a new one with a new serial number(probably refurbished one)
    i've spend the last month and a half with the playbook in my hand about 2 days (like I receive it, I see the dead pixel, i call and they send me a box the next day
    also, they dont have any number for complains (only the head office number in waterloo and its not even a toll free number LOL (I live in quebec, CA))
    Well, its a great device for the price if you dont have any troubles
    Thank you for your time guys
    bdguru likes this.
    10-16-12 06:33 PM
  2. esk369's Avatar
    What was the original problem with it?
    10-16-12 06:41 PM
  3. chiefchie's Avatar
    I just got my pb back last week from sending to bb service due to suddenly not changing. I'm happy with their service, the whole process took 6 days. But I understand your frustration op, hope you get a working trouble free playbook.
    10-16-12 07:03 PM
  4. koontzy65's Avatar
    charging connector, not recognized by pc (not pc side problems, tryed on about 5 differents computer)
    10-16-12 08:15 PM
  5. esk369's Avatar
    That's a buzz kill for sure sounds like they need to stop sending the refurbs and give you a new one. Hope you get it worked out.
    I'm mean you can't argue 5 different pc's sounds like a qc problem with the refurbished units I'm glad I'm reading this because I was considering buying a couple of them from some website someone was recommending today going to have to re think that again hope they do the right thing.
    10-16-12 08:57 PM
  6. playbookpa's Avatar
    Ouch! I've been through 2 RMA in a row, know it feels sad, madening, frustrating... But keep at it : we are so glad with our two working PB in the house now!

    Had exactly the same problem as you, 2nd PB had a problem (would never go to standby) and was refurbished (it was cleary written on one of their paper). So I called back, and had another person, of course. The first one clearly understood french (I'm in Qubec, too), but the second one was just so so, I didn't switch to english and should have, she referred up the ladder many times, and clearly did not understand, BUT she followed by a mail.

    So I could write (in english) the details of the problems, with steps to reproduce, the steps I've gone through (thanks CrackBerry for that), indicated the time I've spend, that I felt entitled to have a working unit, and "if you want to test further, please do it on your time now, not mine".

    OK, took me maybe an hour to write a 2 pages pdf, but I got the 2nd RMA immediately, received good PB in days.

    Shortly: I kept calm and understanding on the phone (not so easy...), I wrote something so detailed, proving I know what a debrick and a security wipe and a cycle charge are, that no tech coud argue about, and it just worked! I think the problem is we don't talk directly to techs, but it seems they can be forwarded a doc., and they read it : now there's hope!

    Keep at it, generally customer service has a good tracking record, and if you can, speak and write in english... Sadening for us in Qubec, but hey, you got to get a working unit, as it's really cool, once it works! ;-)

    Hope it helps a bit, cheers! Lche pas, a vaut la peine ;-)
    Last edited by playbookpa; 10-17-12 at 09:44 AM.
    10-17-12 08:42 AM
  7. playbookpa's Avatar
    10-17-12 09:42 AM
  8. dzl19's Avatar
    maybe its the other way around i know that they work hard for us BB users but if you don't know a clue what to do it is a lot harder for anyone to help

    if u plug it in upside down it will brake the port
    i strongly recommended u buy a raped charger
    solves a lot of issues
    Last edited by dzl19; 10-17-12 at 02:30 PM.
    10-17-12 02:19 PM
  9. zorecati's Avatar
    Ouch! I've been through 2 RMA in a row, know it feels sad, madening, frustrating... But keep at it : we are so glad with our two working PB in the house now!

    Had exactly the same problem as you, 2nd PB had a problem (would never go to standby) and was refurbished (it was cleary written on one of their paper). So I called back, and had another person, of course. The first one clearly understood french (I'm in Qubec, too), but the second one was just so so, I didn't switch to english and should have, she referred up the ladder many times, and clearly did not understand, BUT she followed by a mail.

    So I could write (in english) the details of the problems, with steps to reproduce, the steps I've gone through (thanks CrackBerry for that), indicated the time I've spend, that I felt entitled to have a working unit, and "if you want to test further, please do it on your time now, not mine".

    OK, took me maybe an hour to write a 2 pages pdf, but I got the 2nd RMA immediately, received good PB in days.

    Shortly: I kept calm and understanding on the phone (not so easy...), I wrote something so detailed, proving I know what a debrick and a security wipe and a cycle charge are, that no tech coud argue about, and it just worked! I think the problem is we don't talk directly to techs, but it seems they can be forwarded a doc., and they read it : now there's hope!

    Keep at it, generally customer service has a good tracking record, and if you can, speak and write in english... Sadening for us in Qubec, but hey, you got to get a working unit, as it's really cool, once it works! ;-)

    Hope it helps a bit, cheers! Lche pas, a vaut la peine ;-)
    This is the key. Keep calm and don't give the person on the other end a hard time. If you get pissy with them, you probably will not get what you are looking for.
    10-17-12 02:23 PM

Similar Threads

  1. huge disconnect between VZW customer service and local stores
    By Laureanne in forum Verizon Wireless
    Replies: 3
    Last Post: 07-11-09, 06:41 PM
  2. huge disconnect between VZW customer service and local stores
    By Laureanne in forum Verizon Wireless
    Replies: 0
    Last Post: 07-11-09, 05:16 PM
  3. My 3rd Bold, and ATT customer service
    By JaemanKim in forum BlackBerry Bold 9000
    Replies: 20
    Last Post: 03-11-09, 03:10 PM
  4. Replies: 9
    Last Post: 02-19-09, 07:42 AM
  5. Invisible Shield, and Zagg's customer service
    By korbas12 in forum BBOS Phone Accessories
    Replies: 3
    Last Post: 03-25-08, 08:03 PM
LINK TO POST COPIED TO CLIPBOARD