1. MrT1ki's Avatar
    so i'm sure that i can't be the only one having trouble getting the playbook to connect to my mac via usb. i've done it a couple times and had it show up as a mass storage deice but since then haven't been able to.

    what's the secret to getting this thing to connect?
    05-30-11 01:52 AM
  2. sherwink20's Avatar
    had the same issue before, installed drivers on mac #1 so far so good; then connected with mac #2, drivers doesn't seem to pop up.

    try this:

    You probably have it on "Connect to Mac" - don't. Use "Automatically detect" instead. when you connect it again to your mac, the driver should pop up, install, reboot and you should be good to go.
    05-30-11 02:18 AM
  3. lindajm22's Avatar
    I found it very simple to connect wirelessly to my MacBook Pro as a server, no driver install or anything. You just need to know either the exact name of your Playbook or its internal ip address.
    05-30-11 08:04 AM
  4. MrT1ki's Avatar
    I found it very simple to connect wirelessly to my MacBook Pro as a server, no driver install or anything. You just need to know either the exact name of your Playbook or its internal ip address.
    and then what do you do once you have that?
    05-30-11 10:48 AM
  5. CUNAZ's Avatar
    and then what do you do once you have that?
    Copy files to and fro! Documents, videos, pictures.
    05-30-11 11:34 AM
  6. kill_9's Avatar
    I recommend this tutorial about WiFi file transfer between the BlackBerry PlayBook and a computer.
    05-30-11 11:38 AM
  7. MrT1ki's Avatar
    I recommend this tutorial about WiFi file transfer between the BlackBerry PlayBook and a computer.
    I actually would really like to know how files can be shared via USB. I know it's possible as I've done it before....

    but thank you for the link nonetheless
    Last edited by MrT1ki; 05-30-11 at 12:06 PM.
    05-30-11 12:04 PM
  8. livejam's Avatar
    When I plug in my playbook it just shows up as a network drive, so I can transfer with usb that way. I have it to detect automatically and it works fine.
    05-30-11 12:33 PM
  9. MrT1ki's Avatar
    When I plug in my playbook it just shows up as a network drive, so I can transfer with usb that way. I have it to detect automatically and it works fine.
    I had that happen in the past but I can't seem to get it to happen again even though I don't think I changed any settings.
    05-30-11 12:39 PM
  10. btrister's Avatar
    I have been dealing with this RIM technical support on this issue for weeks. The problem has been identified and they say it will be fixed in a future software release. Until then, using wifi is the slower but only option for those of us who are affected by the problem.
    05-31-11 09:07 AM
  11. btrister's Avatar
    had the same issue before, installed drivers on mac #1 so far so good; then connected with mac #2, drivers doesn't seem to pop up.

    try this:

    You probably have it on "Connect to Mac" - don't. Use "Automatically detect" instead. when you connect it again to your mac, the driver should pop up, install, reboot and you should be good to go.
    When you said "you probably have it on 'connect to mac'" what did you mean by "it"? Thanks.
    05-31-11 09:09 AM
  12. lindajm22's Avatar
    When you said "you probably have it on 'connect to mac'" what did you mean by "it"? Thanks.
    On your PlayBook, in the Storage and Sharing settings, set USB Connections to "Automatically Detect" instead of "Connect to Mac".
    05-31-11 10:05 AM
  13. btrister's Avatar
    For those of you who, like me, have been unable to use our USB ports to connect our PlayBook to our Mac, after a month of back and forth with Tech Support at RIM, they figured out the problem and a workaround. Here are the steps:

    1. Connect your PlayBook to your Mac;
    2. Go to the Apple Menu, select System Preferences, then select Network;
    3. Click on the + and add the PlayBook using the default name offered;
    4. Make sure the DHCP option is selected and hit Apply; and
    5. Close the Network window.

    What is interesting is that the IP address for the PlayBook that was found when you performed the above is not reported correctly. In my case, and likely in yours, it will be off by one digit. So, next do the following:

    1. Go to the widget at the top right hand of your PlayBook screen;
    2. On the About screen, choose Network from the pop-up menu;
    3. Note the IPv4 address under the USB heading (it should begin with 169);
    4. In the Mac Finder, in the Go menu, select Connect to server;
    5. Enter smb://169. and the rest of the IP address found in step 3 and hit return;
    6. Open a Finder window and you should see the IP address under the Shared Devices heading. Double click on the IP address and you should then see the two folders in the top directory of your PlayBook.

    I hope this is of assistance.
    06-15-11 11:09 PM
  14. lynntarbox's Avatar
    wow having the exact same issue now. i never bothered to even try to transfer files to my playbook until today. the solution above did not work for me. i am only able to connect via over my LAN and an unable to actually transfer anything via USB from my macbook at all.

    in storage & sharing i have 'automatically detect' in USB connections. i have file sharing ON and wifi sharing OFF (i don't want to use wifi sharing because right now i want to transfer a bunch of huge videos on it to test compatibility).

    when i start up blackberry desktop manager it just gives me this:

    The BlackBerry Desktop Software cannot connect with this device.
    If this device is rebooting or has a dead battery, click Retry to attempt to reconnect once the device reboots.

    If clicking Retry doesn't connect the device, or the device isn't rebooting with a charged battery, you might need to repair your software to correct the problem.

    You can also click Cancel to stop trying to connect your device with the BlackBerry Desktop Software. To try again, you'll need to disconnect and reconnect your device with your USB cable.
    The device is not rebooting nor does 'repair' actually repair anything at all after disconnect/reconnecting the playbook via usb. i don't know if it makes a difference but i'm also on 2.0 beta (6149).

    sigh. can't even use this thing as a basic usb storage device right now.
    12-19-11 11:53 AM
  15. lynntarbox's Avatar
    got it fixed! i dont know if its a 2.0 beta thing but i *had* to turn on dev mode in order to access the playbook via usb at all. strange but works now!
    12-19-11 12:51 PM
  16. kath_6's Avatar
    For those of you who, like me, have been unable to use our USB ports to connect our PlayBook to our Mac, after a month of back and forth with Tech Support at RIM, they figured out the problem and a workaround. Here are the steps:

    1. Connect your PlayBook to your Mac;
    2. Go to the Apple Menu, select System Preferences, then select Network;
    3. Click on the + and add the PlayBook using the default name offered;
    4. Make sure the DHCP option is selected and hit Apply; and
    5. Close the Network window.

    What is interesting is that the IP address for the PlayBook that was found when you performed the above is not reported correctly. In my case, and likely in yours, it will be off by one digit. So, next do the following:

    1. Go to the widget at the top right hand of your PlayBook screen;
    2. On the About screen, choose Network from the pop-up menu;
    3. Note the IPv4 address under the USB heading (it should begin with 169);
    4. In the Mac Finder, in the Go menu, select Connect to server;
    5. Enter smb://169. and the rest of the IP address found in step 3 and hit return;
    6. Open a Finder window and you should see the IP address under the Shared Devices heading. Double click on the IP address and you should then see the two folders in the top directory of your PlayBook.

    I hope this is of assistance.
    This solution worked. Thank you so much, I was able to retrieve my videos and photos taken on the PB. Can't believe still the same issue in Dec 2012 since your post 18 months ago. They were in the 'Camera' folder in 'Media'.
    12-15-12 04:57 PM
LINK TO POST COPIED TO CLIPBOARD