1. mnhockeycoach99's Avatar
    Greetings,
    With the new native email application on my PlayBook, I'm attempting to set up my Comcast email. I called Comcast, but really didn't get anywhere so I'm hoping a fellow CrackBerryian can help me out.

    -First off, I am choosing "POP server"

    -Next, I enter the description, display name, user name, email address, password.

    Below is where I'm running into difficulties.

    -I enter the server address as mail.comcast.net and the port as 110. I then turn off "use SSL".

    -Then, I deleted SMTP username and password.

    -I entered the SMTP server address as smtp.comcast.net
    and the SMTP port as either 25 or 587.

    Finally, I changed the encryption to "off", finished up the delivery settings and then hit "save".

    The problem is I keep getting an error message about "the port cannot be reached" however, 1. I am connected to Wifi and 2. the Comcast rep verified the above port #s.

    Please help...
    02-21-12 04:21 PM
  2. JosephRuff's Avatar
    why are you doing advanced? i just put in my email and password for comcast and it did the rest.
    02-21-12 04:34 PM
  3. cntrydncr223's Avatar
    Try, add new account. and just add email and pw, does that work?

    swipe down, accounts, pencil, delete, then add new account.
    02-21-12 04:37 PM
  4. jdr116's Avatar
    I cannot add either my btinternet or gmail email address to the email app either....I KNOW 100% that im using the correct passwords and log ins.Anyone got any ideas please?
    02-21-12 04:50 PM
  5. doctord23's Avatar
    Mine works. I also had to do the advanced setup for POP. It did not work by just entering my email address and password. I didn't change any of the default ports or encryption, I just put in the server names.

    My setup is as follows:

    Username = email name (not including @comcast.net)
    Eamil Address = the full email address
    Password = "your password"
    server address = mail.comcast.net
    Port = 995
    SSL = ON
    SMTP Username = email name (not including @comcast.net)
    SMTP Password = "your password"
    SMTP PORT = 465
    Encryption = SSL
    02-21-12 05:06 PM
  6. mnhockeycoach99's Avatar
    Mine works. I also had to do the advanced setup for POP. It did not work by just entering my email address and password. I didn't change any of the default ports or encryption, I just put in the server names.

    My setup is as follows:

    Username = email name (not including @comcast.net)
    Eamil Address = the full email address
    Password = "your password"
    server address = mail.comcast.net
    Port = 995
    SSL = ON
    SMTP Username = email name (not including @comcast.net)
    SMTP Password = "your password"
    SMTP PORT = 465
    Encryption = SSL

    Thank you! That worked for me. I tried the easy way of just entering my user name and password with no luck.
    Willard814 likes this.
    02-21-12 06:37 PM
  7. kjm2010's Avatar
    Anyone getting occasional error message of: "server unavailable try again later "with their comcast account?
    This happens even though it keeps delivering email, and with no loss of WiFi during that interval?
    02-23-12 03:37 PM
  8. f_lungers's Avatar
    from time to time....I'm getting "comcast is not responding" error messages...and in the Hub it claims "Your login information for POP server [mail.comcast.net] has changed or is incorrect. Please check your account settings" messages......the "temporary" fix has been to reenter password but this is getting really really really tiring....anyone know of a fix? Help?!?!?!
    09-06-13 03:51 PM
  9. katesbb's Avatar
    the "temporary" fix has been to reenter password but this is getting really really really tiring....anyone know of a fix? Help?!?!?!
    Happens to me too. As it doesn't seem to actually lose the password, I find it a little easier to just add a space to the account name (etc.), then backspace it out, then hit Save. Bit easier than typing in a whole password
    09-06-13 03:56 PM
LINK TO POST COPIED TO CLIPBOARD