1. Bigum1969's Avatar
    I took the plunge and picked one up. During setup, it hangs at the country/language setup portion. No matter what country/language I choose, it won't load the Blackberry ID.

    I found the problem posted on BB web site, but its fix doesn't work. (trying to configure the wifi as a hotspot)

    Please help.

    I've setup a Xoom, ipad2 and a Viewsonic G tab. So, I'm not totally ignorant on this stuff.
    04-21-11 08:50 PM
  2. laurah2215's Avatar
    Actually this happened when I loaded the new OS.I tried to select a language/country and it wouldn't pull up the agreement. I just restarted and then I was able to get past this step. Maybe try restarting/hard reset?
    04-21-11 08:58 PM
  3. gordazo's Avatar
    It happened to me the first time. I had a bad wifi connection.
    04-21-11 08:58 PM
  4. Bigum1969's Avatar
    I've tried a hard reset twice... Didn't work.

    Wifi connection is fine... My iPad is working.
    04-21-11 09:09 PM
  5. phantom189's Avatar
    Had the same issue too and it was a wifi problem. Low signal to be exact. When I moved closer to the access point and the signal meter was all green, it got past the country prompt.
    04-21-11 09:14 PM
  6. Bigum1969's Avatar
    Had the same issue too and it was a wifi problem. Low signal to be exact. When I moved closer to the access point and the signal meter was all green, it got past the country prompt.
    Let me give that a try...
    04-21-11 09:35 PM
  7. Taxman45's Avatar
    I had the problem and saupport couldn't fix it. Then they told me I didn't need to accept the user agreement and everything would work just fine. So I gave up.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-21-11 09:53 PM
  8. Bigum1969's Avatar
    I had the problem and saupport couldn't fix it. Then they told me I didn't need to accept the user agreement and everything would work just fine. So I gave up.

    Posted from my CrackBerry at wapforums.crackberry.com
    But you can't move on in the setup...
    04-21-11 09:54 PM
  9. Red Rooster's Avatar
    I had the same problem. The only solution that worked for me was plug the usb in with the latest DM on your computer and it upgraded the OS and I was able to finish the set up with no issues. My PB is running smooth and right.

    Good luck.
    chiefbroski likes this.
    04-21-11 10:09 PM
  10. Bigum1969's Avatar
    I'm now trying the DM route.

    This really shouldn't be this hard.
    04-21-11 10:47 PM
  11. Bigum1969's Avatar
    Good lord... 20 minutes and half the OS software isn't even downloaded...
    04-21-11 11:04 PM
  12. Red Rooster's Avatar
    Yup....it did take a hot second....but was totally worth it.
    04-21-11 11:46 PM
  13. Taxman45's Avatar
    I can't get past country ID even after updating the OS by connecting USB to PC. I also get an error message when I try to connect to software update. This is so dumb! Tech support assured me that I didn't need to finish setup because there wasn't anything else to set up after accepting the user agreement. What happens after you get past this screen? My Playbook seems to be mostly working.
    04-22-11 12:52 PM
  14. Taxman45's Avatar
    I was able to finish the setup after resetting my device a second time and installing the latest OS version via desktop manager attached to a PC.
    04-22-11 05:09 PM
  15. Bigum1969's Avatar
    I was able to finish the setup after resetting my device a second time and installing the latest OS version via desktop manager attached to a PC.
    This is what I ended up finally doing... It's finally running like it should.
    04-22-11 09:23 PM
  16. pili4's Avatar
    I had that problem too until I figured out that Comcast couldn't handle 2 laptops, an xbox and my PB all going at the same time. I turned off the xbox and everything has worked perfectly since.
    04-23-11 04:32 PM
  17. mert14's Avatar
    This is what I ended up finally doing... It's finally running like it should.
    What do you do if the DM won't allow for an update? The PlayBook connects to the network (I have actually tried 4 different networks), but it won't get past the country ID. I installed the DM on my laptop, plugged the PlayBook in via USB, the DM software says, "sorry, you need to complete the setup before you can continue". Ugg. How are you supposed to load it on from the DM if the DM needs you to finish the install on the PlayBook? Any help would be great.
    07-27-11 02:38 PM
  18. Trekker22's Avatar
    Hi, can I just say that I had the same problem as other people had with my brand new playbook, but by logging on here I found the answer and it is working fine. So, just wanted to say thanks. I bought the PB because of the enthusiastic review and advice from you folks, and although it's still downloading new updates, I'm already thrilled with it. Many, many thanks for Crackerberry. I'm late coming to Blackberry's but don't think I'll ever leave the family now.
    awindsr likes this.
    01-06-12 02:39 PM
  19. odetolamsl7's Avatar
    Bought my Pb over a year ago, ve upgraded to 2.0 already and am running android apps on it but i just did an update last weekend on my BP to version 2.0.10.358 but am stuck at the Id agreement page and its not allowing me pass the stage....this not nice....and there is no Blackberry support center in Nigeria
    07-26-12 09:25 AM
  20. Steve Nixon1's Avatar
    Did you ever find out the solution to this? I am hung up on the same problem. I want to reset but can't because the setup is incomplete. I want to completely reset so I'm stuck.
    08-04-15 09:45 AM
  21. Ailerumariam17's Avatar
    Bought my Pb over a year ago, ve upgraded to 2.0 already and am running android apps on it but i just did an update last weekend on my BP to version 2.0.10.358 but am stuck at the Id agreement page and its not allowing me pass the stage....this not nice....and there is no Blackberry support center in Nigeria
    Pls how do u solve this problem because am stuck too and also in Nigeria
    04-14-17 03:03 AM
LINK TO POST COPIED TO CLIPBOARD