1. cl8baller's Avatar
    Issue: BlackBerry PlayBook will not connect with Windows Vista.
    Using Windows Vista Business 32-bit
    I am currently running OS version 2.0.0.4869.

    BlackBerry PlayBook not detected as a mass-storage device or a BlackBerry connected device for that matter.

    Will not charge via USB cable.

    Using BBDS 7.0.0.32
    Using BDM 6.0.0.40
    BBDevMgr 4.2.0.15
    RIM USB Driver 4.2.0.14
    PlayBook RNDIS Driver Interface 1.0.0.36

    Assumptions:

    I am assuming the drivers simply cannot be found for some reason. The device is consistently being referred as RIM Network Device. In the Device Manager it is listed other "Other Devices" with an exclamation point next to it.

    Things tried:

    Security wipe.
    Uninstall and reinstall of BDM.


    Other notes:
    Please help me, please and thank you.

    UPDATE:

    Had just downgraded BlackBerry Desktop Software to 6.1.0.36

    Using BDM 6.0.0.40
    BBDevMgr 4.2.0.15
    RIM USB Driver 4.2.0.14
    PlayBook RNDIS Driver Interface 1.0.0.36

    -------

    I have seen the PlayBook be recognized as a RIM Network Device, RIM Disk Drive and BlackBerry Smartphone.

    When BlackBerry smartphone and RIM Disk Drive appears it eventually disappears and reappears as a RIM Network Device.

    ----------
    Currently on the phone with RIM technical support. Very kind.
    ---------------
    IMPORTANT UPDATE:
    Spoke with RIM technical support, turned off User Account Control under Usernames under Control Panel
    Turned off PlayBook, opened Desktop Software, had an error connecting with PlayBook, had the options to "Retry", "Update", "Cancel".

    I was instructed to hit Update, after two hours there was an error connecting the PlayBook when it was detected at first.
    Rebooted and found I had OS version 1.0.8.4985

    The same issues occur when powered on and connected as well as powered on and connected, cannot access mass storage driver, will not communicate with BlackBerry Desktop Software or an error pops up.

    ------------------
    Working with RIM support again. I am beginning to love their technical support, no sarcasm at all.
    Apple was great too, but about 2 out 3 I was just told to go to a store and send it in and they will replace it.
    Can't say much about Microsoft, best advice I have been given was to just upgrade my old junk. Good times good times.
    --------------
    Nothing new. They were about to do a data collection, I am running Windows Vista Business 32-bit. When looking we could not find a service pack number, this may be the issue, I was instructed I needed at least service pack two.

    I factory reset frequently so I usually do not update my Windows Vista unless needed. I run multiple computers and OS.

    Will report back later.

    -------------

    SOLVED
    The issue has been resolved. The issue was surrounding a number of optional Windows updates I have neglected.

    I f you have had this issue there you go. Check your Windows updates. When reading the updated descriptions, some had mention information about the USB controller.

    Note this solution was done with a 6.0 BlackBerry Desktop Software (not the 7.0 that was lekaed not too long ago) with the latest official BlackBerry PlayBook official OS.

    Downloading the 2.0 beta on to my PlayBook as I type the last of this in my BlackBerry PlayBook. Oh and it charges via USB when connected to my computer.

    The issues did not reappear when I installed the 2.0 beta.
    Last edited by CL8Baller; 12-04-11 at 05:43 PM. Reason: UPDATES
    12-02-11 11:30 PM
  2. Wbrian's Avatar
    Try turning off your wifi on the PB, then reconnect it to the PC. I think I recall that working for me a long time ago...

    HTH,
    Brian
    cl8baller likes this.
    12-02-11 11:36 PM
  3. cl8baller's Avatar
    Try turning off your wifi on the PB, then reconnect it to the PC. I think I recall that working for me a long time ago...

    HTH,
    Brian
    Hi Brian,

    With Wifi, Bridge and Bluetooth off and file share switch to on (or off). The error stills persists, although now it is being referred as RIM Disk Device.
    12-03-11 12:09 AM
  4. cl8baller's Avatar
    This is a serious issue, I have read around I am not the only one, tech support was not able to help the first time. And was downgraded.
    12-03-11 03:11 PM
  5. kill_9's Avatar
    12-03-11 03:25 PM
  6. Thomasrox3's Avatar
    I had a similar issue recently. When you connect the PB to your computer it creates a fake network that allows you to access your files, to fix this what you need to is locate the RIM Network drive in Network and Sharing-Change Adapter Settings open up the Properties menu. Click Install and click on Client for Microsoft Networks. This fixed that issue for me I hope it fixes it for you. Lemme know if you want me to create a series of pictures for you to walk you through.
    12-03-11 03:41 PM
  7. cl8baller's Avatar
    Yes I am. Also problem solved, I added what I had to do and what was the problem at the end of my original post

    I had a similar issue recently. When you connect the PB to your computer it creates a fake network that allows you to access your files, to fix this what you need to is locate the RIM Network drive in Network and Sharing-Change Adapter Settings open up the Properties menu. Click Install and click on Client for Microsoft Networks. This fixed that issue for me I hope it fixes it for you. Lemme know if you want me to create a series of pictures for you to walk you through.
    I will make note of this just in case something happens when I finish upgrading to 2.0. I have read about this working as well. Problem was solved, view my original post for more details.
    12-03-11 06:53 PM
  8. DavidM348's Avatar
    New PB owner here - great tablet!

    Also had connection issues with Vista, but per this forum, turning off PB wifi before connecting to PC solved the problem.

    Thanks for a great forum!

    -David
    01-05-12 09:32 PM
  9. EricB1968's Avatar
    BlackBerry Desktop connects with my PlayBook just fine on my PC that uses Vista
    01-05-12 09:50 PM
  10. jafobabe's Avatar
    New PB owner here - great tablet!

    Also had connection issues with Vista, but per this forum, turning off PB wifi before connecting to PC solved the problem.

    Thanks for a great forum!

    -David
    Great Post!! Glad you were able to resolve your issue..

    Welcome to the forums!

    Check out the Newbie Tips and Tricks for the Playbook, by clicking below my signature..
    It was compiled by the knowledgeable posters from this forum.

    Enjoy!
    01-05-12 09:57 PM
LINK TO POST COPIED TO CLIPBOARD