10-13-14 02:09 PM
32 12
  1. Marek S's Avatar
    Ive got similar problem with my Blackberry Playbook. I think I tryed everything, including directly charging battery - on multimeter it show it is 3,97V now, but the device still not starting up or charging... Tryed to hold power button for 20, 40 seconds, tryed to hold power and + button for 20 or 40 seconds, tryed to switching on charging via usb for 60 seconds for couple of times... completely NOTHING even no lights flash or anything... any suggestions? Can I do anything more about it?
    12-02-13 12:16 PM
  2. Marek S's Avatar
    Just would like to add... I measure voltage on battery and on dots on tape... battery - 3,98V dots - 1,11V ... battery 4,23V dots - 1,27V... should I try to charge battery until voltage on dots raise above 3,7 V?
    12-03-13 05:12 AM
  3. Notcho's Avatar

    I purchased a rapid charger and thankfully the led went straight from red to pulsing yellow the first time I put the playbook in it. I now have another problem which is that in an attempt to fix the playbook before I did a software update. Now the battery is stuck at 0% and it needs to be above 20% to continue the software update. What can I do to get the battery charging again?

    For future reference or if anyone else has the same problem I simply held the power button to turn the device off and it had the yellow pulsing LED again so I left it for about an hour before turning it on again and it now has about 31% battery and seems to be charging fine at the moment.
    Did the PlayBook dock charger work. I have the same situation, red light, battery lighting bolt, yellow-green light, repeat.

    Posted via CB10 on my ?Zed10
    01-10-14 03:44 PM
  4. brewman_trueman's Avatar

    either this should be made a sticky, or should go into the sticky that contains other links which used to/should be stickies...

    a couple of things make this article/write-up/thread post one of the best technical troubleshooting pieces i've read due to its detailed info, style, chronology and covering all possible scenarios. On top of that, there is a link of a KB article from RIM which provides a deeper insight into the charging mechanism and the software versions of the PB OS.

    If people having issues with the PB charging/powering up, then as opposed to wasting time and effort on other pages or articles, they should come here and read this one article that provides the entire scenario.

    That's all.

    ps: thanks to F2 for commenting and/or posting/reposting this article. Mapsonburt, awesome job!

    Take into closet or very dark room and make sure that there is no backlight even gray. It should be fully black meaning OFF.

    Locked, bricked Stack Charge Charging

    Another method to try:

    Try this....

    HOLD the power key for 20 seconds, after 20 Seconds do not let go of the power button and plug in the wall charger, and then let go... should get a steady red light for about 10 seconds, then the battery icon with lightning bolt should appear, after that the blinking green will appear and screen will go off.. now its charginggg..... lol wasted 4 hrs tyrign every other method, stack charging everything.... and this one worked for me...hope this works for everyone else


    More Mapsonburt (a pb user) who posted this info:

    Don't keep trying if you get the Red light/5 Yellows... you'll soon drag the battery down past where you can start it again. Leave it off, plug it in and let it charge (with at least a 1.8A charger). Once you get the flashing (once every few seconds) green light, you can power it up - on the charger. If you do drag it down below the red flash/5 yellows, plug it in for 1 minute, unplug (at the wall) for a second or so, plug it back in and repeat for 20-30 minutes. You'll eventually get the red/yellows and then leave it plugged in (and off) until you get the flashing green. It's a PITA but the PlayBook has a very conservative charging algorithm when the battery is below 2.67 Volts to prevent explosions (I'm guessing). I've never been unable to start one with that method.


    The PlayBook OS currently shuts down at 3.5 volts. When the battery gets below 2.67V it won't show power lights or even try to start because there isn't enough juice to even power the processor to run the code on the BIOS. The BIOS is software hard coded on a chip within the PlayBook that tells it how to load the PlayBook OS and is coded such that it only recognizes signed PlayBook boot images (which is why it is so hard to root and that nobody has been able to get one to boot Android or WebOS. The BIOS software also contains some charging algorithms for when the OS is not running - ie device is powered off but plugged into a charging source. This code ONLY runs when the battery is above 2.67 volts because the processor can't run below that.

    The root of the problem is that this design issue prevents the device from accepting any charge longer than 60 seconds when the battery is too low to run the charging algorithms on the BIOS or on the OS (one runs before the device is powered on and one runs afterwards). RIM did this because Lithium Ion batteries have a nasty habit of catching fire if not charged properly so they wanted to ensure that the processor could be in control of the charging. Makes perfect sense and they probably thought they were avoiding situations like where early Li Ion batteries on laptops were catching on fire. The problem is they were a bit too aggressive in dealing with the problem at design stage. If the battery is below 2.67Volts their protective algorithms can't run but you also can't put enough charge into the battery to charge it! Hence all the reports of people having success with stack charging.

    Unfortunately there are a lot of wrong ways to do this floating around out there and getting repeated everyone someone posts a new thread on the issue. It really should be made a sticky. What is the right way?

    1) ONLY use a source that provides 1.7Amps or more of charge. The original charger provides this. The rapid chargers provide a lot more. Your phone charger only provides a fraction of this. Anything less is going to take forever to charge the battery above 2.67 volts and may not have enough juice to charge the battery AT ALL once the processor starts to run above 2.67Volts or even worse once the OS starts to run above 3.5Volts. Forget about using your computer to charge it when the OS isn't running as the computer looks for the hardware to identify itself and won't put out a full charge current unless the device indicates it can accept. Once the OS is running, you'd often CAN get enough power from the USB on the computer but that is because the OS has signaled it is OK for the computer to send it. When the OS/BIOS isn't running, the PlayBook won't take much/any charge from a computer. The rapid chargers are best as they quickly charge but more importantly do not use the (too) flimsy USB port. A lot of problems are caused by this port getting wobbly over time and the device not getting a charge at all. Everyone should have a rapid charger.

    2) Until you get your device WELL above the 3.5Volts that let's the PlayBook boot, do NOT try to start it. Every attempt drags the battery down some more and that attempt sucks much more charge from the battery than you can put in in those 60 seconds before the hardware shuts down the charging. How can you tell where your battery is? Well if you are getting no lights on the playbook on your first charging attempt you are below 2.67volts. If lights go on and then it doesn't start the OS it is below 3.5Volts. If it loads the OS and then dies it is just above 3.5Volts. If the device loads the OS it is somewhere below 5.0Volts. Depending upon where you start (how low the battery is) various techniques work best. They are: REAL stack charging (plug in for 60 seconds, unplug, plug in for 60 seconds, repeat until the processor starts accepting charging (the big battery symbol on the screen). Again, DO NOT try to turn the device on until then. You are just working against yourself and it will take much longer. You should get the charging symbol within 20-45 minutes of repeated REAL stack charging. Forget you ever heard of plugging in for 2 mins and then off for 2 mins and similar as those 2 mins of off time are COMPLETELY worthless. I have put a multimeter on the PlayBook in this state and it NEVER takes more than a minute of charge when under 2.67volts but will accept another minute of charge after a short (1-2 second) disconnection. Just do it right.

    3) Once you see that charging screen leave it plugged in to the charger (stop stack charging) for at least an hour before you try to start the PlayBook. If you don't you may end up in a situation where the attempt to start drags that battery back down below 2.67V and you have start stack charging again. Be patient, you are almost there!

    4) Fully charge your Playbook after this to ensure your PlayBook gets back to 100%.

    Unfortunately, there isn't a lot RIM can do about this now. It's a hardware design issue. I'd be interested in knowing if the fixed it with the 4G versions. I don't think I've ever seen that complaint with one of those but I've "fixed" both of mine a few times (the kids keep trying to power them on after letting them shut down on low battery despite me saying time RUN not walk and put it on a rapid charger when ever it hits the flashing red battery signal (9%). I've also helped many friends and people on the web and NOBODY who has followed the instructions has failed to get their PlayBook to charge.

    I'm convinced this fault is the reason so many PlayBooks are returned to the stores and through RMA. RIM has been very good about this but it should never have happened. Happy Charging!

    The battery is likely below 2.65 volts. That happens if the PlayBook has sat for a while. Plug your charger into the playbook (make sure it's the stock charger and not a computer or other charger as you need to pump in lots of amps - more than 1.7amps - the more the better). The rapid charger is even better as it can go to 5 amps.

    LEAVE the charger plugged into your PlayBook. Unplug it from the wall (to save the fragile micro-USB port) every minute for a few seconds and plug back in. You'll see lots of references on the web to plug in for 2 minutes and unplug for 2 minutes. Ignore those. I took the PlayBook apart and put a multimeter on mine when it was doing this. If the battery is below 2.65 volts, the PlayBook charging circuit charges for about 1 minute and then shuts down. NO AMOUNT of continued charging makes any difference. As soon as you unplug it (at the wall) and power it back up, it will take charge again for another 45-60 seconds. Repeat.

    Keep doing that for as long as it takes to get the screen to show the charging display. If it is just below 2.65volts, it will take somewhere between 20-45 minutes as the battery only takes a little bit of charge each cycle and you need to get that voltage up over 2.65 volts (at which point it will show the charging display and take a full charge). It may take more... but keep at it. Every time you plug it in for 60 seconds, you are adding a bit more power to the battery.

    DO NOT try to power the device on until the device has a full charge. You will just risk getting it into a situation where it can't fully boot before it drags the charge down below 2.65 volts again and you'll have to start all over.

    This works... and saves you from having to jump start it like I did the first time I got mine into this situation.


    KB27705-BlackBerry PlayBook battery power charge, discharge characteristics, and guidance on extending battery life
    09-06-14 07:55 PM
  5. jhimmel's Avatar

    either this should be made a sticky, or should go into the sticky that contains other links which used to/should be stickies...
    I have brought my Playbook back from this state several times through "stack charging", but that is by far the best explanation of the issue that I have seen so far. Thanks.
    09-06-14 09:25 PM
  6. krsashley's Avatar
    My playbook will not charge. I've been stack charging -switch on for 60sec then off- for hrs. nothing. Starting to think the usb port is bad. because I always had to wiggle it to get it to connect. I've ordered a rapid charger, but It will take at least a week. any other options?
    10-13-14 11:32 AM
  7. krsashley's Avatar
    OMG. I fixed it. after 2 days of stack charging & ordering a rapid charger. which is still worthwill.

    The metal piece in the center of the usb port was misaligned. I delicately centered it with a pin and it worked!
    10-13-14 02:09 PM
32 12

Similar Threads

  1. Replies: 15
    Last Post: 11-14-13, 09:35 PM
  2. I just installed .1791 on my Z30 and it wont boot, get error bb10-0004
    By playbookster in forum BB10 Leaked/Beta OS
    Replies: 19
    Last Post: 11-08-13, 07:56 PM
  3. Scanning a location to Blackberry Maps using QR Codes?
    By Neil in West Jersey in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 11-02-13, 07:10 AM