1. AnonymousBruddah's Avatar
    I've had my bby playbook for 1 year now and I don't know why but I went to connect files to it lately and it wouldn't connect when I used a official blackberry USB. I ordered another for playbook on amazon and it now connects but will only connect via file sharing and not as a USB mass storage device. I don't know why as am using Mac OSx Yosemite? So I managed using file sharing to delete some videos but when I try and add new ones it says they're in use and the operation can't be completed but the files aren't in use? Can anyone help. I have the latest blackberry manager and link and no luck. Seemingly it disconnects and connects itself when it wants to PC too
    11-09-14 01:09 PM
  2. howarmat's Avatar
    I am guess it could be a Yosemite issue and that BB needs to update the software but not sure. USB port also sounds like it might be shot
    11-09-14 10:57 PM
  3. tovento's Avatar
    Did playbook ever connect as USB mass storage device? Under windows, this was not an option. Always connected as a network drive (only with the drivers installed). You can try and connect to your device through the wifi (assuming you are connected to the same network). Don't need to have the BB drivers installed for that.

    (video for pc, but should be the same rough idea to connect to the mac)

    FAQ: Transfer Files to the BlackBerry PlayBook Over Wi-Fi or USB - BerryReview
    11-10-14 12:33 PM
  4. AnonymousBruddah's Avatar
    Hi well I don't know how the USB could have gone as only a few month before i managed to connect it and put stuff on it fine. But now since yosemite it seems to not work. I haven't tried it on windows 7, but i have bb link and bb desktop manager both the latest version installed. I've since managed to transfer files using wifi i believe..a number comes up which is the pb in devices and then i can transfer stuff over, but oddly sometimes i get a weird error that the file is in use when its not..but mostly its worked. Does anyone know if it is a yosemite OS X issue or if there is some site i need to download the bb playbook driver from? I checked my pb and its latest software too. USB wise it says its connected to the computer..but doesn't come up as a USB..an pb manager now recognises it too and does backup etc
    11-13-14 11:05 AM
  5. tovento's Avatar
    Could be the USB port...it's a known weak spot on these devices. I'm at 2 years of having this thing without issue and I charge it via USB on almost a daily basis. Coworker has an older unit, but the USB is shot. (got him to buy one of the magnetic chargers for cheap) Anyhow, my point is to test it on the windows computer you have access to. It'll quickly show you if its the USB port or Yosemite.
    Last edited by tovento; 11-17-14 at 08:03 AM.
    mh1983 likes this.
    11-13-14 12:05 PM

Similar Threads

  1. Replies: 29
    Last Post: 12-12-14, 08:38 AM
  2. help with installing snap
    By jensenpark in forum BlackBerry Z30
    Replies: 15
    Last Post: 11-10-14, 07:18 PM
  3. New Z10; battery tips, apps recommendation please!
    By Andrew Sheil in forum BlackBerry Z10
    Replies: 7
    Last Post: 11-10-14, 02:53 AM
  4. BlackBerry OS10 Devices.
    By Rameez Moiz in forum Ask a Question
    Replies: 2
    Last Post: 11-09-14, 07:10 PM
  5. Five Things Apple Could Learn From BlackBerry About Phone Design
    By TCB on Z10 in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 11-09-14, 01:33 PM
LINK TO POST COPIED TO CLIPBOARD