01-27-15 01:24 AM
111 ... 345
tools
  1. jpash549's Avatar
    Hey my daughter was using her blackberry using it while charging it and now the charger cord won't work either the inside is broken not charging it plus I'm lost so help me please
    Your daughter could have plugged the PB in upside down thus damaging the micro USB type ab port. Look for posts by ChaddFace on how to repair and inspect. The official PB charging cord must be plugged in with the Blackberry symbol up which puts the long side of the trapezoidal male plug down as you look at the screen.The PB charging cord has the data wire pair shorted together. The HP TouchPad has a similar arrangement and that charger can be used with the PB. Others have reported obtaining charger wires from AT&T stores or you could make one from a regular micro USB cord by connecting the data wires together. Place a fingernail polish dot on the side that is supposed to be up on the male plug to prevent accidents. Better yet get a charger that uses the magnetic plugs as others have suggested.
    02-02-14 11:14 AM
  2. Marionfrances's Avatar
    I had the same problem but after a night on the charging pod the problem was solved.
    02-03-14 11:01 AM
  3. Sami Altouqi's Avatar
    hello dear,

    my playbook is dead, i dont get any lights when i try to turn it on.. its not charging at all.. please help
    04-11-14 10:45 AM
  4. kwelamnp's Avatar
    Thathas happened to me several times. Even although battery is down to only say 50%, the PB goes dead and nothing works. Plug in. Harger and no charging light.

    But, if i left it plugged in ovdrnight, it somehow recovers and works normally. I have learned to keep it charged and not let it get below about 60%.

    I have a high speed charger as well as a charging stand. I dont use the low speed charger that came with the pb. Connector can be troublesome.
    04-11-14 12:30 PM
  5. oldyellr's Avatar
    hello dear,

    my playbook is dead, i dont get any lights when i try to turn it on.. its not charging at all.. please help
    That happened to my son a year or two ago. He'd left it in a discharged state for too long I guess. We searched for all kinds of ways to revive the battery, "stack charging", etc, but nothing worked. I then found a Playbook Rapid Charger on clearance, the one that uses the magnetic connector, not the USB connector, and tried that and it worked. The rapid charger has a higher capacity than the standard one and the battery won't get killed by the operating system loading. You can still find those chargers on Amazon quite cheap.
    04-11-14 12:57 PM
  6. Masterherm's Avatar
    Thanks for posting this solution.It actually works and it also makes logical sense.
    08-09-14 02:29 PM
  7. damianiw's Avatar
    Very similar scenario (but cable was 100% in the right way) daughter was using it battery remaining had lightning bolt showing charging but 2 hrs later playbook said shutting down.

    This is using the charger which came in box with playbook, orange end, 2amp rating - I've tried stack charging and always get to it even after an hour red light, no light, battery on display, no display, orange flashing light then no light then playbook boots and dies during the boot sequence.

    So either the port is damaged (useless port I returned my playbook in extended store warranty and ended up with an android tablet same problem on usb port thought!)

    The charger isn't giving the full 2amp any more

    Or the battery is useless, this playbook has had little use as she changed to an android phone so it comes out when we travel as for watching films its an amazing device - good speakers, screen and battery (before this!).

    The rapid charger / stand which use the 3 pin magnetic port are going to cost me about 12 in the uk so I need to gamble on it being the charger/port not battery

    Before I came away I noticed I couldn't get the battery above 88% which was unusual - same charger.

    Did you have same problem - ie died plugged in even though said charging ? If so ill give it a gamble if not save the 12 and bin the playbook

    Main problem now will be if I can get It back home as new rules mean it has to be charged and shown working at airport so will have to wrap in many clothes in case and hope it doesn't get broken!



    Regards

    Damian
    08-10-14 03:57 AM
  8. damianiw's Avatar
    Well got it home and plugged it in, damn thing turned on ok but oddly shows zero percent charge and no charging lightning bolt, I've ordered the rapid charger so will see what happens when that arrives - may do a security wipe if it doesn't solve it maybe a corrupt default somewhere

    Regards

    Damian
    08-19-14 05:17 PM
  9. pmcguigan's Avatar
    This worked for me. Tried all other methods and could not get it to charge. Then used a plastic pic to move the plastic piece down and the charger fitted correctly. I knew it did not feel correct the other way. Now it is charging on first attempt and even powered on first time. Will not be lending this tablet to anyone again!!

    Thanks again.
    mh1983 likes this.
    11-12-14 02:36 PM
  10. bernie toal's Avatar
    thank you very much after working with my pb for 5 hours this was the solution as my charger would only work upside down so I used plastic knife an moved the inside of the usb port now to find it charging
    Nu Nguyen likes this.
    01-01-15 06:42 PM
  11. Nu Nguyen's Avatar
    Cound you give me some image about this step? and when it charging, what's the indicator on Playbook, and how long it't full charged ?? . I do that step but now on my PB the green (stand) indicator and it's not turn on. What can i do next step !!! Thanks very much..
    01-27-15 01:24 AM
111 ... 345
LINK TO POST COPIED TO CLIPBOARD