1. Jonathan Guzman's Avatar
    Hi guys, I've been having some issues with my Playbook, first off the stock charger does not charge at all, now I don't think the problem is my charger, since I now use it for my cellphone and it works just fine, and I know my playbook detects it, I put my Playbook on standby and connect it and it lights up, but it doesn't charge and doesn't give any error message.

    After realizing all of this, I went looking for another charger to see if that would work, I did find about 5 other chargers all with the same result, it detects it, but I don't get that lightning symbol, I get a plug symbol which charges a lot slower and practically doesn't charge while I'm using it, so since I incidentally had another BlackBerry charger, I've been using that, but it's really annoying, so I'm hoping someone knows the problem and how to fix it.

    P.S. I've also cleaned both the port and the chargers already
    02-02-13 08:56 PM
  2. jcbrunson's Avatar
    Have you hard reset your Playbook? Hold pwr + volume down + volume up all at the same time. Report back your results and we'll try to help. Also search the threads for charging issues. We have years of answered playbook problems here.
    Jonathan Guzman likes this.
    02-02-13 09:56 PM
  3. xamdam's Avatar
    It sounds like a defective charging port i would call blackberry support
    Jonathan Guzman likes this.
    02-02-13 09:58 PM
  4. Jonathan Guzman's Avatar
    I just tried it and it still doesn't work, although this time when I booted up my playbook th led flashed white for half a second

    Edit: I left the charger on for some reason and after a while, it started charging normally again, thanks.
    Last edited by Jonathan Guzman; 02-02-13 at 10:35 PM. Reason: Update
    02-02-13 10:20 PM
  5. Jonathan Guzman's Avatar
    Thanks but, that and a system wipe/reset are the things I'm trying to avoid
    02-02-13 10:24 PM
  6. kbz1960's Avatar
    Rapid charger. BTW 3 finger salute does no more than restarting your PB, it doesn't delete or remove anything but sometimes corrects issues.
    Jonathan Guzman likes this.
    02-02-13 10:40 PM
  7. jpash549's Avatar
    Phone chargers don't usually put out enough current which I think is the meaning of the plug symbol which means you got it plugged in but the battery is losing charge to the running system. Same thing with plugging into a laptop USB port. The playbook standard charger supplies about 1.8 amps while the rapid travel or dock chargers supply about 2.4 amps for charging plus extra to run the system. Battery Guru app will help you get fairly quick readings as to what is going on. Readings are taken every two minutes and when you plug in a charger you get an immediate indication if it is working.
    02-03-13 01:04 AM
  8. jcbrunson's Avatar
    Thanks but, that and a system wipe/reset are the things I'm trying to avoid
    Oh no, the hard reset is like a battery pull. We won't suggest a wipe unless something is really wrong. Kbz1960 is right - go get a rapid charger that plugs into the three tiny magnetic posts on the bottom of your Playbook. Glad to hear that it's working for you now.
    02-03-13 06:12 AM

Similar Threads

  1. Blackberry playbook dead and not charging
    By jayswap523 in forum BlackBerry PlayBook
    Replies: 20
    Last Post: 06-23-13, 01:33 PM
  2. Blackberry Playbook Charging Problem
    By Laruhhh in forum BlackBerry PlayBook
    Replies: 37
    Last Post: 02-02-13, 04:37 PM
  3. Blackberry playbook charging problems
    By vanessaxx in forum BlackBerry PlayBook
    Replies: 18
    Last Post: 04-01-12, 08:36 PM
  4. BLackBerry PlayBook in trouble!!!
    By kidcalis in forum General BlackBerry Discussion
    Replies: 9
    Last Post: 08-18-11, 05:41 AM
  5. BLackBerry PlayBook in trouble!!!
    By kidcalis in forum BlackBerry PlayBook
    Replies: 9
    Last Post: 08-18-11, 05:41 AM
LINK TO POST COPIED TO CLIPBOARD