1. esqlaw's Avatar
    Okay so I got my playbook day one, in case that matters for anything. Original day 1 model... anyway. Battery worked great until recent. I was away for a little bit and my playbook saw no usage or recharging (a first since I bought it) and the battery was dead for several days. Maybe 2 weeks, a month tops. But now the thing won't charge at all. I have tried doing a search on the forums, but can't quite find an answer or the exact same issue so pls don't bust my balls if this is a common or easily fixed issue. I'll probably try to get some official support but I figured maybe the crackberry community could help out some.

    Here is what happens when I plug into my quick charge stand.... nothing. No lights or anything. Anyway, that thing has been an issue from day one but lets put that aside.

    Now I use a mini/micro w/e charger and the light pops on red for about 15-30 seconds and then goes out. I kept it on the charger for several hours once and no dice tho. I was kinda busy and didn't do anything with it (sat it on the stand charger) for several days and well, I am trying to usb charger again.Just now I am noticing it flash yellow every once in a while... Gonna keep it on overnight. Maybe try booting once or twice in 30-60 minutes.

    So whats up? Any ideas? Even though I've owned the thing since day 1 I don't know how the light indicators work for charging. Any help would be appreciated.
    10-12-12 01:42 AM
  2. esqlaw's Avatar
    BTW I swear before I started writing this post I never saw a yellow blinking light when I had it sit on the usb charger... now hopefully it will be fine once it turns green.
    10-12-12 02:03 AM
  3. esqlaw's Avatar
    Yay, weirdly enough now it works. Please close thread. I can't believe it starts working once I look for help... because I almost gave up on it after a week or two.
    10-12-12 02:18 AM
  4. FF22's Avatar
    Good to hear you got over the charging hump.
    10-12-12 12:03 PM
  5. DC506's Avatar
    It's just like taking your car to a mechanic, but the problem fixes itself before your appointment

    Glad all is well now.
    10-12-12 05:27 PM

Similar Threads

  1. Replies: 7
    Last Post: 12-02-10, 09:20 AM
  2. Sync and Indicator Light Issues...Please Help!
    By matt_1984 in forum BlackBerry Pearl 81xx
    Replies: 1
    Last Post: 01-07-08, 06:22 PM
  3. Email Issue... Please Help...
    By seanerin in forum BlackBerry Curve 83xx
    Replies: 2
    Last Post: 12-20-07, 09:44 AM
  4. Im New and have Browser Issues.. Please Help? :)
    By hugyourstereo in forum BlackBerry Curve 83xx
    Replies: 4
    Last Post: 12-09-07, 01:23 PM
  5. Media issue please help!?!?!?!
    By suburbanswrvyn00 in forum BlackBerry 8830 WE
    Replies: 1
    Last Post: 11-01-07, 09:09 AM
LINK TO POST COPIED TO CLIPBOARD