1. Greenknight66's Avatar
    Hi all,

    I've got an interesting problem with my Playbook. It's not crippling, so I've lived with it for a while. Nonetheless, it gets on my nerves, and I'd like to know if there is a way to fix it.

    Whenever I download an app in the App World (either a new app, or upgrading an existing app), the "Downloading..." meter appears, and shows completely out-to-lunch numbers. For example:

    "2 GB/325 MB"
    tick
    "4 GB/325 MB"
    tick
    "127 MB/325 MB"
    tick
    534 MB/325 MB"
    etc., etc.

    With this happening, the progress bar stays empty, so I never really know how much progress has occurred. I've tried it on multiple Wi-Fi networks, and have re-entered my Blackberry ID in the Playbook's settings, to no effect.

    Worst-comes-to-worst, I can live with it. But I don't like leaving any problem like this un-diagnosed.

    Any ideas?
    10-23-13 10:18 AM
  2. jpash549's Avatar
    It's only a problem if you choose to look at it as one. Google Play does the same type of thing on my Nexus 7. The behaviour varies with showing steady progress and others showing a few per cent download and then saying installing. Computers will drive one up the wall with their inhuman behavior.

    Sent from my Nexus 7 using CB Forums mobile app
    10-23-13 12:31 PM
  3. Greenknight66's Avatar
    I think there might be a little confusion here... I wouldn't be concerned if it looked like it had just downloaded a chunk of data too quick for me to see. I'm concerned because it's reporting that it has downloaded vast quantities of data, above what it should need to complete the download.

    Let me try to clarify using my previous example:

    "2 GB/325 MB" = 630% (note the GB versus the MB)
    tick
    "4 GB/325 MB" = 1260% (note the GB versus the MB)
    tick
    "127 MB/325 MB" = 39%
    tick
    534 MB/325 MB" = 164%
    etc., etc.

    The values that get reported appear random, and very large, and rarely do they go below 100% of the download's size.

    Make sense?
    10-23-13 02:37 PM
  4. MiSsY_'s Avatar
    Are you on the most up to date version of the PBOS?

    Posted via CB10 from my Z10
    10-23-13 02:56 PM
  5. jpash549's Avatar
    You are right I was confused. When the dust has cleared ard the downloaded files apparently of the correct size?
    10-23-13 03:31 PM
  6. Greenknight66's Avatar
    @MiSsY_: I'm on version 2.1.0.1753, which I believe is the latest OS version.

    @jpash549: Well, this occurs when installing apps in App World, so the only measure I have for the file's size is whether the installation is successful, which it usually is.

    Short answer; yes, it works.

    That's why I said I can live with it if necessary; because the downloads/installations still appear to work. But it's a weird behavior to see, and I'd like to fix it if possible.

    Now that I think a little more about it, this same thing happened to me about a year ago at this time. I don't think I did anything explicit to resolve it; it just went away (I may have installed an OS update, after which it stopped, but I don't recall for sure). About a month ago it started happening again.

    One common factor I remember that may have influenced it; on both occasions, my PB had flat-lined the battery. I just put it on the charger and it came back to life no problem (despite the battery-meter staying at 0% for a couple hours solid). I don't see how that would affect App World download metrics, but I thought I'd mention it, since it's common to both occurrences.
    10-24-13 10:26 AM
  7. MiSsY_'s Avatar
    I wonder if it would happen if you download while connected to the charger?

    Posted via CB10 from my Z10
    10-24-13 02:49 PM
  8. Greenknight66's Avatar
    Tried it both on and off the charger. Same thing in both instances.

    It's just such weird behavior... it's like the file-system isn't reporting the correct numbers to the App World download screen. The system knows how big the file is supposed to be (so the "/325 MB" part is correct), but when it asks the file-system how big the file currently is, it gets a nonsense answer, and, not knowing how to handle it, it just reports it on-screen.

    I have the "AIR Browser" free app installed to look at my file-system... maybe that has modified how the file-system is talking to apps, or something.

    Honestly, at this point, I'm just grasping at straws. I'm frankly at a loss. It won't stop me from using my Playbook, but it's one of those weird issues that (as a programmer) will nag at me constantly until it's fixed.

    But hasn't anyone else seen this issue before? I find it hard to believe that mine is the only Playbook that does this.
    10-25-13 07:59 AM
  9. MiSsY_'s Avatar
    Sorry if this is a silly question but Have you tried to hard reboot the PB?


    Posted via CB10 from my Z10
    10-25-13 03:39 PM
  10. jpash549's Avatar
    And I suppose you have refreshed your app list. Might also use Advanced App Manager and check for any lurking Android ports. We always like to blame them.
    10-25-13 04:02 PM

Similar Threads

  1. Animated gif for BBM app
    By magsasaka in forum BlackBerry 10 Apps
    Replies: 7
    Last Post: 10-27-13, 08:10 AM
  2. Couple of App issues
    By AWB70 in forum PlayBook Android App Sideloading
    Replies: 7
    Last Post: 10-24-13, 06:45 AM
  3. How to set messages to download automatically?
    By Valdar729 in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-23-13, 03:27 PM
  4. Z10's app world has <game dev story>?
    By u4n in forum BlackBerry Z10
    Replies: 3
    Last Post: 10-23-13, 02:17 PM
  5. Downloading ALL my gmail
    By MGO in forum BlackBerry Q10
    Replies: 3
    Last Post: 10-23-13, 11:47 AM
LINK TO POST COPIED TO CLIPBOARD