10-18-13 03:01 PM
52 123
tools
  1. Hirazi Blue's Avatar
    Back with some observations. I ran 5 more android apps. Only one did not run, nogago maps. But I don't recall the last time I ran it.
    The scenario I am facing, sadly, has nothing to do with malfunctioning single side-loaded apps, but with a total failure of the Android runtime, resulting in the inability to run any side-loaded apps, apps I have used often enough before to know they should work...
    10-14-13 09:39 AM
  2. ChrisMay's Avatar
    After the most recent update I was quite content, as it brought back my ability to remember "saved networks". For no clear reason this ability has gone again, but I can reluctantly work around that (have been doing that for months now). Way more problematic is the fact, that my Android runtime has stopped working altogether, even after many (hard) reboots. It just hangs at a black screen with a BB logo on it, or just a black screen. How do I fix this, preferably without a security wipe? And if it must be a security wipe: please tell me, how to save my newly acquired commercial Kalemsoft app in such a process.
    Just to be clear, by this, you mean the one where you hold the power key and the up/down volume keys all down together, and the PB powers straight off (without the 'Shutting Down' message) and immediately reboots (red led comes on). I had a big problem with Android Runtime once (before this update, mind) and had to do this to get it working. Normal Power Off/Shutdown/Restart didn't work.

    The other obvious question, is have you sideloaded or run any 'new' apps since the last time it worked properly. In fact, have you done ANYTHING different since the last time it worked properly??
    10-14-13 10:18 AM
  3. sad_old_man's Avatar
    The scenario I am facing, sadly, has nothing to do with malfunctioning single side-loaded apps, but with a total failure of the Android runtime, resulting in the inability to run any side-loaded apps, apps I have used often enough before to know they should work...
    Non parametric end users, I don't know. Just stick to your abacus!

    Posted via CB10
    10-14-13 10:19 AM
  4. Hirazi Blue's Avatar
    Just to be clear, by this, you mean the one where you hold the power key and the up/down volume keys all down together, and the PB powers straight off (without the 'Shutting Down' message) and immediately reboots (red led comes on). I had a big problem with Android Runtime once (before this update, mind) and had to do this to get it working. Normal Power Off/Shutdown/Restart didn't work.
    I've tried both methods of resetting the device.

    The other obvious question, is have you sideloaded or run any 'new' apps since the last time it worked properly. In fact, have you done ANYTHING different since the last time it worked properly??
    Two days prior to this failure I installed the Kalemsoft Media Player, I installed nothing else, but I don't think this to be directly related as one would have expected the stuff to hit the fan earlier in that case, certainly not after two days...
    Last edited by elite1; 10-14-13 at 07:50 PM. Reason: Removed profanity
    sad_old_man likes this.
    10-14-13 11:03 AM
  5. ChrisMay's Avatar
    I've tried both methods of resetting the device.


    Two days prior to this failure I installed the Kalemsoft Media Player, I installed nothing else, but I don't think this to be directly related as one would have expected the sh*t to hit the fan earlier in that case, certainly not after two days...
    As far as I understand it, the Kalemsoft player is native anyway, so certainly shouldn't affect the Android player...(??)
    sad_old_man likes this.
    10-14-13 11:09 AM
  6. ChrisMay's Avatar
    I've tried both methods of resetting the device.


    Two days prior to this failure I installed the Kalemsoft Media Player, I installed nothing else, but I don't think this to be directly related as one would have expected the sh*t to hit the fan earlier in that case, certainly not after two days...
    Have you checked the spare memory (Setup->General->Hardware). The only other time I had problems of this type (though not as severe as yours sound) with Android Runtime was when some dodgy app was consuming all the spare memory...
    sad_old_man and Hirazi Blue like this.
    10-14-13 11:12 AM
  7. Hirazi Blue's Avatar
    Interesting. Must check that. Thanks!
    10-14-13 11:14 AM
  8. sad_old_man's Avatar
    Have you checked the spare memory (Setup->General->Hardware). The only other time I had problems of this type (though not as severe as yours sound) with Android Runtime was when some dodgy app was consuming all the spare memory...
    Pppssssssttttt hey cat with the gorgeous eyes.............don't worry about it, the little dutch thingy has never been the same since the shipwreck. (he actually ate his entire crew you know, all 75003 of them).

    Anyway the cat and the duck and the gooseberry will be along shortly to sedate him!
    ChrisMay likes this.
    10-14-13 11:17 AM
  9. Hirazi Blue's Avatar
    @ChrisMay - After some - apparently much needed - cooling-off I have decided to give this another (probably final) go`. But I cannot seem to locate the "Setup->General->Hardware" page/tab you mention. Could you please point in the right direction? Must be something silly I'm overlooking. Before I lost my Android runtime I used an Android app to gather such data for me...
    sad_old_man likes this.
    10-16-13 09:20 AM
  10. sad_old_man's Avatar
    @ChrisMay - After some - apparently much needed - cooling-off I have decided to give this another (probably final) go`. But I cannot seem to locate the "Setup->General->Hardware" page/tab you mention. Could you please point in the right direction? Must be something silly I'm overlooking. Before I lost my Android runtime I used an Android app to gather such data for me...
    Oooohhhh ooooohhhhh let me, let me please dutch thingy........iz good at directions I iz......you first turn left at Amsterdam right.......then look for the angel holding a goldfish bowl right......just after that you'll see a bar called the drunken toadstool (DO NOT GO IN THIS BAR).......a bit further on you turn right then left, right and then it's there!

    Good ain't I?
    10-16-13 09:41 AM
  11. Hirazi Blue's Avatar
    Oooohhhh ooooohhhhh let me, let me please dutch thingy........iz good at directions I iz......you first turn left at Amsterdam right.......then look for the angel holding a goldfish bowl right......just after that you'll see a bar called the drunken toadstool (DO NOT GO IN THIS BAR).......a bit further on you turn right then left, right and then it's there!

    Good ain't I?
    As you are very rarely annoying in any way, I'll let this one slide...
    sad_old_man likes this.
    10-16-13 09:49 AM
  12. sad_old_man's Avatar
    As you are very rarely annoying in any way, I'll let this one slide...
    Mutter......mutter.......sulkin now...........just cants helps some people's......mutter....mutter
    10-16-13 10:03 AM
  13. FF22's Avatar
    @ChrisMay - After some - apparently much needed - cooling-off I have decided to give this another (probably final) go`. But I cannot seem to locate the "Setup->General->Hardware" page/tab you mention. Could you please point in the right direction? Must be something silly I'm overlooking. Before I lost my Android runtime I used an Android app to gather such data for me...
    I'd leave Amsterdam for Florida - well, I wouldn't but ....

    Open Settings, Select ABOUT. Use the dropdown kind of on the right to move from General to Hardware
    Hirazi Blue likes this.
    10-16-13 12:23 PM
  14. Hirazi Blue's Avatar
    Completely overlooked it, thanks. Would free memory of 494.9 MB be reason for concern?
    And where do I go from here?
    10-16-13 12:35 PM
  15. FF22's Avatar
    Completely overlooked it, thanks. Would free memory of 494.9 MB be reason for concern?
    And where do I go from here?
    That should be enough memory to open/run one android app. What app(s) are you having problems with? All? If so, then a OS reload may be in order and I don't envy that. There are were a few MEMORY eating apps including Android Reset. I don't recall what's free and what costs? Or you can force it yourself - just keep opening apps and more apps until the pb implodes its apps ability.
    10-16-13 12:41 PM
  16. Hirazi Blue's Avatar
    At the moment it doesn't seem to start ANY of my side-loaded apps. Now I was thinking as some Android apps seem to get started at bootup, if there is a NATIVE way to get to the processes running at startup to purge that list?
    10-16-13 01:22 PM
  17. pacoman03's Avatar
    Now I was thinking as some Android apps seem to get started at bootup
    I don't believe that any android apps get started at bootup. Is it only sideloaded apps that don't work, or do android apps installed from app world also not work?
    10-16-13 02:59 PM
  18. Hirazi Blue's Avatar
    I don't believe that any android apps get started at bootup. Is it only sideloaded apps that don't work, or do android apps installed from app world also not work?
    At the moment neither kind are working...
    10-16-13 03:08 PM
  19. pacoman03's Avatar
    At the moment neither kind are working...
    Sounds like it's security wipe time for you. If you're not inclined to go that route (yet), you might try uninstalling all of your android apps, and then reinstalling and testing them one by one. It's possible that you have one offending app causing your problems, and if so you need to narrow things down to isolate it.
    FF22 and Hirazi Blue like this.
    10-16-13 03:19 PM
  20. Hirazi Blue's Avatar
    Sounds like it's security wipe time for you. If you're not inclined to go that route (yet), you might try uninstalling all of your android apps, and then reinstalling and testing them one by one. It's possible that you have one offending app causing your problems, and if so you need to narrow things down to isolate it.
    Next order of business: uninstall all Android apps (to get the Android runtime running again, the irony). Luckily there aren't all that many. Thanks for the suggestion.
    sad_old_man likes this.
    10-16-13 03:28 PM
  21. sad_old_man's Avatar
    Next order of business: uninstall all Android apps (to get the Android runtime running again, the irony). Luckily there aren't all that many. Thanks for the suggestion.
    pssssst......hey dutchy thingy, iz back!!!!!! glad to see mees?
    10-18-13 10:49 AM
  22. Hirazi Blue's Avatar
    @sad_old_man - in one word: ecstatic!
    @pacoman03 - Thank you so very much. The uninstalling of all side-loaded apps followed by the individual reinstall of the 3 deemed most important seems to have worked (for the most part). Sometimes even now the Android runtime fails, but most of time everything seems to be okay. Thanks again...
    sad_old_man and FF22 like this.
    10-18-13 11:12 AM
  23. sad_old_man's Avatar
    @sad_old_man - in one word: ecstatic!
    @pacoman03 - Thank you so very much. The uninstalling of all side-loaded apps followed by the individual reinstall of the 3 deemed most important seems to have worked (for the most part). Sometimes even now the Android runtime fails, but most of time everything seems to be okay. Thanks again...
    @dutchy thingy - should that not be ekstatik - a form of lectrikity?
    @pacoman03 - tanks from me as well for whatever itiz you did?
    dphjeff likes this.
    10-18-13 11:35 AM
  24. Graheem's Avatar
    Since updates are happening often, it is easy to not know which you refer, wouldn't have been hard to have just put the version you are referring to in your OP.
    What part of "most recent update" didn't you understand exactly?
    10-18-13 12:17 PM
  25. Hirazi Blue's Avatar
    Thanks for the timely advise.
    Thing is I interpreted the intent of Lendo's words wrongly and responded accordingly. That's all there is to it as far as I am concerned.
    Last edited by Hirazi Blue; 10-18-13 at 01:40 PM.
    sad_old_man and FF22 like this.
    10-18-13 01:27 PM
52 123

Similar Threads

  1. Need help for runtime on STL100-3, 10.2.0.415
    By jd_statman in forum BB10 Android App Sideloading
    Replies: 10
    Last Post: 10-13-13, 07:31 PM
  2. Android apps flashing on screen issue .4181
    By sinnar in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 10-13-13, 12:17 PM
  3. Android on my Q10?
    By keepingsane101 in forum BlackBerry Q10
    Replies: 2
    Last Post: 10-13-13, 05:54 AM
  4. how to port from android
    By Tom689 in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 10-12-13, 08:01 PM
  5. Have broken or unwanted BlackBerries?
    By BravoZuluDelta in forum General BlackBerry Discussion
    Replies: 12
    Last Post: 10-12-13, 07:40 PM
LINK TO POST COPIED TO CLIPBOARD