1. Darkian's Avatar
    I dropped my phone down a toilet about 2 weeks ago, I left it in rice for 4 days and used a hoover to try and suck some water out of it, I tried turning it on and it had a battery sign and a red X through it with a loading white bar at the bottom which after about half an hour still didn't complete so I took out the battery and ordered a new one. That came today and I have tried putting it in, charging the battery but now I just have a black screen and steady red flashing light. I have taken out the battery incase this makes it worse. Any suggestions???
    06-26-12 07:34 AM
  2. kbz1960's Avatar
    Might have to face that the rice trick did not fix it because it got too wet for too long. You can try reloading the OS.
    06-26-12 08:12 AM
  3. Darkian's Avatar
    Ohhhhhh it's working I just needed to "mate" the batteries, BUT now it's not charging.... Any ideas why that might be???
    06-26-12 08:21 AM
  4. kbz1960's Avatar
    Plug it in the wall charger with the battery out and then put the battery in.
    06-26-12 08:30 AM
  5. Darkian's Avatar
    Tried that already a few times no luck, I've ordered an external charger
    06-26-12 08:42 AM
  6. kbz1960's Avatar
    Hope you plan on getting the same phone if you find its fried from being wet.
    06-26-12 08:46 AM
  7. Darkian's Avatar
    It's not fried but I'm getting an upgrade soon anyway, I've had it for a while :P
    06-26-12 10:16 AM
  8. kbz1960's Avatar
    Ah, are you trying to reload the OS?
    06-26-12 10:30 AM
LINK TO POST COPIED TO CLIPBOARD