1. tattri's Avatar
    I just got an unlocked Pearl 3G (OS 6.0.0.570) that I'm trying to use with T-Mobile in the US, but data and MMS are giving me fits. Email, phone, and SMS all work fine. I do have the BIS data plan, and am trying to upgrade from a Pearl 8100 that I've been using for years with TMO. Every time I try to use the browser or any Internet-enabled app over mobile, I immediately get an error "Browsing over the cellular network is not included as part of your current service plan. To browse the web you must use Wi-Fi or contact your service provider to change your service plan.". I've checked and double-checked the APN, and re-registered the HRT and d/led service books repeatedly, but nothing makes a difference. I spent 45 minutes on the phone with TMO last night, and they verified that everything looks OK on their end. Does anyone have any ideas or advice? I've been googling this for the last two days and haven't found anything useful. I see service books called "TCP for BIBS" and "BlackBerry Internet Browsing Service", which sound like they would be the relevant entries. I found a network troubleshooting menu and see that I have an IP address, but I can't ping it.
    Last edited by tattri; 10-14-11 at 09:37 PM.
    10-14-11 09:35 PM
  2. kurtla's Avatar
    what carrier is your device from?
    10-17-11 12:22 PM
  3. tattri's Avatar
    I don't know if I'm the first to mention this (I haven't waded through all 189 pages of posts), but I was able to get the CrackUtil/Storm procedure (see below) to work on both OS 5 and OS 6 on a Pearl 9105, even though the CrackUtil README wants you to pay berryology for OS 5 and/or desktop loader 6.x--there are a couple of minor changes to load the new service books with the 6.x DL, but it's still pretty straightforward. The IM autolauncher isn't working now, which I saw someone mention elsewhere, but giving up that for the browser and other data apps is an OK tradeoff for me. Other than that, everything appears to be working as expected.

    Aforementioned procedure: http://forums.crackberry.com/storm-t...m-95xx-106023/
    10-17-11 09:58 PM
  4. tattri's Avatar
    what carrier is your device from?
    I'm not sure. I got it off eBay and it shipped from Hong Kong; the firmware splash image looks like a cross between a snake and a three. Any ideas what that would be?

    (I just got this working (see my other post in this thread), so at this point it's purely academic, but I was wondering what carrier it came from myself.)
    10-17-11 10:01 PM
  5. kurtla's Avatar
    to work with tmo you have to have bands 1,4,8 - do you? do you show an uppercase 3G?
    10-17-11 10:40 PM
  6. tattri's Avatar
    to work with tmo you have to have bands 1,4,8 - do you? do you show an uppercase 3G?
    As it turns out, by blind luck, I do. Frankly I would have been happy with EDGE, but a little googling reveals that this phone came from 3 in Australia, who use the same bands.
    10-17-11 10:50 PM
  7. kurtla's Avatar
    blind luck, lol - nothing wrong with that. sounds like you are golden
    10-17-11 11:10 PM
LINK TO POST COPIED TO CLIPBOARD