1. treo2501's Avatar
    I post same msg board yesterday but not under Pearl 3G section got a respond and didn't solve the problem. I bought unlocked 9100 recently and it's my first berry. When I got it, it's says vodafone carrier, then I called tmobile to upgrade data plan to BIS, got e-mails setup, APN setup to tmobile, register the routing table, sent out service book, pretty much all the setup are done. here's the catch everytime i try to surf internet using bb browser, this shows up "browsing over the cellular network is not included as part of your current service........" then so on, even facebook and youtube app says the same thing, called tmobile they can't do anything about since the phone is not tmobile. So perhaps upgrading to OS6 could solve the problem, but nope. Guys, I need help on this......thank you so much
    Last edited by souffles; 05-28-11 at 06:12 PM.
    05-28-11 06:08 PM
  2. treo2501's Avatar
    anyone?? help please??
    05-28-11 06:42 PM
  3. Zach7's Avatar
    If your carrier can't figure it out. Try this.....

    Can't update my email - BlackBerry Support Community Forums
    05-28-11 07:02 PM
  4. treo2501's Avatar
    If your carrier can't figure it out. Try this.....

    Can't update my email - BlackBerry Support Community Forums
    Zack7: tried that many2 times, didn't solve it. thx for replying, appreciate that
    05-28-11 10:32 PM
  5. californiablackberry's Avatar
    Is your device unlocked?
    If the cell phone is unlocked, it will recognize a SIM card from any carrier. The "lock" is a software setting that keeps the cell phone "loyal" to one carrier.
    05-28-11 10:38 PM
  6. treo2501's Avatar
    @californiablackberry: Yes, the device is fully unlocked, once i got the phone i put tmobile sim right away
    05-29-11 06:29 AM
  7. kurtla's Avatar
    I suspect the apn is what is throwing you off, what are the settings you are using and your device will not work on tmo 3g, right?
    05-29-11 12:54 PM
  8. treo2501's Avatar
    I suspect the apn is what is throwing you off, what are the settings you are using and your device will not work on tmo 3g, right?
    you are correct about my device is not showing 3g, it shows edge right before the signal bar and as per APN, it setup as epc.tmobile.com. thanks for the help and problem still occurred.
    05-29-11 03:30 PM
  9. kurtla's Avatar
    what I mean is the device you have is only an edge device, you will not be able to get 3G no matter what you do, unless I am thinking its something different than it is. go into options>about - if its tmo 3G compatible it will have 1,4,8 as your bands. if it is compatible then I don't know what you are up to as all you have to do is unlock the device and its ready to fly except for getting UMA to work. Having a non-3G device does not make much sense as that is what you are paying for and the difference between edge and 3G is, well a lot. funny as 3G is about dead now but whatever.
    Last edited by kurtla; 05-29-11 at 05:00 PM.
    05-29-11 04:53 PM
  10. treo2501's Avatar
    what I mean is the device you have is only an edge device, you will not be able to get 3G no matter what you do, unless I am thinking its something different than it is. go into options>about - if its tmo 3G compatible it will have 1,4,8 as your bands. if it is compatible then I don't know what you are up to as all you have to do is unlock the device and its ready to fly except for getting UMA to work. Having a non-3G device does not make much sense as that is what you are paying for and the difference between edge and 3G is, well a lot. funny as 3G is about dead now but whatever.
    As per your instruction, options>about - shows 3G Bands as 1,2,5,6. So if I don't have 1,4,8 my device is still locked? but how come I can have tmobile signal in vodafone phone? if i get this device 2nd time unlocked, should resolve the issues? thanks again kurtla for the advice.
    05-30-11 08:15 AM
  11. kurtla's Avatar
    T-Mobile USA uses the 1700/2100 MHz AWS Band for its 3G network, here is the wiki on the bands UMTS frequency bands - Wikipedia, the free encyclopedia It really depends on what your objective is, having a device and not running it @ its top intended speed is like having a 911 and using ARCO to fuel it, it will work but not all as well as premium from Shell - you can tell F1 has brainwashed me, lol. Anyway, from what I know your device will not work on TMOs 3G network but it will work fine on EDGE, all you have to do is unlock the device and use it - put the stock APNs back in place, make it look just as you got the device and use it. I don't think UMA is an option either unless you have something that is speced for tmo, like a unit from wind, CBW, etc. Your device sounds like its unlocked, so that does not need to be done. This is a band/carrier issue, nothing more.
    05-30-11 10:50 AM
  12. tattri's Avatar
    I posted a similar request yesterday at http://forums.crackberry.com/blackbe...mobile-660118/ . After seeing this I verified that my unlocked 3g Pearl has bands 1,4,8, but I still can't get data access (and even if I was stuck with EDGE I'd be OK with that). Can someone help, please?
    10-16-11 12:02 AM
LINK TO POST COPIED TO CLIPBOARD