1. reyalP's Avatar
    I searched the forums and tried everything to install the drivers for my BB Peral? I cannot get the system to find a driver for my phone. It shows up as Bluetooth peripheral device in the device manager. Is there somwhere i can go to get a driver for my phone?
    11-21-07 05:19 PM
  2. chinesecatt's Avatar
    11-21-07 06:27 PM
  3. surfanimal's Avatar
    Have you installed the Blackbery Desktop Manager yet?
    11-21-07 06:30 PM
  4. reyalP's Avatar
    chinesecatt- I tried the instructions you provided at the link and I can't seem to get the laptop or vista to find any drivers.

    surfanimal- Yes, i have installed the Desktop manager and it works just fine. It even picks up my phone through bluetooth although it won't let me transfer files unless I have the USB cable plugged in.

    The only thing that is not working is that the Vista OS cannot find any drivers to install so I can enable my laptop to see the phone 4gb memory card. Desktop manager sees the phone on usb and bluetooth. The computer sees the phone on usb and enables large drive support. The computer has even synced with the phone through bluetooth but needs theses so called drivers to enable it to be seen.

    Any other ideas?

    THanks again
    11-23-07 03:36 PM
  5. chinesecatt's Avatar
    Check if you indeed have the drivers downloaded.

    Location:
    C:\Windows\System32\drivers

    Look for:
    RimUsb.sys
    RimSerial.sys
    11-23-07 04:03 PM
  6. reyalP's Avatar
    I don't see those listed. Any idea how I can extract these files without reinstalling desktop manager?

    Thanks for your help.
    11-27-07 12:14 AM
  7. CA808's Avatar
    I don't see those listed. Any idea how I can extract these files without reinstalling desktop manager?

    Thanks for your help.
    Hi All,

    I'm having the same problem. It seems that without the bluetooth drivers one cannot tether and use the phone as a modem via bluetooth. Everything else works fine, tethering using USB, synchronizing using USB, synchronizing using bluetooth, but no phone as modem with DUN (Dial-up networking) using bluetooth. Unless we can locate drivers, the two Bluetooth Peripheral Device entries in Device Manager and their lovely yellow exclamation marks are going to prevent us from using the phone as a modem using bluetooth.

    It would be great if someone who actually KNOWS where to get those drivers could help us. Come on RIM! What gives?

    Thanks.
    12-06-07 11:18 PM
  8. snowbord60's Avatar
    Any update on this?
    12-16-07 05:34 PM
  9. walple's Avatar
    Check out this thread: blackberryforums.pinstack.com/26131-vista_pearl_bluetooth_no_drivers.html]Vista + Pearl + Bluetooth = No Drivers? - PinStack.com

    Basically we are skrewed until RIM releases a Vista driver. Sync works and that is all I care about...
    01-15-08 06:19 PM
  10. donnanicole's Avatar
    I have a 1GB in mine, and vista recognizes it...maybe its the size, but that shouldnt matter
    01-15-08 06:24 PM
  11. RexxNet's Avatar
    Hey there, Chinese Catt.

    Looks like you're the expert on this. I need your help when you have a moment. I am using the 8300 through Suncom, which will soon be T-Mobile. I have downloaded both version 4.2 and 4.3 software to try and solve the Bluetooth Peripheral Device issue I get when I add Bluetooth as a connection method and pair it with my Inspiron 9300 (Vista Ultimate). I cannot find a folder anywhere that has a driver exctracted for this device. It shows up as two separate devices. It will sync with Bluetooth, mostly taking a very long time to connect initially and will sync and do media normally with the USB cable. I have not been able to use the phone as a modem as of yet. I think it's because of the two missing Bluetooth peripheral devices. I've read your comments and also visited your suggested links. Packed full of information, but it seems they are more directed with USB connectivity. My drivers are there as you asked the other person who had difficulty.

    Any help would be appreciated.
    03-06-08 08:28 AM
  12. eroccia's Avatar
    I to cannot find the drivers for Vista. I bought a sony laptop and everything works for me. I am able to transfer files from my laptop to my phone VIA bluetooth. My laptop even answers my calls when i have it active. The only issue I do have is everytime i start my laptop up it asks me to install the drivers for the bluetooth device that is connected (meaning my pearl). if anyone can find the drivers please let me know as well.
    03-06-08 01:23 PM
  13. chinesecatt's Avatar
    When you search for driver and or install them, make sure you go through all the driver installations. It will ask you about 4 or 5 times for the same hardware. I know it is annoying, but that is that only way you can completely and successfully install the driver without having to do it everytime you connect your device.

    You do not have to search it yourself, just have the computer search it for you. Just make sure you direct it to <C:\> when it tries to locate the driver.
    03-06-08 05:35 PM
  14. chinesecatt's Avatar
    RexxNet, I didn't answer your PM. But if you still want me to answer you privately, just let me know. Just too busy right now.
    03-06-08 05:37 PM
  15. bbpwnage's Avatar
    If you look here and read this you can see at the bottom that they (RIM) know that it doesnt work with Vista,

    Well I would provide the URL but I cant because I have not made 10 posts yet. But if you go to Blackberry's website and type in this KB ID "KB12544" and you scroll to the bottom of the page it states that it doesnt work at the current time.

    I have had this problem for six months already, there is no solution, I have tried everything you all discussed in this thread and there is no way that I have found to get it to work. It says at the bottom of KB ID that I provided with the following message,

    “BlackBerry Device Software 4.2.2.x and earlier does not support Bluetooth tethered modem functionality with Windows Vista. This is a previously reported issue that has been escalated internally to our development team. No resolution time frame is currently available.”

    So let’s just wait. BTW is there an updated software available for the 8320 I currently have 4.2.2.180 (Platform 2.5.0.36)? Off topic, has any one got Flash Player to work with the 8320 from T-Mobile. I think I read that it doesnt work, but some one I know has said that they have it working with Verizon's Curve. And how come Verizon's 8100 has a video camera and the T-Mobile 8100 does not I cant even get a camera for my 8320 T-Mobile Curve, this sucks...I'm going to go with the HTC Touch Pro when it comes out... I cant stand not being able to not use Sling Box and Flash Player, those are the only things holding me back from making the change from my Berry.
    Last edited by bbpwnage; 07-13-08 at 02:57 AM.
    07-13-08 02:54 AM
  16. raver_returns's Avatar
    Okay, I honestly don't know why this worked. After spending a couple weeks going through various different driver sources and changing files around on my laptop per directions of others more "knowledgeable" than me, I finally got my computer completely jammed up. That is to the point that I had to do a restore to prior to starting any of this. Then I stumbled on exactly what services were checked on my BB BT options. I unchecked "audio source", and "A/V Remote Control Target". I no longer got the requests for drivers.

    For the syncing, I deleted the BB from the device list on the PC and; respectively, the PC from the BB. The only thing I did different to reconnect is to initiate the pairing with the BB instead of the PC. I really don't know why it worked for me, but it did. It syncs every single time now. Hopefully, this might help someone.

    BTW I am only using the generic drivers that came with my vista64
    01-10-09 09:14 AM
  17. ve4grm's Avatar
    Holy crap it worked!

    Thank you, raver_returns. It worked like a charm.

    And to note, I was able to get away with just deactivating the A/V Remote Control Target option.

    Thanks.
    01-15-09 06:37 PM
  18. here_miah's Avatar
    I have a 8110 pearl and have successfully synced and operated my BB as a wireless modem via bluetooth over a virtual DUN serial...

    Some just got it I guess

    (P.S. I'm on a Toshiba LT running vista home premium)
    04-13-09 12:38 PM
  19. jasongray's Avatar
    I have to say: I'm really disturbed by the consensus on this thread. Everyone's answer is to re-install the software, or to try another version of the install.

    Does RIM really not provide drivers for their hardware? On my XP laptop, my Curve links without any trouble. I've tried everything, and cannot get my Vista laptop to see my Curve at all...

    If anyone has a solution other than to reinstall everything (again), I am more than open to it. I'm going to call RIM tomorrow and ask them for specific drivers. Wish me luck. :\
    04-22-09 06:43 PM
  20. joyce26's Avatar
    Okay, I honestly don't know why this worked. After spending a couple weeks going through various different driver sources and changing files around on my laptop per directions of others more "knowledgeable" than me, I finally got my computer completely jammed up. That is to the point that I had to do a restore to prior to starting any of this. Then I stumbled on exactly what services were checked on my BB BT options. I unchecked "audio source", and "A/V Remote Control Target". I no longer got the requests for drivers.

    For the syncing, I deleted the BB from the device list on the PC and; respectively, the PC from the BB. The only thing I did different to reconnect is to initiate the pairing with the BB instead of the PC. I really don't know why it worked for me, but it did. It syncs every single time now. Hopefully, this might help someone.

    BTW I am only using the generic drivers that came with my vista64
    raver_returns thank you! It worked! I didn't have to reinstall anything i just went into my BB Storm Bluetoothoptions and unchecked the "audio source" and "A/V Remote Control Target" and I can now sync my Storm on Vista with no problem. What a time saver!
    08-19-09 05:40 PM
  21. faangel's Avatar
    A year later, and this solution still works!!
    10-24-10 11:05 PM
LINK TO POST COPIED TO CLIPBOARD