1. mlo22's Avatar
    ok so i have been having this problem for a little while....i try to retrieve content from a MMS a pic or video and it says"could not retrieve try again later"...
    i take my battery out...doesnt work
    i checked my firewall...
    checked my mms settings..it all says "always"
    call tmobile..and thats a nightmare...



    what could it be?
    05-11-08 04:58 PM
  2. flairbrtndr3's Avatar
    ok so i have been having this problem for a little while....i try to retrieve content from a MMS a pic or video and it says"could not retrieve try again later"...
    i take my battery out...doesnt work
    i checked my firewall...
    checked my mms settings..it all says "always"
    call tmobile..and thats a nightmare...



    what could it be?
    calling tmo should never be a nightmare, try having them send your service books
    05-11-08 05:09 PM
  3. tinye's Avatar
    I don't have TMO, but was having the same problem.

    This info from jcj1 in another thread resolved that issue for me:

    is a known problem on the BB with tmobile and they are working on it with RIM. what help some is going to event log by pressing ALT > LGLG on main screen - then menu > options > highlight warning and press ball > change to debug info and save - then menu clear log and then pull battery with power on - may still have to manually retrieve but helps
    05-12-08 02:29 PM
  4. sarbear's Avatar
    I took my phone down to T-Mobile because I was having the exact same problem. All the guy did was delete a few service books? I think? That weren't supposed to be there and I have recieved every picture perfectly now.
    I think that's all he did anyways..just try taking your phone down and hopefully they will know how to fix it like the guy did for me.
    And if you're not an adult I suggest a parent go in with you since they never seem to take me seriously without one.
    Hope this helps
    =]
    05-12-08 06:59 PM
  5. sarbear's Avatar
    BTW: Every time I have gone down to T-mobile about this problem by myself, they told me it was just a T-Mobile problem. But I have had that problem since December. And just got it fixed a few days ago. But when I went down with a parent they actually took the time to fix my phone for me. Ha. So dont believe them when they tell you its a RIM problem! My was fixed and now works perfectly! They probably just don't feel like dealing with it.
    05-12-08 07:04 PM
LINK TO POST COPIED TO CLIPBOARD