1. enduroman's Avatar
    I have downloaded and followed instructions to upgrade new OS. About 5minutes into the upgrade i get a message in desktop manager
    "A fatal error has occurred while updating your devices software please try again"
    I have tried the upgrade a couple of timed but get same message.
    The phone is an ex corporate phone - I am wondering if there is some setting that is preventing upgrading the OS.
    There was an IT policy - which i successsfully removed thanks to this forum (fantastic).
    Any ideas or help appreciated.

    11-22-08 01:45 AM
  2. PvT's Avatar
    more here:


    BlackBerry 101: How to Reload the Operating System on a Nuked BlackBerry | CrackBerry.com

    Hope things work out for ya.


    Here's some more threads that are good on the upgrade procedures once you have un bricked your phone:


    Here's the way I used to do an upgrade:

    I followed the JLcommander Wipe and deleting the vendor.xml procedure.


    The way I do it now, quicker but more decisions to make:

    Using CrackMem... http://forums.crackberry.com/f35/cra...eleased-52044/

    CrackMem you choose the delete Vendor.xml in the process.

    Procedure for upgrades is:
    1. Uninstall the older version from the PC
    2. Install the newer OS to the PC.
    3. Change the theme on the device to carrier default.
    4. Run CrackMem, make desired changes
    5. Close CrackMem.
    6. Run Desktop Manager.
    7. Plug in BB
    8. When prompted to upgrade, click OK
    9. Choose "Advanced", so individual OS changes can be made.
    10. Begin

    During the upgrade, the device is wiped.
    11-22-08 01:50 AM
  3. enduroman's Avatar
    thanks very much
    11-22-08 02:21 AM
  4. PvT's Avatar
    Your welcome, My pleasure. I've been there so I can sympathize, and hope that all my agony helps make it easier for you, LOL

    Posted from my CrackBerry at wapforums.crackberry.com
    11-22-08 02:43 AM
  5. enduroman's Avatar
    I have tried all options and get it to successfully recognise os but the install seems to hung up on the step "connecting to boot rom". It stays on this step for 3-4 minutes and then it fails. the phone still works but cannot get the new os on the phone
    11-22-08 03:33 AM