03-21-14 02:06 PM
173 12345 ...
tools
  1. werdlum's Avatar
    My issue appears to be slightly different than others:

    BB Pearl 8100
    OS v4.5.0.55
    4GB MicroSD HC card

    BB worked great. If I ever needed to reboot (battery pull), it would reboot just fine.

    I recently started using a 4GB MicroSD HC card. It formats and stores data just fine. However, if I have to reboot the BB (battery pull), it displays "Application Error 523". When I remove the SD card, the BB boots up just fine.

    If I format the SD card on my PC, and reinstall it in my BB, the BB boots up just fine. I reformat the SD card on the BB and reload my data. However, the next time I have to reboot the BB (battery pull), it displays "Application Error 523".

    This is repeatable.

    Any ideas regarding the problem?

    I suspect the SD card is the wrong size/format; however, why does the BB work at all after a reformat of the SD card?

    Thanks for your help.
    02-18-09 12:07 PM
  2. mtj2k's Avatar
    I have a fix that does not require erasing your data! Of course following these instructions could also destroy everything on your blackberry, so read between the lines and only do things that make sense to you.

    First off this is on a T-Mo 8320 software v 4.2.2.180

    This happened to me because of a theme error. I was using the "bbdimension today" and found my phone locked up in a reboot cycle in the morning. After digging around I found someone that suggested looking through modules with the javaloader/jl_cmdr software and removing anything new. This theme was the first thing i removed and my blackberry powered right up.

    You have to get JL_cmdr package from pinstack:
    blackberryforums.pinstack.com/downloads.html?catid=5&linkid=452

    Then install it on your system. Now that your blackberry is in a reboot cycle, you have a very short amount of time to actually run these commands while the system is booting up and you have the white screen with the hour glass. So you may have to pull the battery several times while doing these steps and run one command at a time.

    (in windows xp)
    1) click "start" -> "run" -> type in "cmd" and hit enter to get to dos prompt
    2) type in the following:
    "c:\Program Files\JL_Cmder\JavaLoader.exe" -u -w<passwordifyouhaveone> dir > mymodules.txt
    this will create a file in your current directory called mymodules.txt. open it and look through your modules. in my case the culprit was "net_rim_theme_bbdimension_today_320x240_b". This theme displays my messages and calendar on the front page of the system. I'm guessing that since it has to recalculate the calendar each day, there must have been something about the tasks that I set up yesterday to show up in my calendar. It must have hit a snag after the date changed at midnight, and it got hung up. Could have also been something about my messages.
    3) once you determine which module(s) you want to delete, we'll need to save it just in case we want it back later. In my case the module was "net_rim_theme_bbdimension_today_320x240_b"
    the full command to save it was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> save net_rim_theme_bbdimension_today_320x240_b
    4) now erase it!
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase net_rim_theme_bbdimension_today_320x240_b

    On my blackberry, it said that this was an active module, so I had to force it with the -f switch. Total command was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase -f net_rim_theme_bbdimension_today_320x240_b

    After the module was erased, the blackberry restarted and my system came back to fully working status.

    Hope this helps someone!
    After a dismal upgrade to 4.5, I went back to an old Theme and I got in this loop. I wasn't feeling very hopefully, but this saved me a wipe! Thank you so much!
    03-14-09 08:45 PM
  3. stephberrr's Avatar
    i have an at&t red curve 8310 which reads app error523. ive tried several different ways to reboot it but it seems like the device isnt connecting on the desktop manager!? idk what else to do -can anyone help me with this???
    03-21-09 04:29 PM
  4. BigBadWulf's Avatar
    i have an at&t red curve 8310 which reads app error523. ive tried several different ways to reboot it but it seems like the device isnt connecting on the desktop manager!? idk what else to do -can anyone help me with this???
    Did you recently upgrade your os? If so, try using an original theme. If your already using on of the preinstalled themes, or that didn't help, remove your SD card.
    03-22-09 12:16 AM
  5. laur318's Avatar
    2) type in the following:
    "c:\Program Files\JL_Cmder\JavaLoader.exe" -u -w<passwordifyouhaveone> dir > mymodules.txt


    What is JL_Cmder?
    When i go to run > cmd
    the blac k screen has already got C:\documents and settings
    "stuck" there... like i cant backspace it
    so if i go to type that "command" after it, i get an error.
    i'm guessing i don't have whatever JL Cmder is.

    and where on tmobile is the OS download link???? all i can find on the website is how to download deskatop manager. i already have it.
    03-22-09 12:59 PM
  6. BigBadWulf's Avatar
    Here's the jl comander link:
    JL_Cmder Javaloader Utility

    And here's the link to the latest OS for your flip:
    http://forums.crackberry.com/f85/new...nguage-159375/
    be sure to delete the vendor code.
    03-22-09 01:30 PM
  7. vaney_murillo's Avatar
    Hello everyone,
    One thing that worked for me after by mistake decided to select an old theme on my BB8320 after updating to the OS4.5 was the following. This is after I got the Error 523 and the phone got pretty much stuck:
    -Downloaded and installed the latest media manager.
    -Downloaded the os4.5 from the vendor (T-mobile)
    -Deleted the vendor.xml file (C:/Program Files/Common Files/Research in Motion/AppLoader).
    -Double clicked the LOADER file withing the same folder (C:/Program Files/Common Files/Research in Motion/AppLoader).
    -It automatically started the loader application.
    -Plug in the phone and the loader application gives you a list of whats in the phone.
    -Looked for the theme file and unchecked the box next to it.
    -The application successfully removed the theme, click finish.
    -The phone reboots itself (or do a hard reset by removing battery)
    -Since at time of reboot the theme file no longer exists, it goes back to a default theme.
    -The problem is solved without the lost of data.

    Hopefully this helps.
    03-27-09 02:33 PM
  8. dragon4000's Avatar
    Hello everyone, well, im having the same problem "app error 523 reset" and did a lot of research and nothing. i wiped my handhels, reinstalled the entire os (from tmo ver 4.5) i have a pearl 8120, btw, and nothing. i got a replacement phone, and the same issue. ok, i even changed simcards, got a new sim card and still doing the same thing... just finished talking to tmo and they r going to send me another one.. now my question is, IF, by any chance, the same thing were to happen again, what can i do to resolve this?? or do i just have bad luck??

    Any help is appreciated
    03-29-09 10:05 PM
  9. BigBadWulf's Avatar
    Did you have the problem before or after you moved your contacts into it? I can't imagine it was that way out of the box.
    03-29-09 10:08 PM
  10. dragon4000's Avatar
    Did you have the problem before or after you moved your contacts into it? I can't imagine it was that way out of the box.
    ok, my 1st phone was fine. it started acting slow so i pulled the batt. got the error msg. after a few days of troubleshooting, i got a replacement. i openned the box, placed my sim, put the batt and waited for the phone to boot. the clock was loading and the, "error 523"

    i called them to troubleshoot, i got the sim replaced as well, continue to troubleshoot even more, and now i am receiving another replacement. now im worried that if the new replacement that im going to receive, what are the odds that its going to happen the same thing?? will they be able to replace it or just ignore me, or will they give me a diff phone??

    thx in advance
    03-29-09 10:27 PM
  11. BigBadWulf's Avatar
    I'd expect the same problem, and more than likely due to a faulty contact entry in the SIM. When they replaced the SIM, did they copy yours over to it?
    03-29-09 10:30 PM
  12. dragon4000's Avatar
    I'd expect the same problem, and more than likely due to a faulty contact entry in the SIM. When they replaced the SIM, did they copy yours over to it?
    did they copy what??

    they had me go to a corporate store, they gave me a new sim, and activated it. if you mean the contacts, no, i dont really care about them, as i have them saved in google sync.
    03-29-09 10:35 PM
  13. BigBadWulf's Avatar
    There's something very wrong there. 2 Pearls 523 right out of the box? You must have worse luck than Job! Hopefully the next one is fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-29-09 11:02 PM
  14. dragon4000's Avatar
    There's something very wrong there. 2 Pearls 523 right out of the box? You must have worse luck than Job! Hopefully the next one is fine.

    Posted from my CrackBerry at wapforums.crackberry.com
    lol, thx. hopefully it is. they do say, 3rd time's a charm, lol
    03-29-09 11:07 PM
  15. Jazzi#CB's Avatar
    Is anyone experiencing the error 523 issue using ToDoMatrix. It's the only app I've installed in the past month or so, and the errors began shortly thereafter. I found the following in my sent folder:

    App: tmx
    Ver: 2009.01.05.45
    Loc: 2
    Msg: Partial DB load.
    Ex: none
    ffree: 23300458
    ftot: 96993280
    ram_free: 11040284
    ram_alloc: 15747568

    Apparently the application "tmx" is ToDoMatrix.
    03-30-09 05:03 PM
  16. Van Gogh's Avatar
    I have a fix that does not require erasing your data! Of course following these instructions could also destroy everything on your blackberry, so read between the lines and only do things that make sense to you.

    First off this is on a T-Mo 8320 software v 4.2.2.180

    This happened to me because of a theme error. I was using the "bbdimension today" and found my phone locked up in a reboot cycle in the morning. After digging around I found someone that suggested looking through modules with the javaloader/jl_cmdr software and removing anything new. This theme was the first thing i removed and my blackberry powered right up.

    You have to get JL_cmdr package from pinstack:
    blackberryforums.pinstack.com/downloads.html?catid=5&linkid=452

    Then install it on your system. Now that your blackberry is in a reboot cycle, you have a very short amount of time to actually run these commands while the system is booting up and you have the white screen with the hour glass. So you may have to pull the battery several times while doing these steps and run one command at a time.

    (in windows xp)
    1) click "start" -> "run" -> type in "cmd" and hit enter to get to dos prompt
    2) type in the following:
    "c:\Program Files\JL_Cmder\JavaLoader.exe" -u -w<passwordifyouhaveone> dir > mymodules.txt
    this will create a file in your current directory called mymodules.txt. open it and look through your modules. in my case the culprit was "net_rim_theme_bbdimension_today_320x240_b". This theme displays my messages and calendar on the front page of the system. I'm guessing that since it has to recalculate the calendar each day, there must have been something about the tasks that I set up yesterday to show up in my calendar. It must have hit a snag after the date changed at midnight, and it got hung up. Could have also been something about my messages.
    3) once you determine which module(s) you want to delete, we'll need to save it just in case we want it back later. In my case the module was "net_rim_theme_bbdimension_today_320x240_b"
    the full command to save it was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> save net_rim_theme_bbdimension_today_320x240_b
    4) now erase it!
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase net_rim_theme_bbdimension_today_320x240_b

    On my blackberry, it said that this was an active module, so I had to force it with the -f switch. Total command was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase -f net_rim_theme_bbdimension_today_320x240_b

    After the module was erased, the blackberry restarted and my system came back to fully working status.

    Hope this helps someone!
    Aptyp, you're a genius! This worked perfectly for me! Thanks!
    04-03-09 03:52 PM
  17. skipintro's Avatar
    everything here is all well and good for you pc folks, but what about error 523 on a bberry and a mac? mac has no desktop manager (for whatever STUPID reason), just a 3rd-party sync tool.

    any mac people find a solution to this?
    04-04-09 01:29 PM
  18. AmberNyse's Avatar
    Ok I just received the app error 523 reset message while waiting for a browser page to load..I haven't made any recent changes to my OS (v4.5.0.77) or added any new apps lately!
    I've tried searching for an answer already but all the threads I see are related to some one changing or adding something to their berry...not just surfing on the internet. So does anyone know why I would be receiving this message?? thanks in advance

    Posted from my CrackBerry at wapforums.crackberry.com
    04-08-09 11:25 AM
  19. sleepydumbdude's Avatar
    I worked for ATT. I've only run into like 2 of this error over the past year until the past 3 weeks I've been getting at least 2 calls a day on it. Something must be up or maybe I just never got the calls before.
    04-08-09 04:39 PM
  20. BigBadWulf's Avatar
    I worked for ATT. I've only run into like 2 of this error over the past year until the past 3 weeks I've been getting at least 2 calls a day on it. Something must be up or maybe I just never got the calls before.
    Did ATT finally release a 4.5 OS of their own, or have more people finally realized they don't need to use an official carrier OS to upgrade?
    04-09-09 04:29 AM
  21. swjost's Avatar
    I have a fix that does not require erasing your data! Of course following these instructions could also destroy everything on your blackberry, so read between the lines and only do things that make sense to you.

    First off this is on a T-Mo 8320 software v 4.2.2.180

    This happened to me because of a theme error. I was using the "bbdimension today" and found my phone locked up in a reboot cycle in the morning. After digging around I found someone that suggested looking through modules with the javaloader/jl_cmdr software and removing anything new. This theme was the first thing i removed and my blackberry powered right up.

    You have to get JL_cmdr package from pinstack:
    blackberryforums.pinstack.com/downloads.html?catid=5&linkid=452

    Then install it on your system. Now that your blackberry is in a reboot cycle, you have a very short amount of time to actually run these commands while the system is booting up and you have the white screen with the hour glass. So you may have to pull the battery several times while doing these steps and run one command at a time.

    (in windows xp)
    1) click "start" -> "run" -> type in "cmd" and hit enter to get to dos prompt
    2) type in the following:
    "c:\Program Files\JL_Cmder\JavaLoader.exe" -u -w<passwordifyouhaveone> dir > mymodules.txt
    this will create a file in your current directory called mymodules.txt. open it and look through your modules. in my case the culprit was "net_rim_theme_bbdimension_today_320x240_b". This theme displays my messages and calendar on the front page of the system. I'm guessing that since it has to recalculate the calendar each day, there must have been something about the tasks that I set up yesterday to show up in my calendar. It must have hit a snag after the date changed at midnight, and it got hung up. Could have also been something about my messages.
    3) once you determine which module(s) you want to delete, we'll need to save it just in case we want it back later. In my case the module was "net_rim_theme_bbdimension_today_320x240_b"
    the full command to save it was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> save net_rim_theme_bbdimension_today_320x240_b
    4) now erase it!
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase net_rim_theme_bbdimension_today_320x240_b

    On my blackberry, it said that this was an active module, so I had to force it with the -f switch. Total command was:
    "c:\Program Files\JL_Cmder\JavaLoader.exe -u -w<passwordifyouhaveone> erase -f net_rim_theme_bbdimension_today_320x240_b

    After the module was erased, the blackberry restarted and my system came back to fully working status.

    Hope this helps someone!
    Just wanted to let anyone else know with this problem that aptyp's solution works. I have an AT&T 8310. Decided to change to the Surreal theme and got the 523 error. Things to note. Do not have your BB device manager running it will interfere with the pinstack app as you need the port open to connect. Your BB needs to be booting for this to work. Once erased (I had to force as well) the old theme will be running the hour glass, but then the BB will reboot using the default theme.

    Thank you aptyp!
    04-20-09 01:20 AM
  22. swjost's Avatar
    Did ATT finally release a 4.5 OS of their own, or have more people finally realized they don't need to use an official carrier OS to upgrade?
    Sure did! Wish the OS was smart enough to disable incompatible items; i.e. themes.
    04-20-09 01:26 AM
  23. ZARA1's Avatar
    I did something that was more simplier and rid myself of the dreaded Reset code 523. I plug the usb plug into my 8800 open DM, it did not recognize my device and stated that it was disconnected, I ignored that and open the application loader, deleted the two modules which were the latest themes." Surreal and Stargrazer of gazer", wtf and it removed the apps, once I received the message that the operation was successful, I unplugged it, rebooted and it is back to normal. I recently installed the upgraded Device Manager OS and forgot that those themes would not work. Sometime simple is best. But whatever gets it to work. I say go for it. If you try this be reminded that the desktop manager will tell you that no device is connected. Ignore DM and do your thing. Hope this help others. Thanks Crackberry forum it is nice to know you are here when we screw up our Babies.
    Hi just registered to confirm that you are absolutely right!! I too have the themes surreal and stargazer. Althousgh loading these two havent affected my blackberry in the past, it displayed an error the last time i tried the surreal theme. So I too intend to connect the phone via usb to PC, as that seems to be the only option now despite challenging the error with a hard reset.

    thanks....
    04-20-09 12:18 PM
  24. ZARA1's Avatar
    i cnt seem to remove the stargazer and surreal theme through application loader...aaaaaaaaaaaaaaaaaaaaaaaaaahhhhhhaaaaaaaaa aaaa!!!!!
    04-20-09 03:01 PM
  25. juliaday's Avatar
    I have the same problem, only I have black berry curve 8310. Iv never hooked my bb up to the computer or ever downloaded desktop manager... not even sure how those things work. please help
    04-28-09 12:19 PM
173 12345 ...
LINK TO POST COPIED TO CLIPBOARD