1. bokenrosie's Avatar
    I am wondering how large this group is? I started having this issue sometime in early spring of 2008. After working fine for almost a a year of service I suddenly lost the CallerID on inbound calls that are forwarded.

    If I forward a call from my home phone to my 8100 Pearl (on T-Mobile) it gives me CallerID of myself (since my home phone number is sending the call to the cell phone). The problem is that this used to work properly - ie) it would give me the phone number of the person that was calling me.

    Anyone else having this issue? According to T-Mobile it is ONLY an issue with 8100 phone and they will hapily sell me a replacement 8120 to solve the issue! Funny, my spending money can solve THEIR problem?

    Anyhow, if you are having this problem I would love to know if you have found a solution and/or had any contact with T-Mobile?

    Thanks,
    Andrew
    08-27-08 03:12 PM
  2. Gsolo5150's Avatar
    Have the same problem been trying to find a resolution for over six months!!!
    09-03-08 08:41 PM
  3. tmadan's Avatar
    i'm having the same problem. i've been forwarding my # to my business partners phone for years but as of this spring it no longer shows the callers #, it now shows my #. i have it set that if i hit ignore it goes to my vm but if i don't answer then it goes to the business partners phone. i was on the phone with tmobile for an hour but still no solution. i'm with tmobile and my business partner is also with tmobile. tmobile must have changed a internal setting in the spring if we are all having the same issue.
    09-10-08 02:12 PM
  4. HondaDNA's Avatar
    It is a thing with the 8100 Pearl, the phone it self is forwarding the calls not the network(like 3-way calling, but your not on the phone). It may only happened right before because of the older OS used the network to do the work and now the newer OS uses it-self to forward the calls. Also how you have you call forwarding set up may be the problem now.
    09-11-08 01:34 AM
  5. glgarcia1's Avatar
    I have the same exact issue...but mine started about a month ago, where people who call my landline office phone number after I've forwarded the calls to my pearl, it shows up on my pearl's caller ID that I am calling myself from my cell phone. I've spent 7 or so hours on 4 different days with four different T-M blackberry techs, and the first two had no idea...had never heard of the problem. the third tech said it was a RIM problem and that RIM had been notified. The last person said that it was a network issue, that since T-M was upgrading to 3G, this was causing the problem. This person thought that if I got a 3G BB when it came out in a few weeks, that this should fix the problem. still, it raises the issue of that nobody knows how to fix this, and we're stuck til something new comes out. Don't you think T-M ultimately has to make this right, and that they owe us some of our money back? I'm sure that won't happen, but they don't seem to care. T-M tech also said, if you went to Verizon or Sprint, that the BB's would have the same issue...who knows??
    09-12-08 01:50 PM
  6. robkacz's Avatar
    I have Tmobile 8800. I forward calls fron Vonage to 8800 and caller ID works fine on ALL calls.
    I also forward calls from PhonePower to 8800 ---- Caller ID only shows my PhonePower number no matter who calls my PhonePower number....
    If I forward to TracFone, Verizon, etc.... Vonage & PowerPhone caller ID is fine.... Only Tmobile from PhonePower caller ID sucks! Help!
    -Robert
    01-23-09 12:54 AM
  7. CaptB123's Avatar
    I hope this helps fix your problem. It worked for me I bought a 9700 blackberry from T-Mobile it worked fine with call forwarding for about a month. Then when a call was forwarded from my office phone to my 9700 blackberry all I would see was the office phone number instead of the call of the person calling the office phone. When I looked in the call log after ward I could see the phone number of who called. I tried looking up some help on the web, talking to T-Mobile and Blackberry none of it did any good.

    Heres how I got my call forwarding to work again so I could see who was calling. I wiped my 9700 blackberry again like T-Mobile recommended and I also change my phone on my T-Mobile to another phone that was not a blackberry that used the web. I would have used my old Treo 650 but T-Mobile does not support it anymore. Then after a day or two my call forwarding started working. I set my 9700 blackberry not to do any updates; I think that is what stopped it from working in the 1st place. This worked for me I hope it helps you.
    05-23-10 11:16 AM
LINK TO POST COPIED TO CLIPBOARD