1. sunshine1908's Avatar
    I bought a cheap AT&T Gophone and activated it with the sim card. After unlocking my blackberry pearl 8120 , I put the activated go phone sim card into it. I have confirmed the blackberry is unlocked by following the steps Options > Advanced Options > Sim Card and typing MEPD. Everything is Disabled. The AT&T Network is not detected and SOS is in the top right corner of the phone display. When I select mobile network options, there are two items listed: Data Services (which is set to off) and Mobile Network (which currently says AT&T). I only want to use this as a voice phone, no data. How do I get the phone to detect the AT&T network so that I can send and receive phone calls?
    04-15-12 03:56 PM
  2. troshs's Avatar
    Well, with AT&T, they currently have a thing where if ou have some sort of smartphone, such as a BB, that it must have a data plan put on it to run. You can't use the BB without a data plan, even if you found a way to shut the data off, their network will do a sweep once in a while to make sure that all BB's on their network have a plan. What I would do is get ahold of AT&T and see which ones they have, the one I'm running on gives me 200 KB for $15.
    06-05-12 01:07 PM
  3. freethisberrydotcom's Avatar
    Make sure it set to 2G/GSM in mobile network options.

    If it says disabled beside network, then it is definitely unlocked.
    06-05-12 04:41 PM
  4. galaxy999's Avatar
    Yeah, sadly the days are gone where you could get a BB without data. When I first got my 8100 it was not required to get a data plan with it. If they won't let you use the phone without data, you may want to consider using net10, or t-mobile prepaid, as these will not require that depending on the plan you choose. Not to mention those two carriers are much cheaper than AT&T. So if you have them in your area, I'd suggest that as a last resort.
    06-17-12 07:35 PM