1. nattyz2004's Avatar
    I am living in Jamaica

    i have a blackberry 8100 which was working fine and then i get an error saying insert sim card. i re-insert the simcard but it is saying no sim card still so i tryed a LIME (formerly Cable & Wireless Jamaica) and the phone automatically recognized the sim and the phone start working again. If i insert a claro Jamaica sim card it work perfectly as well too but if i put in the digicel jamaica sim card it start saying insert sim card.

    the phone is unlock cuz the network is disable but it just wont take the digicel sim card and it use to work with it before. I have also tried upgrading the phone and it is the same problem.

    Any ideas guys of how to solve this problem?
    06-12-10 01:30 PM
  2. Pete6's Avatar
    This sounds like you may have a dead SIM card. Can you get a replacement?
    06-12-10 01:34 PM
  3. nattyz2004's Avatar
    the same sim work in other phone (8520). it doesnt matter how many sim i tried in it its the same result as long as the sim is from digicel jamaica
    06-12-10 01:42 PM
  4. Lady_Jade's Avatar
    the same sim work in other phone (8520). it doesnt matter how many sim i tried in it its the same result as long as the sim is from digicel jamaica
    Ok it seems your bb might need to be unlocked again. One possible cause of this is becuase of the constant swap of digi, lime n claro sims. Some phones when unlocked n constant sim swapping with different network sims can cause issues. So get it flashed, reload and unlocked again n choose which network you are gonna dedicate it to and only use that sim in there.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-12-10 02:19 PM
  5. nattyz2004's Avatar
    i have already flashed it and reload the software. it is showing network disabled which means its unlock
    06-12-10 02:42 PM
LINK TO POST COPIED TO CLIPBOARD