1. roseb510's Avatar
    so i recently got the blackberry pearl, its my first one and it does way more than im used to! anyways, im having major issues getting my browser to do anything! i cant even get to a screen where i can type in a web address so its getting quite frustrating..can anyone give me like a step by step way of starting up the browser? i did the registration (i think) i have a user name and password..but it seems to be and endless loop! i know its gotta be simple...im just not that intelligent i guess haha thanks in advance!
    12-18-07 11:30 PM
  2. TehPatty's Avatar
    When you click on the browser hit the menu button. This will bring up a list and you click on "Go to..." this is where you enter the URL.

    Also try downloading Opera Mini. I got it today and I LOVE it compared to the BB browser.
    12-18-07 11:35 PM
  3. roseb510's Avatar
    alright when i hit the menu button nowhere does it say go to...i dont understand why it doesnt work!
    12-20-07 01:50 AM
  4. scottjb's Avatar
    Are you sure you're selecting the Browser icon? It doesn't require a user name and password. Which icon are you selecting?
    12-20-07 07:45 PM
  5. kport's Avatar
    Not sure why that happens, but once you have went throught the setup wizard it happens.

    Just take the battery out wait about 30 seconds, put it back in, go to the browser and then you should have the "go to" option.
    12-20-07 09:28 PM
  6. Kebero's Avatar
    It sounds like they're going through the email setup icon as opposed to the browser icon, which explains the lack of a "go to" option.
    12-23-07 01:28 PM
LINK TO POST COPIED TO CLIPBOARD