1. AquaHazel's Avatar
    Hello all, I havin a problem gettin some of my MMS opened on my BB pearl. I keep receiving this message "Could not retrieve message content. Try again later." And when I click on the "retrieve now" link, it says receiving content and nothin shows up after that. It then expires in 3 days if I don't retrieve it. Anyone have any ideas, any advice would b helpful, thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    02-22-08 10:25 AM
  2. pitbulldawgs05's Avatar
    Alot of people are having this same problem including me. What I do as a temporary solution is reply to it (random re then go back and retrieve, which has worked for me.
    02-23-08 01:26 PM
  3. AquaHazel's Avatar
    Ok I'll try that

    Posted from my CrackBerry at wapforums.crackberry.com
    02-23-08 06:19 PM
  4. AquaHazel's Avatar
    So u reply 2 the person that sent it 2 u and then ur able 2 retrieve it? I'm gonna try it

    Posted from my CrackBerry at wapforums.crackberry.com
    02-23-08 07:06 PM
  5. pitbulldawgs05's Avatar
    yes thats all you do...discovered by accident but it works for me and my friend so far.
    02-26-08 09:50 PM
  6. sunkast's Avatar
    Where was this suggestion a week ago when I had an MMS I couldn't open?
    02-26-08 09:59 PM
  7. pitbulldawgs05's Avatar
    Where was this suggestion a week ago when I had an MMS I couldn't open?
    How did you get your MMS to work????
    02-27-08 08:35 PM
  8. sunkast's Avatar
    I never got my first MMS to work. I kept trying the retrieve now option but it would never work. Today I got another MMS from a friend, this time however I click on retrieve now, and had no trouble. No idea why.
    02-27-08 08:42 PM
  9. jerzey904's Avatar
    I had the same problem so I called T-Mobile. They told me I had to turn on the firewall and it worked. You can do this by going to Options> Security Options> Firewall.
    02-28-08 08:04 PM
  10. shong87's Avatar
    i just don't get mms.. it goes to my t-mobile album.. i don' know
    02-28-08 08:43 PM
  11. jpfdeuce's Avatar
    Hey all. N00b member but I've had my Blackberry (8700g) for almost two years. I'm gettign this same error from time to time -- some go through and some don't. T-Mobile being my carrier too. Their web site offers nothing regarding allt hese gray areas of troubleshooting, doesn't it?

    I recieved a picture from my GF this afternoon and she sent another one that didn't go through -- got the error message being described here and in other threads that people have pointed to.

    Tried a battery pull and then hit RETRIEVE NOW. Nothing. Tried turning on the firewall as explained above. No dice. It just starts retrieving and then stops.
    03-28-08 07:45 PM
  12. matcarlson's Avatar
    I've never been able to send MMS messages via my T-Mobile 8320, even when I got it brand new. The firewall part seems like the option if you get the notice that the message is there, then get the retrieve option.

    My issue was that I would send a message, and 10-30 seconds later get a red X where the envelope would be, when viewing the message list.

    T-mobile said to do a Master Reset. Eff that! I have App world apps that I don't want to buy again. I don't know if they would let me download it for free or what, so I tried another way.

    From the home screen: Options > Advanced > Host Routing Table. Click on the bold listing (there will be many T-Mobile listings, but only the active one is bold). Once you're in the detail of the routing setting, click Menu > Register now.

    Right after that happened, everything worked FINE! By the by, my firewall is off. It may help your issue to turn on automatic retrieval (Home > Messages > Options > General Settings > Automatically retrieve... I think it's there. Or it's under Home > Options > MMS).

    07-01-09 06:54 PM
  13. jcevans7's Avatar
    My wife's pearl doesn't even have the MMS setting. Any ideas?
    07-07-09 06:33 PM
  14. JBerryKid's Avatar
    My wife's pearl doesn't even have the MMS setting. Any ideas?
    Update your OS.
    07-08-09 01:33 AM