09-25-15 05:56 AM
109 ... 2345
tools
  1. ATFC's Avatar
    Ever since the last update, mine has been getting buggier by the day. The lag was noticeable only in Android Apps at first and phone heats up like mad. Now its spreading to native apps too. There's been some suspect call drops and unexplained muting as well. Soo frustrating.

    Posted via CB10
    Leaked on official?

    Posted via the CrackBerry App for Android
    05-09-15 08:01 AM
  2. mmednick1's Avatar
    My passport lags too. I'm running a new GPS software for work and it's unusable with my passport. My co workers note 4 pushes the software with no stutter. It's actually making me want to trade the phone in. Yes I've done a reboot and totally rest the phone twice to no avail.

    Posted via CB10
    05-09-15 09:05 AM
  3. CharlieV's Avatar
    Zero lag. Ever. No matter what I throw at it.

    Posted via CB 10 on my Passport SQW100-1 sporting 10.3.1.2582
    05-09-15 09:44 AM
  4. AluminiumRims's Avatar
    I don't have any problems with lag at all. There are situations when some things can take time, like loading settings menu. This happens because everything isn't in the memory yet and must be transferred from flash, these delays happens regardless of how much RAM you have.
    05-09-15 09:51 AM
  5. jopfet's Avatar
    No lag at all!!!!

    Posted via CB10
    05-09-15 05:07 PM
  6. kurniawan tanadi's Avatar
    Mine too after update I fell lagging and sometimes my battery drain fast anyone know how to solve this problem?
    09-19-15 05:39 AM
  7. LyoobaBerry's Avatar
    2500???? wtf lol

    Posted via CB10
    2500 is nothing, no lagging here
    Is your Passport lagging even with 3gb ram?-img_20150919_145703_edit.png

    Posted via CB10
    09-19-15 08:07 AM
  8. shawnreum's Avatar
    Mine too after update I fell lagging and sometimes my battery drain fast anyone know how to solve this problem?
    Try power cycling the phone off and on. With both power button or the volume up and down button reset.

    Also OS reload sometimes is needed as the OS update doesn't always take to the phone nicely. I've experienced that across multiple systems Android and IOS alike.

    Additionally, after a OS update always check for App updates over the next few weeks.
    Sometimes after a OS update an app could require a fix in order to play nice with the OS. Otherwise you get unexpected results like battery drain, unwanted fuctioning, etc.....

    "I reject your reality and substitute my own!" from Adam Savage
    09-19-15 08:18 AM
  9. Eric_PP's Avatar
    Nope, super fast always. Maybe a reboot will help?

    Posted via my lovely SE passport!
    09-19-15 08:26 AM
  10. JMDBERRY's Avatar
    If experiencing lag,...should consider rebooting at least every 7 to 10 days.

    Posted via CB10
    09-19-15 09:11 AM
  11. gum_bee's Avatar
    No, runs very smooth

    Posted via CB10
    09-19-15 11:14 AM
  12. Steve
    I got my passport in January. I am very happy with the hardware of the phone (Camera,Sound, Connectivity features, Call quality etc). But in case of speed of the phone..it is not looking like a 3gb phone. When I Open photos folder..it is taking 10-15 seconds to load!!! And also it is even hanging sometimes...This is where iPhone has superiority on..ios users njoy lag free software (only minor bugs which are negligible)

    Posted via CB10
    Not with ios 9 - my ipad has hung opening settings and apps several times since the upgrade.
    09-19-15 05:20 PM
  13. gum_bee's Avatar
    sometimes it does weird things like open up the browser or pictures when i want to unlock it.
    09-19-15 08:22 PM
  14. jdesignz's Avatar
    Never.

    Pasaporte Pilipinas | SQW100-1/10.3.2.2639
    09-19-15 09:00 PM
  15. BlackberryFan777's Avatar
    That's a lie. The Passport definitely lags lots of times. However, so does the iPhone 6 and iPhone 6 Plus, and virtually every other phone. Poorly optimized apps will do this most often.
    One thing that would help is if Chen hadn't stopped the move to Qt 5 with QML 2. That would mean OpenGL acceleration for the UI of pretty much every app.

    Let's hope we get a big announcement soon revealing that Chen hasn't been as bad as it seems he has.

    -- B.

    Posted via CB10
    dejanh likes this.
    09-19-15 10:59 PM
  16. letrantrung's Avatar
    Sometimes, yes, it is. I used to experience my pp running with more than 2gb ram used and it sure lags. After I restarted, it goes down to 1.5gb running and it runs smoothly again.

    Posted via CB10
    09-19-15 11:03 PM
  17. cbosdell's Avatar
    I don't have lag but get low on memory a lot more often than you'd expect from 3GB ram. A little frustrating when the OS closes apps I'm still working with to save memory. Usually a restart every couple days or so helps prevent that.
    09-21-15 12:23 AM
  18. dejanh's Avatar
    I don't have lag but get low on memory a lot more often than you'd expect from 3GB ram. A little frustrating when the OS closes apps I'm still working with to save memory. Usually a restart every couple days or so helps prevent that.
    Ugh, I get this so many times. It is incredibly frustrating. I will go back to the home screen and see the apps with that transparent outline, and I immediately know that they were forcibly shut down by the system to recover memory. I actually think that memory management in BlackBerry 10 OS is not very good. For me at least, this issue happens much too often. With that said, at any given point in time I have no less than 4 apps open simultaneously, and usually at least 4-6 browser tabs.
    mrlahjr likes this.
    09-21-15 12:08 PM
  19. mfried0815's Avatar
    sam lag here with approx 9500 pictures on SD card. when I attach pictures and the galery opens there is a lag of 4-7 seconds.
    only lag I experienced so far.

    PassportSQW100-1/10.3.2.2639
    09-21-15 12:50 PM
  20. anon(2325196)'s Avatar
    Mine never lags. Has never lagged. This is primarily because I installed another 3GB's of RAM. Didn't you know about this? With 6GB I practically doubled my RAM. Or, wait a minute here, this can't be right. Forget it.

    Posted via CB10
    09-21-15 04:19 PM
  21. benmhall's Avatar
    Pictures takes less than 5 seconds to load on my Passport. 3000+ photos on an SD card, several apps running already.
    09-21-15 04:37 PM
  22. Resilience's Avatar
    What's lag in phones nowadays?
    09-21-15 04:57 PM
  23. joshua_sx1's Avatar
    What's lag in phones nowadays?
    'Lag' means when your fingers are faster than your mobile reaction...

    Posted via CB10
    09-21-15 10:33 PM
  24. rebroker2009's Avatar
    No lag here except with CB10 app when I am in my man cave in the basement!

    Blackberry Passport running 10.3.2.2639
    09-21-15 11:05 PM
  25. The_Passporter's Avatar
    It is normal on every phone I've owned on all platforms to be a little quirky or laggy at first after a new update. After a few updates and a few app re-installs it works just as fast as the day I got it. That I can't say about any phone I've had before. This is the only one that still flies after 1.5 years.
    Just amazing and I think we owe it to BB10

    Posted via CB10
    09-22-15 06:08 AM
109 ... 2345

Similar Threads

  1. Connect Passport to a beamer?
    By nimra in forum BlackBerry Passport
    Replies: 5
    Last Post: 09-25-15, 10:21 AM
  2. Location-Path of native BB10 apps, where is it?
    By Fotis_Greece in forum BlackBerry 10 Apps
    Replies: 2
    Last Post: 09-21-15, 11:24 PM
  3. Mic problem with z30
    By azharraja85 in forum BlackBerry Z30
    Replies: 2
    Last Post: 09-21-15, 06:37 PM
  4. Issues with Facebook unable to show posts
    By divernan in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 09-21-15, 04:22 PM
  5. Any luck with Android Pay working on BB10?
    By bmtaylor9 in forum BlackBerry Z30
    Replies: 2
    Last Post: 09-21-15, 01:01 PM
LINK TO POST COPIED TO CLIPBOARD