1. antipaticu's Avatar
    Hi,

    Maybe someone can help me, as Google didn't or I didn't find what I've needed. My home Wifi network works like hell on my Passport. It's showing me full bars, all the other devices are working just fine, Passport takes a long time until it opens a webpage, or even 'try again' message. It's really annoying, I cannot use my wi-fi and have to use mobile data because it blocks the Internet. And it's not only the browser, all the apps have the same problem. This happens only on my home wi-fi and only with my Passport, I also tested a samsung, an iPhone and the TV's are working without problems. The worse thing is that it's working now and then when connected, but the wi-fi stays always connected.

    I hope some of you know how to solve this.

    Posted via CB10
    10-16-16 01:31 PM
  2. RoseBud68's Avatar
    You try a hard reset? Hold both Volume Button down till the phone resets and the BlackBerry name comes up then let go.
    10-16-16 05:51 PM
  3. antipaticu's Avatar
    I did a hard reset and the problem is still there. Some other ideas? All my other phones, the notebook didn't or don't have this problem.

    Posted via CB10
    10-22-16 02:36 PM
  4. S1lv1o's Avatar
    You might want to analyze your wifi environment, my Passport works great, my retina macbook pro drops three or four times a day... The likely culprits are way too many devices from other people connected on 2.4ghz, and a low quality ISP provided router. I'm going to have to buy and configure a 5ghz router just to make this go.
    10-22-16 03:10 PM
  5. chiphazard's Avatar
    Hi,

    Maybe someone can help me, as Google didn't or I didn't find what I've needed. My home Wifi network works like hell on my Passport. It's showing me full bars, all the other devices are working just fine, Passport takes a long time until it opens a webpage, or even 'try again' message. It's really annoying, I cannot use my wi-fi and have to use mobile data because it blocks the Internet. And it's not only the browser, all the apps have the same problem. This happens only on my home wi-fi and only with my Passport, I also tested a samsung, an iPhone and the TV's are working without problems. The worse thing is that it's working now and then when connected, but the wi-fi stays always connected.

    I hope some of you know how to solve this.

    Posted via CB10
    May want to do a speedtest to confirm you didn't download some crap software.

    BlackBerry Since 2006. SE/Priv/DTEK50
    10-22-16 08:01 PM
  6. antipaticu's Avatar
    Update: I re-did router connection, changed channel and set 'network rotation key' to 86400. For those who have an Asus RTN18U and this problem this is how I solved it. Thanks for the tips and advices.

    Posted via CB10
    10-23-16 02:02 AM

Similar Threads

  1. AT&T PRIV wifi can not turn on
    By a3hbt9720 in forum BlackBerry Priv
    Replies: 4
    Last Post: 10-17-16, 12:54 PM
  2. ATT Priv Marshmallow install problems
    By MarkyZ10 in forum BlackBerry Priv
    Replies: 8
    Last Post: 10-15-16, 08:29 PM
  3. why my z10 stuck on first setup connection ?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-15-16, 09:26 AM
  4. whatsapp problem
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-15-16, 06:57 AM
  5. screen replacement question and problem
    By drt_3770 in forum BlackBerry Z10
    Replies: 0
    Last Post: 10-14-16, 06:44 PM
LINK TO POST COPIED TO CLIPBOARD