1. rnem's Avatar
    don't go so far , with this and don't be panic , you just said stuck on %98 or less or more
    1- make sure your device charged at lest over then %50.
    2- open blackberry link ,
    3- go to performance
    4- click on reload device software
    5- hold the power button for 10 second
    6- once the device turned off reconnect to your pc ,
    you might be not fast enough to so, and your device go back( re-boot security wipe) mood again don't worry,
    leave it plugged into your pc , and hold the power button again and click again on reload device software , then, should start the
    process ,
    03-09-16 01:08 PM
  2. Ddembe Kizza Jonathan's Avatar
    My Blackberry passport got stuck at 98% for the last 5 days after i decided to reset it when i could not connect to the Network. I have tried to reset it again but i have failed.
    Help me solve this problem.
    03-15-16 03:14 AM
  3. iamselectaiman's Avatar
    Do the Wipe over BlackBerry Link and it should take you less than 10 mins. That's how I solved the issue...

    Posted via  BlackBerry Passport Silver Edition
    03-15-16 04:13 AM
  4. chinmay007's Avatar
    Thanks a lot. Worked like charm on my bob z30
    04-10-16 10:39 PM
  5. Seong Hyeon Cho's Avatar
    oh my gooooooooooooooooooooooooooooooooodddddddddddddddd ddddddddddddddddddddd

    working
    05-02-16 07:45 AM
  6. emak08's Avatar
    Very helpful, I almost throw my passport. Thanks for the info! You're the BB God!
    05-06-16 07:53 AM
  7. kitsol's Avatar
    thank u so much for your advice..... it took long time for me too .... i've thot that my phones memory is corrupted... now i knw the reason because my phone memory was almost full when i started to wipe it ... im so grateful ur advice ...
    05-16-16 10:15 AM
  8. Ramesh Kumar25's Avatar
    S..It works as Ahmed posted
    05-20-16 02:44 AM
  9. Mayowa Pitan's Avatar
    Thanks a lot for this piece of info. I was experiencing the same problem and thought that something has gone wrong but it is quite calming to know that I am still covered
    06-07-16 04:28 AM
  10. JDWallace's Avatar
    So I followed the steps, and I do get the error but I still can't connect to link. It doesn't even find the device or anything. After a few minutes the BB Passport SE shuts down. Is there something I'm missing or did wrong? Please advise with ideas, thank!!
    06-07-16 01:47 PM
  11. JDWallace's Avatar
    Well after being a long time BB user I made a rookie mistake. It might help if I used the actual BB cable instead of a regular USB/mini.....smh....Panic beat me today....sad day in my life.
    06-07-16 01:51 PM
  12. B Louang's Avatar
    Just reinstall from your computer. Much much faster!!

    Posted via CB10
    06-07-16 08:27 PM
  13. drags_bberry's Avatar
    That's what it looks like, but it is actually talking to the phone. Keep going forward in Blackberry link to do the reload and follow the instructions. I had to call tech support for this a couple of weeks ago.
    06-08-16 06:49 AM
  14. B Louang's Avatar
    This method worked perfectly!!!! Thanks bud
    06-10-16 06:02 PM
  15. Kushal Nagar's Avatar
    My BB Passport security wipe was stuck for 12 hours at 97%. I performed these steps and they are a bit tricky but it worked for me. You need to plug in the other end of the USB into your Passport as soon as the screen goes off. If you wait for the red light or the security wipe to start again, link will not be able to detect your Passport and it will be stuck at installing the driver in your PC.
    06-15-16 12:21 AM
  16. dollface's Avatar
    Can someone help me, I want to try to do the wipe from Link, because I started the security wipe on my Q10 yesterday and it is now only at 98%. I guess I'll wait another hour to see if it completes itself, but if I do try the wipe on Link, how do I get it out of this security wipe mode that it is in. I'm guessing that Link won't recognize my phone if it is in Wipe mode? thank you
    06-19-16 10:41 AM
  17. Andrew4life's Avatar
    Before doing a wipe, if you delete as many of your apps and files as possible, the wipe is much faster.

    Posted via CB10
    06-19-16 11:27 AM
  18. dollface's Avatar
    Before doing a wipe, if you delete as many of your apps and files as possible, the wipe is much faster.

    Posted via CB10
    Thank you, but my problem is that it is now at 98% and has been for 3 hours. Is there any way to connect it to link on my laptop while it is in this wipe mode and get it to restore to default without bricking the phone? I don't even know how to stop this wipe
    06-19-16 12:28 PM
  19. Andrew4life's Avatar
    Thank you, but my problem is that it is now at 98% and has been for 3 hours. Is there any way to connect it to link on my laptop while it is in this wipe mode and get it to restore to default without bricking the phone? I don't even know how to stop this wipe
    I've had it stuck at 99% before and two things have happened when I tried to restart.
    Once it just started booting up again and then it finished wiping.
    The other time it gave me an error and wouldn't boot up, but then I connected it to Link, did a factory restore, and it was fine.



    Posted via CB10
    dollface likes this.
    06-19-16 07:43 PM
  20. dollface's Avatar
    I've had it stuck at 99% before and two things have happened when I tried to restart.
    Once it just started booting up again and then it finished wiping.
    The other time it gave me an error and wouldn't boot up, but then I connected it to Link, did a factory restore, and it was fine.



    Posted via CB10
    That's what I ended up doing. I did a battery pull and hooked it up to Link and it thankfully recognized the device and I did a Restore. That's the first and last time I do a wipe from the phone
    06-19-16 07:48 PM
  21. MPF94025's Avatar
    My passport, was stuck on 96% for the last 5 hours, so out of frustration, i started messing around with it. But i ended up fixing it in the process . So here's what i did .
    Open up link on your PC, connect the USB cable in but do not plug in the other end to your passport just yet.
    Press and hold the power button, Plug in the other end right before or as the red notification light is flashes before the security wipe restarts.
    Then look back on link, the connection process won't work, but will show you some sort of *error* (don't panic, that's a good thing). As soon that error code appears on your Passport, go back to link, where you will have the following options "reconnect" and "reload". Press reload.
    Your Passport will reset again, but this time it won't go back to the security wipe, but instead it'll flash the green light you, get when downloading updates form link, and that's basically what's happening.
    In 10 minutes, the whole setup will complete and your passport will start up on the *language selection* and *agreement page*.

    I'm not exactly certain if it'll work for everyone, but wouldn't hurt to try.

    Many Thanks. Have lived through this a few times. Hopefully never again.Will consider ther suggestions great if done in advance, eg decrypt before wipe, close BB Protect, etc...

    Minor contribution: did not work if I connect through dock. Had to be direct to PC. Also, plugged in immediately

    Downloading latest OS as I write...been trying to get phone back for 5 days
    Last edited by MPF94025; 06-30-16 at 01:00 AM.
    06-30-16 12:44 AM
  22. dollface's Avatar
    Many Thanks. Have lived through this a few times. Hopefully never again.Will consider ther suggestions great if done in advance, eg decrypt before wipe, close BB Protect, etc...

    Minor contribution: did not work if I connect through dock. Had to be direct to PC. Also, plugged in immediately

    Downloading latest OS as I write...been trying to get phone back for 5 days
    Wiping my Q10 through the Security Wipe option on the phone it was at 98% 16 hours later. I removed the battery and hooked it up to my laptop with Link and did a restore. Worked perfectly and took about 30 minutes
    06-30-16 11:02 AM
  23. WP7Nettwerk's Avatar
    My passport took security wipe nearly 24h hours and still 98%. I get tired to wait. I just use reload and it took 15 minutes. Security wipe is really annoying.
    06-30-16 08:51 PM
  24. Mack Gans's Avatar
    My passport, was stuck on 96% for the last 5 hours, so out of frustration, i started messing around with it. But i ended up fixing it in the process . So here's what i did .
    Open up link on your PC, connect the USB cable in but do not plug in the other end to your passport just yet.
    Press and hold the power button, Plug in the other end right before or as the red notification light is flashes before the security wipe restarts.
    Then look back on link, the connection process won't work, but will show you some sort of *error* (don't panic, that's a good thing). As soon that error code appears on your Passport, go back to link, where you will have the following options "reconnect" and "reload". Press reload.
    Your Passport will reset again, but this time it won't go back to the security wipe, but instead it'll flash the green light you, get when downloading updates form link, and that's basically what's happening.
    In 10 minutes, the whole setup will complete and your passport will start up on the *language selection* and *agreement page*.

    I'm not exactly certain if it'll work for everyone, but wouldn't hurt to try.
    You're a life saver!
    07-11-16 04:18 PM
  25. ronberry10's Avatar
    It happened on my Passport SE too then someone advised me to use the BlackBerry link when you do Security Wipe. Voila! It works! Leasson learned.

    Posted via CB10
    Got2GetAway likes this.
    07-12-16 12:45 AM
107 12345

Similar Threads

  1. Replies: 1
    Last Post: 08-05-15, 11:16 AM
  2. New sent and received texts don't appear in Hub (passport)
    By CrackBerry Question in forum Ask a Question
    Replies: 5
    Last Post: 08-05-15, 01:05 AM
  3. Replies: 3
    Last Post: 08-05-15, 12:56 AM
  4. Which Blackberry Classic Model works best on Cricket Wireless
    By contender1543 in forum Cricket Wireless
    Replies: 1
    Last Post: 08-04-15, 11:22 PM
LINK TO POST COPIED TO CLIPBOARD