1. Julian Buss's Avatar
    I have my Passport for about a month now and just experienced the following problem for the second time: all of sudden the keyboard (both hardware and onscreen) don't work anymore. I cannot enter my device password anymore, I can focus the password dialog, but then simply nothing happens when I press keys.

    After a restart of the Passport it asks me for my SIM card PIN. Again, I can focus the text field in the dialog, and I can touch numbers of the onscreen keyboard, and the number keys light up, but no input gets to the dialog.

    There is simply no way to activate the device anymore. I can do a backup using BlackBerry Link, and I can access the device with BlackBerry Blend - but the device itself is useless. No kind of restart or reset helps. The only solution is to do a factory reset, after that the device works fine again - for some time.

    Once this happened while I was on the road, without doing anything with the device. The second time it happened when I was trying to deploy a self written app using the Momentics IDE.

    Additional information:
    - development mode is on (needed since I want to develop Apps for BB10)
    - Snap is installed
    - a handful of Android apps from Google Play store are installed
    - two BlackBerry World apps are installed (whatsapp and HUB++LED)

    Did anyone experienced similar issues or has an idea what might cause this problem?

    Thanks!
    11-25-14 11:06 AM
  2. howarmat's Avatar
    sounds like faulty unit to me
    12-08-14 10:39 PM
  3. Julian Buss's Avatar
    since it seems that I'm the only one in the world having this problem, you may be right. I already asked Amazon for a replacement. Thanks!
    12-08-14 11:54 PM
  4. thymaster's Avatar
    Never seen or heard of this problem before. Maybe a loose circuit in the keyboard. Exchange it.
    12-09-14 02:30 AM
  5. Julian Buss's Avatar
    Strange enough, I just got the very same problem with a Z10 device, which has an onscreen keyboard only. Same behaviour, the device asks me for the device password, I can type on the onscreen keyboard, the keys light up and I hear the click sound, but nothing arrives in the password dialog. Only a factory reset solves the problem.

    So it seems I do something which provokes this problem. I'm working on a standard iMac with OS X 10.10.1, I have the most recent BB software installed, I'm trying to develop an app with Momentics and tried to sideload a BAR file with the BB10 Chrome extension.

    Very strange, isn't it?
    12-09-14 02:40 AM
  6. Taigatrommel's Avatar
    Something similar, yet fortunately not as bad happened on my Passport yesterday: I was just typing in a Whatsapp conversation, when the keyboard stopped working all of a sudden. The virtual row wouldn't even appear, that showed in every single app. Strange enough I was still able to use shortcuts within apps, like creating a mail inside the Hub.
    Luckily a simple reboot solved the problem.

    If the problem keeps happening on your Passport, I'd claim warranty and get a replacement.

    Posted via CB10
    12-09-14 02:48 AM
  7. Julian Buss's Avatar
    In my case a reboot does not solve the problem, only factory reset. And I see the virtual keyboard, and the keys on it light up just fine when typing, other than that nothing happens.
    12-09-14 02:51 AM
  8. balenax's Avatar
    What os version do you have installed? Did you perform a clean installation or upgraded an older one? Did you restore any backup? Keep in mind that installing leaks and restoring backups, specially when jumping over versions, might get pretty evil. If you did install a leak/ restore an older backup I would do a clean (autoloader) installation and set up everything from scratch. If you didn't and use the offcial version then it might really be a faulty unit. I would try to do a clean installation anyways, just in case.

    Sent via my square wonder thingie
    12-09-14 03:33 AM
  9. bakron1's Avatar
    sounds like faulty unit to me
    +1
    12-09-14 03:47 AM
  10. Julian Buss's Avatar
    My Passport uses the most recent 10.3 OS, the Z10 uses 10.2.2.984.

    The Passport was a clean install about two months ago, I made backups from that install and restored the backups after the failure.
    The Z10 was a clean install about two weeks ago and no backups were restored since.

    A doubt that both units are faulty. I can believe that I got a faulty Passport, but a Passport AND a Z10 and both faulty?
    It seems that I do something that causes this fault, but I have no idea what :-)

    The Passport had this problem three times so far (in about two months):
    - first time at home when it was attached to the power cord
    - second time on the road, I placed it on a table, took it ten minutes later and then the problem was there
    - third time at home shortly after I tried to deploy an app from Momentics IDE

    The Z10 had this problem once so far (in about two weeks) when it was attached to the computer with the USB cord, shortly after I tried to connect it to BlackBerry Link in a virtual machine running Windows 8 and shorty after I connected it to my WLAN.

    So there is no clear pattern yet.

    balenax: is a clean install something else then doing a factory reset via BlackBerry Link?
    12-09-14 04:45 AM
  11. jgrobertson's Avatar
    Twice my keyboard did not light up at night. A restart fixed it. Running 10.2.0.1418

    Posted via CB10
    12-09-14 04:50 AM
  12. Julian Buss's Avatar
    that's different, in my case the keyboard does light up, and I hear the click sound when tapping virtual keys.
    12-09-14 04:55 AM
  13. balenax's Avatar
    By a clean install I mean installing an os with autoloader (you can find all the versions in the leak section, even the official ones) and not restoring any backups. Nothing. Just make all the settings and installations manually. I also find it hard to believe that both devices are faulty.

    Sent via my square wonder thingie
    12-09-14 06:06 AM
  14. mrpjer's Avatar
    I know this was a long time ago, but this is one of the rare threads that I found relevant to my problem.

    My Passport's keyboard stopped working as well. Physically, everything was fine as keyboard shortcuts worked fine and I could scroll with the keyboard, but I wasn't able to enter any text anywhere, neither with the physical keyboard, not with the software one. Also, switching the symbols was very slow.

    An additional problem that I had was that the device would not connect to any data services without WiFi.

    This all happened after turning the device off and then turning it back on. I do this rarely so it was really hard to remember what changed since the last reboot. The device was running the latest available release, 10.3.2.2474.

    I've tried a lot of things, but the comments about developing posted here made my try removing the debug token from the device. And, after a restart, everything was back to normal.

    This can be done by going into Settings -> Security and Privacy -> Development Mode -> Remove debug token.

    I'm a bit sad that I deleted my learned predictions in an attempt to fix this, so I'm posting this so that anyone else with the same problem knows that there may not be any need for reloading the OS or deleting data.
    Last edited by mrpjer; 11-23-15 at 02:08 PM.
    11-23-15 01:46 PM

Similar Threads

  1. Why is my device rebooting when I install updates?
    By swapnil_117 in forum BB10 Leaked/Beta OS
    Replies: 9
    Last Post: 11-25-14, 12:03 PM
  2. Replies: 2
    Last Post: 11-25-14, 10:36 AM
  3. Keyboard size comparisons - bold vs classic
    By Lee Eshelman in forum BlackBerry Z30
    Replies: 1
    Last Post: 11-25-14, 07:42 AM
  4. Why don't some of my bbm contact profile pictures update?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-25-14, 07:35 AM
  5. BlackBerry announce new partnerships to help monetize BBM
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 11-25-14, 04:40 AM
LINK TO POST COPIED TO CLIPBOARD