1. maxym's Avatar
    After factory resetting my BB Passport (due to battery drain being higher then usual), and restoring from two backups (first from initial full backup, and after that restoring some apps from second backup), I cannot connect with BB Link over WiFi. Wired connection works fine, but when USB is disconnected, link cannot be established over WiFi.

    In recent activity I have periodic message: 'Unable to save name', but name of my Passport is same in BB Link, and on device.

    At the same time, BB Blend works perfectly over WiFi, and mobile data connection too.

    Is there a way to solve this without doing Factory Reset, and restoring from backup again?!
    10-08-15 05:02 AM
  2. HereticHermit's Avatar
    Try to reinstall the Link and Blend again and see you have latest version.
    Also give a hard restart to Passport.
    Unable to save name Link msg sometime appears with fresh OS update or after a security wipe. But it gets sorted once phone link up with Link.
  3. HereticHermit's Avatar
    Try to reinstall the Link and Blend again and see you have latest version.
    Also give a hard restart to Passport.
    Unable to save name Link msg sometime appears with fresh OS update or after a security wipe. But it gets sorted once phone link up with Link.
    10-08-15 06:00 AM
  4. maxym's Avatar
    Thanks, I'll try, reinstalling BB Link (Blend works flawless). I wouldn't like to do another hard reset, if I don't have to.

    I remember that even after the restore I had strange message on PC where it said: Waiting for device to restart, do not disconnect device; but my Passport was already restarted and working.

    It seems to me as if there is still old generic device name (the one assigned automatically after first installation) somewhere in BlackBerry Link WiFi setings, and it refuse to rename it to current name. I was watching in registry editor but couldn't find anything useful.

    I hope BlackBerry Link reinstalling will do the trick.

    Posted via CB10
    10-08-15 06:37 AM
  5. HereticHermit's Avatar
    You can also delete/forget the device showing in Link. Repairing with link again should do the trick. BB quirks and gremlins are a complex lot with no real straight forward solutions sometime, so guesswork and 6th sense plays a good role here !
    Blend and Link software are bundled together that's why I said try reinstalling both.
    When ever you securirty wipe or do a fresh install, don't let the phone remain connected via USB to your comp once the Boot screen comes up. Disconnect and let the phone do its usual drill, set up the phone normal and only in end connect to link on PC.
    10-08-15 11:14 AM
  6. maxym's Avatar
    I did Factory Reset, and restored one of my previous backups (along with second restore of additional programs), and after all that both connections worked (USB and WiFi), but as soon as I left area with my WiFi signal, and came back, I lost ability to connect to BB Link via WiFi.

    There is still message: Unable to save the name... but same message appeared in Sync Activity while I was able to connect to Link with wireless connection

    Blackberry Blend works perfectly, but I had 'side effect', in BlackBerry Blend configuration screen, I had two lines with same computer name (my home PC), first is active, and second was obviously some garbage remained after all this fiddling with Backup/Restore, so I deleted it.

    It doesn't bother me a lot (since Blend works, and I usually use Link with USB) but I would prefer if it would work as it is supposed to.
    10-08-15 12:50 PM
  7. HereticHermit's Avatar
    Sorry to hear your predicaments are not over. If you are fine working with blend but no Link then keep things as they are for now. But I would have earmarked a lazy Sunday for a security wipe and reinstall the apps and contacts list without restoring from backups. Something goes wrong with backup and it stays. every time you install from backup, the issues comes back like a virus in hiding. Fresh app install usually does the trick. Good luck
    10-09-15 11:21 AM
  8. eyeb's Avatar
    I get this when I load new os each time. Haven't figured out how to fix it yet. Sometimes I can mount drives from the icon on taskbar, no idea what it is called. Then link works afterward
    10-09-15 11:39 AM
  9. moody's Avatar
    Close Link and unplug phone. Open task manager on your PC and end task for anything relating to Link, BlackBerry, Blend, RIM, etc.

    Open link and make sure access via wifi is toggled on and check phone settings to be sure it's toggled on.

    Give Link a few minutes to activate and you should see it connect.

    Passport & Z30 & Q10 Can't imagine life without Blackberry
    maxym likes this.
    10-10-15 05:28 PM
  10. maxym's Avatar
    Thanks moody, but it didn't work.

    I'll make Factory Reset, and manually install all programs and do the configuration, since it's still fresh device, and there is not so much things to do.

    I suspect problem appeared because of device name has changed, and during restoring some internal settings are corrupted and system cannot update my current device name.
    10-12-15 01:07 PM
  11. maxym's Avatar
    Unfortunately, even after Factory Reset, and manual setup & installation of my programs, WiFi BB Link connection worked for a while, but now it work on USB cable only.

    I'm still guessing that something went wrong after device rename (rename inside BB Link desktop app, and on Passport in Settings - About device).

    As I already said, it's not big deal because Backup&Restore only works over the cable, and I don't use WiFi folder synchronization, and BB Blend is not affected with this, but I would still like if it would work as intended.
    11-17-15 03:40 AM
  12. maxym's Avatar
    *** BREAKING NEWS **** BB Link over WiFi works again!!!

    Since the last time, I didn't used BB Link at all (because it worked only via USB cable), and today, I started BB Link, as usually my device was shown greyed out (not connected), and suddenly, it connects via WiFi and starts synchronizing stuff...

    What has happened, I don't have clue, but probably something PC related, and it 'auto-solved' maybe with power-off-on, or due to some system update. Important thing is: it works now.

    Folks, thanks for all constructive comments.
    01-08-16 11:39 AM

Similar Threads

  1. Switching from classic to Passport
    By Jamal Abuhijleh in forum BlackBerry Passport
    Replies: 20
    Last Post: 10-13-15, 02:59 PM
  2. Blackberry Passport (White) - unlocked (EU)
    By sweeperdk in forum Buy, Sell, Trade - Sold / Archived
    Replies: 5
    Last Post: 10-12-15, 05:08 PM
  3. Blackberry Passport water damage
    By Harshad Dombe in forum Ask a Question
    Replies: 4
    Last Post: 10-10-15, 07:34 PM
  4. Would a BB Bold still be completely functional/compatible to use today??
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 10-09-15, 01:30 AM
  5. Unable to remove devices associated to BlackBerry ID
    By stefanbechen in forum General BlackBerry Discussion
    Replies: 0
    Last Post: 10-08-15, 02:58 AM