1. Jp Gallard's Avatar
    Hi, has anybody encountered that problem with their BB passport, yesterday I was on the phone and turned my navigation system and then I lost may radio no more signal cant make any call and a message appears (unknown internal error) and when I check my sims card is says from unknown source, so I changed the sims card and the message error is still there, thank you
    12-11-14 12:57 PM
  2. achiquitachaser's Avatar
    any chance you found a solution? My passport has also just encountered this issue
    12-24-14 11:46 AM
  3. achiquitachaser's Avatar
    Yeah I get this as well.

    Steps that I have taken that did not work
    Hard Reset
    Security Wipe
    Autoloader for both 10.3.0 and 10.3.1 (several different oses)
    SIC Multi wipe and reload through autoloader
    Used Link to restore official OS

    No luck yet, if anyone has any suggestions please let me know.

    Sent from my Z30 using Tapatalk
    12-24-14 04:13 PM
  4. achiquitachaser's Avatar
    Why am I getting an error message?-img_20141224_170027_hdr.jpg

    Posted via CB10
    12-24-14 05:55 PM
  5. conite's Avatar
    Looks like a provisionning problem with your carrier.

    Z30STA100-5/10.3.1.1154
    12-24-14 06:01 PM
  6. achiquitachaser's Avatar
    Even tried on att and t-mobile no luck

    Posted via CB10
    12-24-14 06:07 PM
  7. conite's Avatar
    Even tried on att and t-mobile no luck

    Posted via CB10
    Call your carrier and have them re-provision.

    Z30STA100-5/10.3.1.1154
    12-24-14 10:42 PM
  8. achiquitachaser's Avatar
    no luck with with the reprovision. Ive got a call into blackberry support, thanks for your help.
    12-25-14 06:54 AM
  9. homer1475's Avatar
    SIM card failure? Tried a different SIM card?

    Or perhaps its the card reader that has failed?
    12-25-14 07:05 AM
  10. achiquitachaser's Avatar
    nope not a problem with the sim since ive used two different ones, and this a problem with the phone itself. It should say sim not installed not a red x and unknown error. and should not be stuck in a constant reboot loop
    TrueKulcha likes this.
    12-25-14 07:59 AM
  11. TrueKulcha's Avatar
    Same problem here Nd I've tried everything in the book that I can think of. It started off by not allow any mobile services so I tried changing from lte to 4g to 3g all with no luck. Next it wasn't seeing the SIM as same message as above saying SIM from unknown. When I go to device monitor cpu is not opening. The phone is almost behaving as if it's locked but when I go to privacy and security and SIM card it shows nothing. Hardware problem I think and BlackBerry needs to address this ASAP

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    12-27-14 08:32 PM
  12. achiquitachaser's Avatar
    I recommend contacting BlackBerry Support, I had to RMA mine.
    12-27-14 10:56 PM
  13. GreenCopperz's Avatar
    Hopefully an isolated issue, too bad it happened to you guys. Keep the forums up to date with any findings if any are provided.

    Z30STA100-5/10.2.1.3247
    12-27-14 10:58 PM
  14. TrueKulcha's Avatar
    I recommend contacting BlackBerry Support, I had to RMA mine.
    Do you have any contact information for BlackBerry support? This is so annoying because for all my years using BlackBerry phones this has never happened to me. While rebooting there's no message about verifying and securing BlackBerry 10 as per normal either. Just so many indications that something is seriously wrong somewhere be it hardware or software.

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    12-28-14 01:56 AM
  15. achiquitachaser's Avatar
    For North America this is the number I called 1-877-255-2377

    Posted via CB10
    12-28-14 09:43 PM
  16. buwee's Avatar
    For North America this is the number I called 1-877-255-2377

    Posted via CB10
    I don't think this is an isolated issue - just happened on my PP again - (This is the third PP that has done this) This latest PP has been working flawlessly for about 4 weeks and today all of a sudden the dreaded red X followed by internal error message, then sim card not detected error even though the sim card was in the phone. I rebooted, took sim card out and put it back in but nothing worked so it's going back to Telus again. BTW - I put the same sim card in my Classic, then my Z30 and my Note 4 and it worked on all of these phones. I think the Passport has a really crappy sim card reader and it seems like if you look at it the wrong way it fails. Despite loving the PP I think after I get it repaired or replaced I'm done with the phone because of the sim card reader (I don't want to be having to deal with this on a monthly basis nor do I want to be caught having this happen while I'm travelling)
    01-07-15 01:09 AM
  17. TrueKulcha's Avatar
    This is a hardware issue. We have two older threads on this very same problem. Only alternative is to have these phones repaired or exchanged. I've literally driven hundreds of kilometres back and forth, spent endless hour's on phone with Rogers and BlackBerry both. Passport seems to be infected by an age old Z10 bug if you ask me.
    I've seen one instance where someone was successful in reviving their device through an updated version of Link with an OS reload so if you folks want to try that it's may be worth it.
    I've also noted that BBVE picks up nothing on my phone so my early suspicion is that the RAM is corrupted. After one of my reloads my mobile signal came on for about a minute or so but nothing since.
    Take your phones back to your carrier or place of purchase for an exchange where possible. If you are unable to do that somehow and got your devices through private sale or amazon etc I'll be able to provide BlackBerry contact information for those who need ok.

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    01-07-15 05:39 AM
  18. anon(870071)'s Avatar
    Rogers Blackberry support after asking you a few questions would have ok'd a replacement. But due to timeline you wouldn't be getting a brand new one, but a refurbished replacement. They are like new in gray market packaging

    Posted via CB10
    01-07-15 06:12 AM
  19. TrueKulcha's Avatar
    The major carriers in Canada all have what I'd consider a pretty straightforward return / exchange policy if you are an account holder and the device is one from their network originally, regardless of proof of purchase or anything like that. Now if the phone came from one of the agents like uptown communications for example and you're not the original owner/ registrant then you're in for a rough ride. Amazon Canada phones would fall under the latter category as well.
    BlackBerry Technical support has been nothing short of classy in all my dealings with them but initially it's not easy for the person off the street or end user to reach these folks without a "ticket number" for example.
    Bottom line is though, I'm hoping for a speedy solution to this issue and hope BlackBerry nips it in the bud before too many phones fall prey to whatever bug this may me.

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    01-07-15 09:17 AM
  20. anon(870071)'s Avatar
    Radio issues (hardware)is albeit rare but it does happen by the fact that it's a mobile device with very tiny parts inside!

    Posted via CB10
    01-07-15 10:42 AM
  21. TrueKulcha's Avatar
    Radio issues (hardware)is albeit rare but it does happen by the fact that it's a mobile device with very tiny parts inside!

    Posted via CB10
    Yes a few issues here and there can be expected but it's magnified when it happens to one of your devices lol. I bought another from shop bb during the boxing day sale and that one has been flawless so far. The phone in general is so much more zippy, so conclusion is that the first one definitely is a faulty unit.

    NewsFlash! The highest rankin g American citizen is using a BlackBerry
    01-07-15 10:51 AM
  22. YUUUUP's Avatar
    Same problem here!! Unplugged the phone off the charger and powered it on. Got the red X and unknown error. Phone keeps re booting. Tried a new sim a security whip and reload the os still still got the red X. Phone was working perfectly for three months. Bought it directly from shop blackberry.

    Posted via CB10
    02-07-15 09:58 AM

Similar Threads

  1. BB Assistant; Useful or just frustrating waste of time?
    By Tim Smith2 in forum Ask a Question
    Replies: 6
    Last Post: 03-10-15, 12:45 PM
  2. Surprising BB World app update -- Greater Anglia Tickets
    By jamescarruthers in forum PlayBook Apps & Games
    Replies: 2
    Last Post: 12-13-14, 11:13 PM
  3. How do I share a video on Whatsapp above the 16mb on BB Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-11-14, 07:49 AM
  4. How do i create a signature on my BB Passport?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-11-14, 06:07 AM
  5. Replies: 2
    Last Post: 12-10-14, 11:35 PM
LINK TO POST COPIED TO CLIPBOARD