1. nucks26's Avatar
    I know Link takes forever to backup / restore a device. My passport should arrive and I wanted to know the most efficient way to transfer my data. Is the device switch app even made by blackberry? Is it reliable and secure? And is it faster? If so should I just use link anyways? Seems more secure to me.

    Posted via CB10 for Q10
    10-11-14 12:11 AM
  2. Mirk's Avatar
    I would just use Link... that way you can retain the backup in case you need it later. Also, not sure if the device switch app works going from BB10 to BB10, it seems to say its for legacy devices, Androids, and iPhones.
    10-11-14 12:25 AM
  3. nucks26's Avatar
    I would just use Link... that way you can retain the backup in case you need it later. Also, not sure if the device switch app works going from BB10 to BB10, it seems to say its for legacy devices, Androids, and iPhones.
    Ok. But yes it certainly does work for bb10 to bb10. It will not work with legacy devices because that app isn't available on the old BlackBerry world i believe. It was said in the passport keynote that it's mean for iphone, android, or other bb10 devices to the passport. But i just feel it isn't secure. They actually advertised this app in their keynote and it's not even made by blackberry!! Wtf!? I would feel way more comfortable if it were an app made by blackberry!

    Posted via CB10 for Q10
    10-11-14 12:37 AM
  4. alan510's Avatar
    I first used the device switch and it does not transfer everything that l wanted transferred. Then I used Link. It was quite efficient and the transfer was relatively easy and quick. I'd use Link again.

    Posted via CB10
    10-11-14 12:49 AM

Similar Threads

  1. What will the Z30's successor be?
    By BBMan1121 in forum BlackBerry Z30
    Replies: 19
    Last Post: 10-14-14, 08:14 AM
  2. Is it wise to get a new Z10 at this time?
    By Cheewii Poon in forum BlackBerry Z10
    Replies: 41
    Last Post: 10-14-14, 05:14 AM
  3. Is games app dead?
    By BK_NY_RAY in forum Ask a Question
    Replies: 2
    Last Post: 10-11-14, 03:29 AM
  4. Why Claro Symbol while z10 starting or getting off
    By maYur_O7 in forum Ask a Question
    Replies: 4
    Last Post: 10-10-14, 10:52 PM
  5. Do I have a OMAP or QUALCOM chip?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-10-14, 09:33 PM
LINK TO POST COPIED TO CLIPBOARD