1. FabriciusFab's Avatar
    I recently moved to another country and now my location icon appears on the top of the screen almost non-stop.
    The battery drain because of this is huge, and I can't seem to find a way to pinpoint which app or service is constantly asking for the location.
    Is there a way to know this? the "Location services" tag offers no additional information about this and I'd really like to know.
    Thanks!
    08-06-20 06:18 AM
  2. conite's Avatar
    I recently moved to another country and now my location icon appears on the top of the screen almost non-stop.
    The battery drain because of this is huge, and I can't seem to find a way to pinpoint which app or service is constantly asking for the location.
    Is there a way to know this? the "Location services" tag offers no additional information about this and I'd really like to know.
    Thanks!
    Did you reboot the phone?
    08-06-20 06:30 AM
  3. FabriciusFab's Avatar
    Did you reboot the phone?
    couple of times, both soft and hard pressed-16-seconds-buttons resets
    08-06-20 09:18 AM
  4. conite's Avatar
    couple of times, both soft and hard pressed-16-seconds-buttons resets
    Just toggle off location services (in quick settings) for a bit.
    08-06-20 09:46 AM
  5. FabriciusFab's Avatar
    Just toggle off location services (in quick settings) for a bit.
    Done that all day and now the minute I turn them on it starts again showing the small icon every time.

    Any way to check for what I was asking in the first place?
    08-08-20 11:26 AM
  6. brookie229's Avatar
    Done that all day and now the minute I turn them on it starts again showing the small icon every time.

    Any way to check for what I was asking in the first place?
    Curious - what happens to that icon if you pull the sim out and just use wifi?
    08-08-20 11:36 AM
  7. conite's Avatar
    Done that all day and now the minute I turn them on it starts again showing the small icon every time.

    Any way to check for what I was asking in the first place?
    Apart from looking at your battery use by app, not specifically.
    08-08-20 11:36 AM
  8. FabriciusFab's Avatar
    Curious - what happens to that icon if you pull the sim out and just use wifi?
    Same thing. Actually I was first using it without the sim and I thought that it might have had to do with that, but it's been a few weeks with the sim in and it's been the same
    08-08-20 11:51 AM
  9. FabriciusFab's Avatar
    Apart from looking at your battery use by app, not specifically.
    I've stopped every app that has had any activity over the last 48 hours but still have this. Guess I'll have to figure out something.
    Thanks anyway
    08-08-20 11:52 AM
  10. conite's Avatar
    I've stopped every app that has had any activity over the last 48 hours but still have this. Guess I'll have to figure out something.
    Thanks anyway
    Maybe something is buggered in the system. You may need to resort to an autoloader.
    08-08-20 11:53 AM
  11. FabriciusFab's Avatar
    Maybe something is buggered in the system. You may need to resort to an autoloader.
    I'll try that later down the road and I'll report if that solved it. Thanks again

    </Passport SQW100-1>
    08-10-20 06:06 AM
  12. dmlis's Avatar
    I had the problem with the battery drain caused by Location Services on two BB10 phones. On both, the drain began after several months of usage, absolutely unexpectedly. What was ironic, it was higher when the bedside mode was on. The only solution for me was to keep Location Services off unless I needed it for any specific reason.
    08-22-20 05:49 AM
  13. Ben xfg's Avatar
    I'll try that later down the road and I'll report if that solved it. Thanks again

    </Passport SQW100-1>
    Do you have "send diagnostics and usage data" active? Settings, Security and Privacy, Diagnostics. I like to keep it off but unsure if it will solve your issue here.
    brookie229 likes this.
    08-22-20 07:16 AM
  14. FabriciusFab's Avatar
    Do you have "send diagnostics and usage data" active? Settings, Security and Privacy, Diagnostics. I like to keep it off but unsure if it will solve your issue here.
    I did. Now I'm gonna turn it off for a few days and see if it helps in some way.
    Thanks for the suggestion

    </Passport SQW100-1>
    08-22-20 07:40 AM
  15. FabriciusFab's Avatar
    I did. Now I'm gonna turn it off for a few days and see if it helps in some way.
    Thanks for the suggestion

    </Passport SQW100-1>
    It did not.

    Thanks for your suggestions but there's still something frequently accessing my location and I can't pinpoint what it is
    09-03-20 06:34 AM
  16. mikael11's Avatar
    It did not.

    Thanks for your suggestions but there's still something frequently accessing my location and I can't pinpoint what it is
    Is your phone able to find your location, i.e. via blackberry maps?

    Posted via CB10
    09-12-20 02:58 PM
  17. FabriciusFab's Avatar
    Is your phone able to find your location, i.e. via blackberry maps?

    Posted via CB10
    Actually I was realizing that it couldn't, so I ran an autoloader. I did this yesterday and till today the location icon is not appearing like crazy and because of that battery life improved a lot.

    However running BBVE I was getting very few satellites in my list, something that didn't happen before. I don't know if me moving from rural area of South America to a building in Spain has anything to do with it or its just that the phone is breaking down.

    I don't know if you have a similar experience or it was just for troubleshooting purposes

    </Passport SQW100-1>
    09-12-20 03:21 PM
  18. Chuck Finley69's Avatar
    Actually I was realizing that it couldn't, so I ran an autoloader. I did this yesterday and till today the location icon is not appearing like crazy and because of that battery life improved a lot.

    However running BBVE I was getting very few satellites in my list, something that didn't happen before. I don't know if me moving from rural area of South America to a building in Spain has anything to do with it or its just that the phone is breaking down.

    I don't know if you have a similar experience or it was just for troubleshooting purposes

    </Passport SQW100-1>
    Could there be compatibility issues from LATAM to EU for your specific model?
    09-12-20 03:30 PM
  19. mikael11's Avatar
    Actually I was realizing that it couldn't, so I ran an autoloader. I did this yesterday and till today the location icon is not appearing like crazy and because of that battery life improved a lot.

    However running BBVE I was getting very few satellites in my list, something that didn't happen before. I don't know if me moving from rural area of South America to a building in Spain has anything to do with it or its just that the phone is breaking down.

    I don't know if you have a similar experience or it was just for troubleshooting purposes

    </Passport SQW100-1>
    Just troubleshooting - that a reason for the gps to be always on could be that it couldn't find anything. Few satellites if you're outside too?

    Posted via CB10
    09-13-20 01:45 AM
  20. FabriciusFab's Avatar
    Just troubleshooting - that a reason for the gps to be always on could be that it couldn't find anything. Few satellites if you're outside too?

    Posted via CB10
    It varies, sometimes I get 11 in less than a second but the other day it would detect 3 and prompt me to have a clear view of the sky even though I was in the passenger seat of a car.

    I may have to tear it apart to see if I have a bad contact with the back case.

    Thank you for your suggestions

    </Passport SQW100-1>
    mikael11 likes this.
    09-13-20 06:19 AM

Similar Threads

  1. Pixel 4a as replacement for my BB?
    By laid-back in forum BlackBerry Priv
    Replies: 49
    Last Post: 03-01-21, 10:03 AM
  2. What helps you appreciate BlackBerry Z10?
    By Lili Chirtina in forum BlackBerry Z10
    Replies: 21
    Last Post: 08-15-20, 12:49 PM
  3. My KEYONE is "irreparable" according to repair shop. What to do about it?
    By something4uor4me in forum BlackBerry KEYone
    Replies: 9
    Last Post: 08-11-20, 02:12 PM
  4. My Priv is no longer working.
    By Gigi Malone in forum BlackBerry Priv
    Replies: 13
    Last Post: 08-11-20, 07:43 AM
  5. Apps still work fine in 2020?
    By RUSHHUSH in forum BlackBerry 10 Apps
    Replies: 4
    Last Post: 08-06-20, 02:49 AM
LINK TO POST COPIED TO CLIPBOARD