10-29-14 11:12 AM
61 123
tools
  1. anon721037's Avatar
    How would I load an older radio file to see if the problem is software related?

    Posted via CB10
    The problem is there isn't to many out for the passport yet. The fix will probably come in a new os coming out later.

    Official pain in the **** of the peevishlicious crew.
    10-19-14 06:16 PM
  2. BCLoco's Avatar
    Well, I was skeptical, but it does appear that the Z30 gets better reception than the Passport:

    Weak Signal Help needed-img_20141019_213429.png
    Weak Signal Help needed-img_20141019_213501.png

    The difference is minimal, and certainly hasn't affected my use of the phone.

    I took the screen shots with the phones side-by-side. Both phones are on the Telus network.

    Posted via PassportSQW100-1/10.3.0.1052 on CB10!
    10-19-14 09:41 PM
  3. anon721037's Avatar
    Yes and when the Z30 came out I had the same problem, but with every new OS they seem to get better.

    Official pain in the **** of the peevishlicious crew.
    10-19-14 09:54 PM
  4. rai187's Avatar
    Yeah I don't mind the fact I have less bars. It is just annoying when I have no signal in areas my Z10 would have signal. I am in those areas a lot.

    Posted via CB10
    10-19-14 10:06 PM
  5. Adif_70's Avatar
    Does radio signal go to a power save mode when phone is connected to wifi. Does not mean you will drop a call just saving battery. Try turning wifi off to see if that makes a difference. Really not an issue maybe.
    Also I tried one less setting as per below and that helped.

    Posted via CB10
    10-19-14 10:23 PM
  6. anon721037's Avatar
    Try changing your settings down one.



    Weak Signal Help needed-img_20141019_212349.png

    Official pain in the **** of the peevishlicious crew.
    10-19-14 10:24 PM
  7. Adif_70's Avatar
    No. I definitely get full bars once wifi is off. if you do. A search on Google for low signal when wifi is on you see many phones use a low power state when both are on. Does not drop calls.

    Posted via CB10
    10-19-14 10:29 PM
  8. rai187's Avatar
    I've tried one setting down, it is helpful in some situations.

    Any way I can install a different radio file to ensure it is a software issue rather then hardware?

    Posted via CB10
    10-22-14 01:18 AM
  9. MikeyJSydney's Avatar
    I've tried one setting down, it is helpful in some situations.

    Any way I can install a different radio file to ensure it is a software issue rather then hardware?

    Posted via CB10
    Is your Passport working any better?

    My one seems to be having a few issues at home too.

    Sometimes the signal shows 3G or 3.5G, even 4G with one bar, but once I try to connect to the internet or make a call it doesn't work, says "call failure".

    Sometimes when I turn on flight mode and turn it off, it shows an SOS message that there is no signal, which makes me kinda worried.

    I am thinking it may be the sim? I don't have another phone that uses a nano-sim to try it out though, unfortunately.
    10-27-14 01:36 AM
  10. will308's Avatar
    Yes and when the Z30 came out I had the same problem, but with every new OS they seem to get better.

    Official pain in the **** of the peevishlicious crew.
    I had a better signal on my passport with the os that it was shipped with
    10-27-14 02:28 AM
  11. rai187's Avatar
    Is your Passport working any better?

    My one seems to be having a few issues at home too.

    Sometimes the signal shows 3G or 3.5G, even 4G with one bar, but once I try to connect to the internet or make a call it doesn't work, says "call failure".

    Sometimes when I turn on flight mode and turn it off, it shows an SOS message that there is no signal, which makes me kinda worried.

    I am thinking it may be the sim? I don't have another phone that uses a nano-sim to try it out though, unfortunately.
    Still having issues. Unfortunately I don't think it is my sim as I have tried a different provider sim and the connection is still weak. The other sim typically gets full bars for LTE on the iPhone 5 so this is definitely an issue.

    Posted via CB10
    10-27-14 04:13 AM
  12. will308's Avatar
    try installing radio 10.3.0.1053 I get very good signal with this
    10-27-14 12:11 PM
  13. rai187's Avatar
    try installing radio 10.3.0.1053 I get very good signal with this
    How would I do that?

    Posted via CB10
    10-27-14 12:23 PM
  14. will308's Avatar
    How would I do that?

    Posted via CB10
    you can use sachesi to load the bar file there is a thread on it already........Sachesi Tutorial: How to install the latest OS as an Update this thread is on this site
    10-27-14 03:40 PM
  15. rai187's Avatar
    I downgraded to the 1053 radio and still no improvement.

    Posted via CB10
    10-28-14 03:03 AM
  16. scrannel's Avatar
    It may be better to wait for an OTA update. Especially since their own survey asks about signal. They must realize there is an issue.
    10-28-14 05:17 AM
  17. will308's Avatar
    I downgraded to the 1053 radio and still no improvement.

    Posted via CB10
    dam not good...............sorry to hear that its no better I have to say im running it and my signal is 100 times better than with the radio from 10.3.0.1418
    10-28-14 07:30 AM
  18. Cojaeck's Avatar
    Hi. I'm experiencing the same problem. I'm on OS 908 with radio 1419. The Z10 of my colleague has definitive better reception. E.g. I just have 2G, while the Z is on 4G. I have the red x and the Z has reception. Turning WiFi off does not help at all. I had the issues with the initial rom also. Hope BlackBerry will become aware off the problem and is able to fix it via software...and I don't think it's my sim, cause in my Z10 it works perfect. Aaaargh...

    Posted via CB10
    10-28-14 10:54 AM
  19. anon721037's Avatar
    I downgraded to the 1053 radio and still no improvement.

    Posted via CB10
    Try this radio, and see if it helps,

    http://l.bitcasa.com/VOQ8OI0K
    10-28-14 08:23 PM
  20. rai187's Avatar
    Try this radio, and see if it helps,

    http://l.bitcasa.com/VOQ8OI0K
    How would I get this to work as it isn't a bar file?

    Posted via CB10
    10-28-14 09:24 PM
  21. anon721037's Avatar
    How would I get this to work as it isn't a bar file?

    Posted via CB10
    It's a radio autoloader so it's non destructive, will do nothing to your info, you unzip it and plug your phone into you PC and double click on the exe file you get when you unzip.
    10-28-14 09:42 PM
  22. rai187's Avatar
    It's a radio autoloader so it's non destructive, will do nothing to your info, you unzip it and plug your phone into you PC and double click on the exe file you get when you unzip.
    Okay thank you. I will try that

    Posted via CB10
    10-28-14 09:49 PM
  23. anon721037's Avatar
    Okay thank you. I will try that

    Posted via CB10
    If you have a problem or a question just PM me. I'll give you my pin.

    Official pain in the **** of the peevishlicious crew.
    10-28-14 10:03 PM
  24. rai187's Avatar
    If you have a problem or a question just PM me. I'll give you my pin.

    Official pain in the **** of the peevishlicious crew.
    Thanks for all your help. Still a bad quality signal. I believe I have a defective Passport. My signal quality sucks and battery doesn't get through the evening with medium/low usage.

    Posted via CB10
    10-28-14 10:11 PM
  25. anon721037's Avatar
    Thanks for all your help. Still a bad quality signal. I believe I have a defective Passport. My signal quality sucks and battery doesn't get through the evening with medium/low usage.

    Posted via CB10
    What provider you on. And the last update did you do it OTA or by sachis.

    Official pain in the **** of the peevishlicious crew.
    10-28-14 10:16 PM
61 123

Similar Threads

  1. A friend needs Spotify and Instagram...are these reliable on BlackBerry 10?
    By BenjaminTheDonkey in forum Android Apps (Amazon Store & APK Files)
    Replies: 8
    Last Post: 11-20-14, 06:11 AM
  2. Where can I find an orginal LCD display for a BB 9720?
    By abdullah nayeem in forum BlackBerry 9720
    Replies: 2
    Last Post: 10-24-14, 03:02 AM
  3. Need help!!
    By Jaivik in forum Ask a Question
    Replies: 1
    Last Post: 10-18-14, 08:02 AM
  4. File messages on passport needs 2 clicks
    By jacla in forum BlackBerry 10 OS
    Replies: 1
    Last Post: 10-18-14, 06:44 AM
LINK TO POST COPIED TO CLIPBOARD