1. sbrylski's Avatar
    Does anyone else have problems watching videos on Vimeo? The page loads and everything but the video never starts playing

    Posted via CB10
    10-02-15 09:17 PM
  2. bb8900edit's Avatar
    Just tried it, works fine on my passport

    From my Jamaican Passport
    10-02-15 09:49 PM
  3. sbrylski's Avatar
    Well fack doesn't on my PP

    Posted via CB10
    10-02-15 10:29 PM
  4. joshua_sx1's Avatar
    Vimeo-img_20151003_222541.png


    Vimeo-img_20151003_222703.png

    There must be something wrong with your Passport or with your browser (in particular)...

    Posted via CB10
    10-03-15 02:30 PM
  5. eldricho's Avatar
    Try and clear your browser cookies and if that doesn't work also try clearing your history.

    Posted via CB10
    10-03-15 02:40 PM
  6. sbrylski's Avatar
    Cleared cookies and history still nothing.. what could possibly be wrong with my particular passport to make something like this occur? I've had no problems with anything else

    Posted via CB10
    10-03-15 04:38 PM
  7. Emaderton3's Avatar
    Cleared cookies and history still nothing.. what could possibly be wrong with my particular passport to make something like this occur? I've had no problems with anything else

    Posted via CB10
    Mine also stopped working a while ago, and I have a Q10.

    Posted via CB10
    09-29-16 09:03 AM
  8. brookie229's Avatar
    Cleared cookies and history still nothing.. what could possibly be wrong with my particular passport to make something like this occur? I've had no problems with anything else

    Posted via CB10
    Is your browser in desktop mode?
    09-29-16 12:28 PM
  9. Emaderton3's Avatar
    Mine is not. Does it need to be?

    Posted via CB10
    09-29-16 05:07 PM

Similar Threads

  1. Vimeo App
    By ZedAlpha in forum BlackBerry 10 Apps
    Replies: 1
    Last Post: 03-22-14, 08:36 AM
  2. Replies: 3
    Last Post: 11-06-13, 02:54 PM
  3. Does vimeo.com work in Z10 browser?
    By notafanboy in forum BlackBerry Z10
    Replies: 9
    Last Post: 04-21-13, 02:30 AM
  4. Trouble Playing Vimeo Videos
    By Benjamindaines in forum BlackBerry Bold 9930/9900
    Replies: 1
    Last Post: 02-05-12, 11:01 AM
  5. WATCH!!! Vimeo/HTML 5 Error on Torch 9810
    By moe1up in forum General BlackBerry Discussion
    Replies: 0
    Last Post: 11-18-11, 01:00 AM
LINK TO POST COPIED TO CLIPBOARD