1. kawikaratekid's Avatar
    Hello all,

    I'm having trouble with my Passport. When I plug it in, it says USB not recognized. I've tried deleting Link and loading it again, I've tried a different USB cable, I've tried all four ports, I've tested the ports with other devices to ensure they work as intended, I've rebooted the phone and plugged it in when it's just turning on, I've turned it off and turned it on while it was plugged in, I've rebooted my computer with it unplugged and rebooted it with it plugged in, I've tried to fix the unknown error in the device manager by uninstalling it and attempting to reinstall it and I've scanned the device hardware for changes.

    Does anyone have any idea what else I can do? Any help will be appreciated. Thanks
    08-31-15 05:26 PM
  2. tw1g_007's Avatar
    Have you tried getting a new device? Are you under warranty? I believe yours is defective because that problem is really unusual.

     вιaсĸвεггч PP Silver Edition via CB10 (AT&T OS
    08-31-15 05:40 PM
  3. kawikaratekid's Avatar
    I received a refurbished device as a replacement for my screen issues. Neither the old nor the new to me are working.
    08-31-15 07:46 PM

Similar Threads

  1. Replies: 8
    Last Post: 11-29-15, 10:37 PM
  2. Playbook will not complete reboot, how can I get it to boot?
    By CrackBerry Question in forum BlackBerry PlayBook
    Replies: 13
    Last Post: 10-08-15, 04:31 PM
  3. z30 call screen not showing 10.2
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 09-01-15, 06:19 AM
  4. Replies: 5
    Last Post: 08-31-15, 05:52 PM
  5. Replies: 4
    Last Post: 08-30-15, 02:59 PM