1. kev718's Avatar
    I need help fixing this asap all suggestions required

    Posted via CB10
    09-12-15 10:53 AM
  2. serbanescu's Avatar
    I need help fixing this asap all suggestions required

    Posted via CB10
    Try another USB cable asap
    09-12-15 11:02 AM
  3. dvmblues's Avatar
    Change cable, i dont't know what happens but I have had Change cable 4 times.

    Posted via CB10
    09-12-15 01:51 PM
  4. serbanescu's Avatar
    Change cable, i dont't know what happens but I have had Change cable 4 times.

    Posted via CB10
    What do you mean?
    09-12-15 01:59 PM
  5. rebroker2009's Avatar
    Make sure the cable works with another BlackBerry 10 phone first

    Blackberry Passport running 10.3.2.2639
    09-12-15 02:26 PM
  6. Al moon's Avatar
    Maybe it's the phones charging port and not the cable

    Posted via CB10
    09-12-15 02:33 PM
  7. robsteve's Avatar
    Try rebooting the phone. I had this happen a few weeks ago where I was prompted to use the proper charger even with multiple chargers known to be good. A reboot cured it.


    Posted via CB10
    kw9700 likes this.
    09-12-15 03:34 PM
  8. jpoq's Avatar
    Try the cables first and also the latest update that apparently address 2 specific issues related to the USB port either not charging or not detecting the cable. Here I have the same issue and although changing the cables solved the issue still occurs.
    Have not been able to try the OS update yet.

    Posted via CB10 from Passport
    09-13-15 05:21 AM
  9. nvestn's Avatar
    I am having the same issue.. have been since early August... I was hoping the latest update would fix this but it hasn't. Still can't charge my phone while it is on. The only way I can charge my phone is when I fully power it down. It will not detect being plugged in while it is on. Have tried several cables, etc. My carrier (Telus) pushed 10.3.2.2639 last week... I was hoping it would fix, but it didn't. Still the same thing. I cannot do a wipe and restore since my USB port won't communicate with my PC. Bah!
    09-23-15 10:02 AM
  10. anon9347040's Avatar
    If you have changed the cable 4 times, then your USB port is faulty. Either cracked or cold solder joints. Unit needs service.
    09-23-15 05:32 PM
  11. jpoq's Avatar
    Finally I could update to the latest OS. Using new BlackBerry cables and the update has lessen the occurrence of the issue. Now the phone detects the USB cable and charges, however the time to detection has a slight lag before the charging icon pops out on the screen. Communication with link via USB has been impossible so far, thus had to opt for a backup app and forget about BlackBerry link. As nobody can service a Passport In Japan I will have to wait for a chance to do it abroad.

    Posted via CB10 from Passport
    09-24-15 06:51 AM

Similar Threads

  1. Google play services not installing
    By ritam_s in forum Ask a Question
    Replies: 10
    Last Post: 10-23-15, 04:52 PM
  2. Audio is not working on video record but everywhere else is OK?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 3
    Last Post: 09-18-15, 10:00 AM
  3. Replies: 2
    Last Post: 09-14-15, 01:31 PM
  4. Hotspot still not working
    By ivak110 in forum BlackBerry Z30
    Replies: 2
    Last Post: 09-13-15, 04:51 AM
  5. Windows 10: passport not connecteed to BB Link
    By zou5376 in forum BlackBerry Passport
    Replies: 7
    Last Post: 09-13-15, 01:57 AM
LINK TO POST COPIED TO CLIPBOARD