1. Paul Willcox's Avatar
    Having become completely bored of the usual apple and android stuff, I decided to purchase my first ever blackberry device.

    I got a new SE from Hong Kong via a company called TobyDeals. It took 12 days to arrive and I can confirm that this device is 100% brand new.

    And what a beauty she is!!!

    However, I'm having some trouble with it. I have an EE sim card which works perfectly in another phone. When I put it into the passport I get full signal, full 4g... I can make and receive calls... but anything that requires the Internet is hit and miss.

    So I do a Google search and the results appear. If I click on any of the links I get a network error please try again. This is the same for almost every link but occasionally one will work. Whether this is related or not, the links that do work tend to be https.

    Even if I get the BBC website to load none of the photos load, but again, occasionally one will!

    To confirm my set up, I'm right next to a 4g tower, no WiFi. Device is fully updated.

    I also cannot connect via any apps nor download anything from blackberry world, yet the thumbnails load so I can see the apps but not download them.

    One final piece of info. I phoned EE and spoke about the problem. They said they had to activate blackberry services. They did this and it fixed the problem for about 5hrs before it then all started happening again!!!

    Any ideas what's going on?

    Thank you

    Posted via CB10
    04-15-17 02:33 PM
  2. Niallac's Avatar
    Hi mate. I had exactly the problems you describe when I moved my account from EE to Voda and got a new 4G SIM for my Z30, a few years ago.

    What might help is if you do an Internet search for the correct APN settings for BB10 on EE, then update your APN settings and reboot.

    If that doesn't fix it, then I think you will need to persist on the phone with EE support. The first line guys obviously don't have a clue - it sounds like they think you need any Blackberry Internet Service (which is what they, and Vodafone told me back then, too). That isn't required for BlackBerry10 phones. You need to get through to second line support, who will look at how your account and SIM are provisoned and will be able to fix it for you.

    Posted via CB10
    04-15-17 05:38 PM
  3. Paul Willcox's Avatar
    Thanks for the great advice. I'll have a look around for apn settings to see if it helps. I'm glad it sounds solvable as I was worried it was a hardware fault

    Posted via CB10
    04-16-17 01:44 AM
  4. Paul Willcox's Avatar
    Right, I've had a good search and it appears the correct settings are


    I've tried restarting and a hard reset and the problem remains.

    I've called EE and they asked me to swap my sim card into another phone (android) and of course, it worked perfectly. They then said that it is clearly a hardware fault.

    When I've searched the Web for people with similar issues, they don't seem to get data full stop. Whilst I do get some data perfectly fine. For example I'm writing this on my passport via the crackberry app using my 4g data connection!

    Posted via CB10
    04-16-17 02:32 AM
  5. Paul Willcox's Avatar
    Also the blackberry logo in the top right never appears unless connected to wifi.

    Posted via CB10
    04-16-17 02:33 AM
  6. Paul Willcox's Avatar
    I've also tried a phone wipe to see if it made any difference (but it didnt)

    Posted via CB10
    04-16-17 02:34 AM
  7. Kbreen's Avatar
    Wipe the phone and look for correct apn; sounds APN issue.

    Posted via CB10
    04-16-17 03:15 AM
  8. Paul Willcox's Avatar
    Wipe the phone and look for correct apn; sounds APN issue.

    Posted via CB10
    I did that unfortunately, but it's the same problem

    Posted via CB10
    04-16-17 06:51 AM

Similar Threads

  1. Scary! New Passport SE's on Ebay from Hong Kong
    By EndRacism in forum BlackBerry Passport
    Replies: 46
    Last Post: 05-02-17, 03:14 AM
  2. New DTEK50 keeps restarting (Internal SD-Card?)
    By hgrom in forum BlackBerry DTEK50
    Replies: 5
    Last Post: 04-26-17, 08:03 AM
  3. my blackerry passport silver take long to wipe
    By saniboy47 in forum BlackBerry Passport
    Replies: 4
    Last Post: 04-21-17, 01:54 PM
  4. When can I get a DTEK50 screen replacement in the UK?
    By leighalligan in forum BlackBerry DTEK50
    Replies: 4
    Last Post: 04-17-17, 05:54 PM
  5. Any Leads On New SE's For Sale Any Where?
    By EndRacism in forum BlackBerry Passport
    Replies: 1
    Last Post: 04-15-17, 12:52 PM