1. chrispmoto's Avatar
    Hi.
    For the first time, I accidently ran my batttery out.
    Now, when I plug it in, it blinks twice, shows the Blackberry logo, then the empty battery symbol, then goes blank, then repeats.
    Is it messed?
    How can I reset it?
    12-07-14 08:27 AM
  2. Arabianhorse's Avatar
    I would try a hard reset. Hold both volume buttons down at the same time untill it turns off. It should restart correctly after that. Fingers crossed.

    Cloaking Device & Special Opps Commander for the Peevishlicious Crew on SQW-100-1 10.3.1.1154
    12-07-14 08:32 AM
  3. chrispmoto's Avatar
    Its not tho.....
    12-07-14 08:35 AM
  4. Arabianhorse's Avatar
    it takes time while recharging the battery before you can use it again. Did you give it sometime plugged in before trying to operate?

    Cloaking Device & Special Opps Commander for the Peevishlicious Crew on SQW-100-1 10.3.1.1154
    12-07-14 08:47 AM
  5. Arabianhorse's Avatar
    And better check your charger, plug, ect.

    Cloaking Device & Special Opps Commander for the Peevishlicious Crew on SQW-100-1 10.3.1.1154
    12-07-14 08:48 AM
  6. Arabianhorse's Avatar
    Starting with the easy stuff. GOOD LUCK


    Cloaking Device & Special Opps Commander for the Peevishlicious Crew on SQW-100-1 10.3.1.1154
    12-07-14 08:49 AM
  7. geekaren's Avatar
    Sorry to hear this. How much have you recharged it so far? (I'm wondering if it just needs to recharge a bit before the hard reset can be performed successfully.)
    12-07-14 08:52 AM
  8. chrispmoto's Avatar
    Hi, thanks, I will give it more time. Charger is fine,
    Fingers crossed is right ,,,!
    12-07-14 08:53 AM
  9. chrispmoto's Avatar
    Nope, I think it's done

    it won't take a charge. And it wont do a reset with the cord plugged in.

    It just keeps doing the same cycle over and over again

    Sad day....

    Z30 user and lover.
    12-07-14 09:46 AM
  10. gogogadgets's Avatar
    Let it sit for a good long while on the charger, then try reloading the OS.
    12-07-14 09:59 AM
  11. chrispmoto's Avatar
    It's toast.

    Z30 user and lover.
    12-07-14 11:36 AM
  12. Q10Bold's Avatar
    ....and thats why I hate the non removable battery thing!!
    12-07-14 11:41 AM
  13. jas1978's Avatar
    Did you try pressing the power button on top to turn it on? Just plugging in the power does not turn on the phone.

    Posted via CB10
    12-07-14 11:50 AM
  14. superbb10's Avatar
    Maybe you should try restoring or reload the stock os again it might work because my z10 did the same to me but now its working again!
    12-07-14 12:06 PM
  15. arnavrs's Avatar
    Keep it on the charger for a while. Don't switch it on. Try switching charger bricks if possible (preferably to the UK brick)

    Posted via CB10
    12-07-14 12:56 PM
  16. Tornado99's Avatar
    Try a different charger and cable...I've been fooled before when a new charger died. Also, try connecting to a pc via USB (confirm the cable is good) and connect via Link....see if you can restore from backup or perform a complete os reinstall to default.


    Posted via CB10
    12-07-14 01:14 PM
  17. thymaster's Avatar
    Probably a faulty charger. Switch out your USB cable and try again. This topic has been discussed in another passport thread already with the same problem.
    12-07-14 02:05 PM
  18. anon(870071)'s Avatar
    Hi.
    For the first time, I accidently ran my batttery out.
    Now, when I plug it in, it blinks twice, shows the Blackberry logo, then the empty battery symbol, then goes blank, then repeats.
    Is it messed?
    How can I reset it?
    If the device was in an active state prior to depleting the battery, plug in immediately. Don't worry while it may power cycle. Then once sufficient charge has been reached approx 20% will turn on by itself. Don't keep on turning the device off and on or attempt any reboots while this is happening as you may mess up the startup!

    Posted via CB10
    Last edited by cellphonejunkey; 12-08-14 at 12:36 AM.
    12-07-14 02:14 PM
  19. AshokGov's Avatar
    Nope, I think it's done

    it won't take a charge. And it wont do a reset with the cord plugged in.

    It just keeps doing the same cycle over and over again

    Sad day....

    Z30 user and lover.
    On the Hard Reset, I hope you are releasing the 2 Volume Buttons when the Blackberry Logo comes up!!! Keeping it pressed even after this stage will mean the Passport is going into a 'hard reset loop'. Apparently, in the Z series, you had to keep the buttons pressed for the whole time - but, for the Passport, the Volume Buttons have to be released when the Blackberry Logo comes up for the Hard Reset to correctly and completely execute.
    12-07-14 02:35 PM
  20. chrispmoto's Avatar
    Okay, poopy day. But it got a bit better....
    Charger(s) were fine. Tried 2, then even my Mac. Link wouldnt even recognize the phone.
    Kept plugged in for quite a while. It just WOULD NOT take a charge. It kept the cycle going as in my first post. (when plugged in)
    When not plugged in, it did something a bit different. A different sequence of blinks, but then would seem dead.
    Tried hard reset numerous times. Nothing.
    So, I left it off charger all day. When I got home, Pluged it in, it did the same sequence.
    Then the charging battery icon came on!!! And now its taking a charge, and phone has came back to life!!
    I will just leave it over night now.
    Thanks for the suggestions.
    The sad part is my Z 30 had a terrible day too. But thats another story, one that I am quite ashamed about.....
    12-07-14 11:55 PM
  21. Cyber015's Avatar
    Okay, poopy day. But it got a bit better....
    Charger(s) were fine. Tried 2, then even my Mac. Link wouldnt even recognize the phone.
    Kept plugged in for quite a while. It just WOULD NOT take a charge. It kept the cycle going as in my first post. (when plugged in)
    When not plugged in, it did something a bit different. A different sequence of blinks, but then would seem dead.
    Tried hard reset numerous times. Nothing.
    So, I left it off charger all day. When I got home, Pluged it in, it did the same sequence.
    Then the charging battery icon came on!!! And now its taking a charge, and phone has came back to life!!
    I will just leave it over night now.
    Thanks for the suggestions.
    The sad part is my Z 30 had a terrible day too. But thats another story, one that I am quite ashamed about.....
    I faced the same issue with my blackberry passport, and the solution like what you did, I didn't charge my phone approximately for 12 hours, then plugged it in and the device now taking a charge and it's work fine,
    i replied just to confirm the solution it's work in case someone else face same issue.
    12-11-14 12:54 AM
  22. chrispmoto's Avatar
    After it started working, it did a couple random reboots, I think while using Android apps.

    Also, maybe worth mentioning was in my battery guru app, my battery always showed the health was at or very close tob100. After this little incident, it dropped to 89%.
    After a couple hard resets, the battery health is now back to 100% and phone seems to be working fine!

    Former 9900, Z10, and Z30 user and lover, but now Passport rocker!
    12-11-14 01:07 AM
  23. kojikid's Avatar
    I have the same problem in 2015, exactly 7months after this post.... it's been sooooo frustrating!
    06-15-15 05:56 AM
  24. kojikid's Avatar
    I will leave mine off charge for 24hours if that would help!
    06-15-15 06:00 AM

Similar Threads

  1. Which theme you keep on BlackBerry, light or dark?
    By klobb in forum BlackBerry Passport
    Replies: 29
    Last Post: 12-22-14, 09:43 PM
  2. Proximity light sensor serious issue
    By Fahad Shafiq in forum BlackBerry Q10
    Replies: 3
    Last Post: 12-09-14, 02:03 AM
  3. BlackBerry Watch light concept
    By grahamf in forum BlackBerry Concepts & Dream Devices
    Replies: 1
    Last Post: 12-04-14, 08:48 PM
  4. Why is there a red light blinking?
    By Qaddafi in forum BlackBerry Z30
    Replies: 11
    Last Post: 12-04-14, 04:51 PM
  5. Low light photos
    By vader42 in forum BlackBerry Passport
    Replies: 3
    Last Post: 12-03-14, 12:43 PM
LINK TO POST COPIED TO CLIPBOARD