1. Daniel_asdf's Avatar
    Has anyone here successfully changed their passport battery?

    I tried to change mine myself but can't turn it on. I'm getting a red battery symbol with explanation point.

    Also it shows: bberror.com/bb10-0020

    I tried using Link and reinstalling the OS. It seems to recognise the device. I went through the process of installing the OS, which took about 30 minutes. So it seemed to be doing something but I still cannot turn it on regardless how many times I try or how long i hold the power button.

    Can anyone suggest a way to fix this? I'm otherwise going to have to sell this.

    Tried to change battery but now can't turn it on.-20171126_013223.jpg

    Tried to change battery but now can't turn it on.-20171126_013341.jpg
    Attached Thumbnails Tried to change battery but now can't turn it on.-20171126_013316.jpg  
    11-25-17 12:11 PM
  2. LSDBerry's Avatar
    The low hanging fruit here is obviously the battery.

    What happens if you re attach the old battery?

    Have you checked the phone for anything you may have dislodged in the process?

    Also, I tend to dry assemble things and test them before screwing them back together.
    11-25-17 12:44 PM
  3. arfeo's Avatar
    I remember that red battery on my bold. On BBOS that was the sign of corrupted battery. On BB10 it may mean the same. If you're sure you've done everything right.

    Posted via CB10
    11-25-17 12:51 PM
  4. Daniel_asdf's Avatar
    When I try putting the old battery back, it's the same thing. there's zero difference with the new and old battery. I would guess it's not related to the battery. This is my first time attempting something like this, so I'm really not sure if I did it correctly.
    11-25-17 01:07 PM
  5. Niallac's Avatar
    What symptoms were you seeing before you changed the battery?

    How did the disassembly go? Was it straightforward? If you have never done anything like this before, then first of all, well done for having a go. Your next repair will take you half as long and will work out twice as well!

    I would suspect you've probably disturbed a small ribbon-cable connector somewhere, or disconnected one and not reconnected it properly. These modern smartphones are assembled to unbelievably close tolerances in order to fit everything into the smallest casing possible. There is generally very little slack on the ribbon cables connecting sub-assemblies like batteries, cameras etc to the motherboard, and it's easy to accidentally yank one loose when reassembling. You are going to have to (carefully ) tear it apart again, and check each tiny connector to see that it is properly 'home'. The 'zero insertion force' connectors, which are basically just a row of exposed contact pads at the end of a ribbon cable usually have an insertion line across the cable, which gives an indication of how far they must be inserted for a proper connection. They also sometimes have a locking mechanism on the socket, at one edge of the face where the connector inserts. This will pull away from the socket when the cable is removed, and needs to be re-engaged after the cable is inserted. The type which use a small plastic plug with a number of pins corresponding to a socket on a board, are usually 'keyed' i.e. they have a (tiny) tongue somewhere that fits into a groove in the socket, or vice-versa.

    My advice is to persist with it, but wait until you have an opportunity to do so with plenty of time to spare (if possible). Work in good light over a clean sheet of white paper to make it easier to spot small parts. Let us know how you get on...

    Posted via CB10
    11-25-17 02:09 PM
  6. Daniel_asdf's Avatar
    I'm wondering if I've triggered some error code on the device and you have to reset it somehow to clear that. I've check every ribbon connector and don't think i've disturbed any of them. I think I've bricked it somehow... Oh well.

    My battery life was pretty bad, not lasting even a day in airplane mode and with low-level use. The back of one side of the device would get overly hot as well. I discharged and charge the battery over 10 times but it didn't seem to be getting any better.

    I think it's hopeless unfortunately.
    11-25-17 03:16 PM
  7. Daniel_asdf's Avatar
    I have posted it for sale on Ebay in a 7 day auction. cheers.

    11-25-17 07:21 PM
  8. Daniel_asdf's Avatar
    Posted it again after buyer claimed he didn't realize it's not a working device.

    12-03-17 06:54 AM
  9. IvanTheTolerable's Avatar
    I replaced my battery on my red pp. I ordered a 3rd party battery rather than an oem branded one. Haven't had any issues
    12-04-17 04:33 PM
  10. BB-JAM215's Avatar
    Sounds like the problem was a failed charging system rather than a failed battery.
    andy957 likes this.
    12-04-17 07:47 PM

Similar Threads

  1. Can I only get Hotmail messages please!!!
    By Paullybob in forum BlackBerry Priv
    Replies: 12
    Last Post: 11-29-17, 09:49 AM
  2. Transferring text messages to KeyOne
    By Hilary Hawthorne in forum BlackBerry KEYone Support
    Replies: 3
    Last Post: 11-26-17, 02:19 PM
  3. Priv: Can you disable autostart at plugin?
    By dmacregor369 in forum BlackBerry Priv
    Replies: 3
    Last Post: 11-26-17, 07:24 AM
  4. Replies: 1
    Last Post: 11-25-17, 11:19 AM
  5. Bluetooth activated on restart
    By RLeeSimon in forum BlackBerry Priv
    Replies: 0
    Last Post: 11-25-17, 06:21 AM