1. NJ1193's Avatar
    My AT&T Passport battery is draining super fast (50% in three hours) and shows that it's still charging when it clearly isn't plugged in or on my wireless charging plate. I tried resetting it by holding down the volume keys but no luck. The back is quite warm also and the top right corner is very hot. Any suggestions? Thanks!

    Posted via CB10
    05-27-15 09:57 AM
  2. Lostboy5151's Avatar
    update to the latest OS!

    http://forums.crackberry.com/bb10-le...links-1012656/

    I believe there is a higher one . you'll have to look?
    05-27-15 10:20 AM
  3. J Quimson's Avatar
    But don't jump to the 10.3.2 just yet though.

    Try to look at your resource monitor and see which app is using up a lot of your resources then delete it first and then reset.

    My Passport did that once when I loaded a few apps. After I deleted them and reset, it went back to normal after a few minutes.

    Passport 10.3.2.680
    05-27-15 10:51 AM
  4. anon(153966)'s Avatar
    Are we sure it isn't an app causing this? Or is the device still relatively stock?
    05-27-15 02:05 PM
  5. lang007's Avatar
    I had the same issue and did a master reset and it has worked just fine since.
    05-27-15 03:10 PM
  6. CecilTsunami's Avatar
    Top is hot, something is definitely running that shouldn't be. That's always what I discover.

    Posted via CB10
    05-27-15 05:08 PM
  7. NJ1193's Avatar
    Here is my device monitor info. Phone is stock, other than installing 10.3.1.2576.

    AT&T Passport Problem-img_20150527_182757.png

    Posted via CB10
    05-27-15 06:29 PM
  8. NJ1193's Avatar
    Also, I had a regular Passport before I got the AT&T one, and never had a problem getting the battery to last me from 8am-11pm with 20% left when I went to bed. I know I've read a few posts from people with AT&T Passports with poor battery life. I wonder if it's just the AT&T version?

    Posted via CB10
    05-27-15 06:32 PM
  9. yamahammer's Avatar
    Here is my device monitor info. Phone is stock, other than installing 10.3.1.2576.

    Click image for larger version. 

Name:	IMG_20150527_182757.png 
Views:	854 
Size:	92.4 KB 
ID:	354819

    Posted via CB10
    Firstly I must say that what you have posted indicates that you are heavy user! Looking at the info it looks like PIM services looks to be running a tad high. Check your sync options in your account settings. How many email accounts do you have set up on the phone?

    Passport SQW 100-1 OS 10.3.2.680
    05-27-15 07:38 PM
  10. NJ1193's Avatar
    Three email accounts, Facebook, and Twitter.

    Posted via CB10
    05-27-15 09:18 PM
  11. J Quimson's Avatar
    Sync intervals on you accounts? I have mine set on 24 hour sync.



    Posted via CB10
    05-27-15 09:27 PM
  12. Mmickel Abraham's Avatar
    I have the AT&T version when you first get the Passport it takes at least 3 charges to settle,also the apps have to settle as well.

    Posted via CB10
    05-27-15 09:33 PM
  13. NJ1193's Avatar
    Sync intervals on you accounts? I have mine set on 24 hour sync.



    Posted via CB10
    No setting for sync interval on any account except Gmail, which was 30 minutes. Changed it to 24hrs. The other two accounts are on 'manual' with the box greyed out and no option to change.

    Posted via CB10
    05-28-15 07:26 AM
  14. J Quimson's Avatar
    How's the battery life now? Sorry, I haven't been able to follow up sooner.

    SQW 100-3 10.3.1.1955
    06-02-15 09:14 AM

Similar Threads

  1. BlackBerry z30 battery problems
    By naorrazla in forum BlackBerry Z30
    Replies: 21
    Last Post: 07-08-16, 10:19 AM
  2. How do you get a job at BlackBerry?
    By Acvdm in forum General BlackBerry Discussion
    Replies: 16
    Last Post: 05-31-15, 04:37 PM
  3. Replies: 22
    Last Post: 05-30-15, 04:56 PM
  4. Passport vs z30 speakers - for music and media
    By RexdaleNap in forum BlackBerry Passport
    Replies: 13
    Last Post: 05-29-15, 07:09 PM
  5. Replies: 21
    Last Post: 05-29-15, 03:56 AM
LINK TO POST COPIED TO CLIPBOARD