1. jtcrew88's Avatar
    I've searched through Crackberry, but can't find any clear answers to my issue. I recently moved from an Unlocked Classic to an Unlocked Passport Silver Edition on T-Mobile US. On the classic I got full 4G LTE 90% of the time with no issues. On the Passport I'm experiencing connections that revert to Edge and stay there. I can usually get it back to 4g LTE by changing the network settings to 4G LTE / 4G / 3G only, but with that setting the phone will not receive incoming calls. (T-Mobile US uses 2G for incoming calls). Right now I am back on stock 10.3.2.2474, but I have tried with Blitz files for 2879 (which added Wifi calling) and that was even worse.

    Is there a better radio bar to be using with the Passport?

    Things I haven't tried so far:
    1. New SIM Card (I'm going to try that later this week).

    I'm in the Charleston SC area and have had a great experience with T-Mobile 4G LTE so far on a Nexus 5, Moto X v2, BB Classic. Only the Passport Silver Edition seems to be struggling.

    Thanks.
    12-08-15 12:23 PM
  2. shawnreum's Avatar
    There is no clear answer.
    To get better reception more than likely you'd have to get your hands on a copy of the radio files for the classic from Tmobile for best results.

    In short, Passport is set up to run on multiple carriers, where a carrier branded phone is set up to run best on just that carriers towers. In turn, it makes connectivity less appealing on the Passport.

    Posted via CB10
    12-08-15 07:51 PM
  3. gravesend60's Avatar
    T mobile ny and always have 4g lte.

    Blackberry Passport
    12-08-15 09:05 PM
  4. joeyjay's Avatar
    I upgraded to os 2789 and recently 2813. New Sim from tmobile. When using the phone on wifi at work I end up on voice only 4g and an error message that reads "Device not compatible with Sim Card". Didn't have this issue with 2474. If I manually set the phone to tmobile voice and data it is better.

    I would switch back to 2474 except I love the newer OS Updates. Smooth and fast . Wifi calling seems better on 2813.

    Hope this helps!

    Posted via CB10
    12-08-15 09:18 PM
  5. SK122387's Avatar
    That's weird.

    I get the same if not better LTE with my SE Passport that I do with my T-Mobile branded Classic.

    I'm in LA though, so I'm not in your same area.

    Posted via CB10
    Attachment 383642
    12-08-15 09:31 PM
  6. shawnreum's Avatar
    It's hit and miss on Tmobile with passport that's for sure.

    Posted via CB10
    12-08-15 09:33 PM
  7. Powdah's Avatar
    I was told bt tech support that in some areas with heavy traffic, the longer one is on a tower, the lower down the priority one gets. Therefore, if there is only so much LTE bandwidth, then you could be down graded. He said to go to airplane mode, and then reconnect. That will put at the one back at the top of the heap.

    Posted via CB10
    LoneStarRed likes this.
    12-08-15 09:55 PM
  8. LoneStarRed's Avatar
    Agree. Reinitialize at least twice a day. See how that works.

    "I don't think that word means what you think it means."
    12-09-15 12:54 AM
  9. jtcrew88's Avatar
    The Classic I have was bought from Amazon (not T-Mo branded), although after the 2879 update I suppose that could be considered T-Mo branded, but the signal was the same before.

    Last night I did another update to 2879 on the Passport through Sachesi. Here's what I gather from the results:

    1. I have exceptional 4G LTE service when I have it, using a signal monitoring app, the db levels are very good.
    2. I also have exceptional 2G service on TMo's Edge network.
    3. The Passport will stay locked to whatever network it is on that has good signal. If I don't get a call (which bumps the phone down to 2g, and sometimes fails to switch back) or If I don't going into any poor reception areas, the phone will stay on 4G LTE. The issue seems to be once the phone downgrades to 2G it gets stuck. Usually you can fix it by disabling 2G in the network settings, but sometimes it requires a reboot. I think there is an issue with the Passport hardware radio / software radio combination that doesn't handle switching well.
    12-09-15 06:58 AM
  10. Powdah's Avatar
    What settings did you use in Sachesi to get 2879. I have not been able to find it.

    thks
    12-09-15 10:16 AM
  11. jtcrew88's Avatar
    What settings did you use in Sachesi to get 2879. I have not been able to find it.

    thks
    I used the default settings for TMOBILE with Classic as the device.

    Posted via CB10
    12-09-15 06:15 PM
  12. thakor pravin's Avatar
    Lte probkem
    07-11-17 08:46 AM
  13. rchewning2's Avatar
    I have the same problem in CHS with my Passport.

    I've searched through Crackberry, but can't find any clear answers to my issue. I recently moved from an Unlocked Classic to an Unlocked Passport Silver Edition on T-Mobile US. On the classic I got full 4G LTE 90% of the time with no issues. On the Passport I'm experiencing connections that revert to Edge and stay there. I can usually get it back to 4g LTE by changing the network settings to 4G LTE / 4G / 3G only, but with that setting the phone will not receive incoming calls. (T-Mobile US uses 2G for incoming calls). Right now I am back on stock 10.3.2.2474, but I have tried with Blitz files for 2879 (which added Wifi calling) and that was even worse.

    Is there a better radio bar to be using with the Passport?

    Things I haven't tried so far:
    1. New SIM Card (I'm going to try that later this week).

    I'm in the Charleston SC area and have had a great experience with T-Mobile 4G LTE so far on a Nexus 5, Moto X v2, BB Classic. Only the Passport Silver Edition seems to be struggling.

    Thanks.
    09-23-17 06:30 PM

Similar Threads

  1. 4g problem
    By Paul94 in forum BlackBerry Z10
    Replies: 8
    Last Post: 12-20-15, 01:10 PM
  2. Fitbit on Both my Z30 and My 4G LTE Ellipsis Tablet
    By DoctorNeutron in forum BlackBerry Z30
    Replies: 5
    Last Post: 12-13-15, 07:34 AM
  3. AT&T LTE
    By OTCHRussell in forum General BlackBerry Discussion
    Replies: 13
    Last Post: 12-09-15, 07:39 PM
  4. BBM and 'mobile' phone numbers
    By pineapple2607 in forum General BBM Chat
    Replies: 2
    Last Post: 12-08-15, 08:51 AM
  5. alarm issues
    By ALLYSON1989 in forum BlackBerry Priv
    Replies: 1
    Last Post: 12-08-15, 08:44 AM
LINK TO POST COPIED TO CLIPBOARD