1. prince_1308's Avatar
    Do yall ever lose signal for like 10 seconds? I am in a big city and I seem to randomly lose connection and drop calls. I even have days where I can't browse the internet for a solid minute cause of connection issues. I'm assuming this is a T-MOBILE thing and not an issue with my baby

    Posted via CB10
    11-03-14 09:47 AM
  2. C Youngblood's Avatar
    Do yall ever lose signal for like 10 seconds? I am in a big city and I seem to randomly lose connection and drop calls. I even have days where I can't browse the internet for a solid minute cause of connection issues. I'm assuming this is a T-MOBILE thing and not an issue with my baby

    Posted via CB10
    I haven't any connection problems yet. Have only had mine for about a week now. But I hate that there's no T-Mobile support for the Passport. Can't get my T-Mobile apps (mainly Wifi Calling) to work on it. When I switched over from Z10 they disappeared or stopped working as did several of my Andriod apps. The Amazon Appstore stopped working too even though it was preinstalled. Couldn't get any help from T-Mobile but BlackBerry customer service is looking into it.
    11-03-14 09:56 AM
  3. rolojr1's Avatar
    Hello there I am using Tmobile network with my Passport and the only thing I have experienced was LTE would drop to 4G more often then with my Z30 in the beginning.

    I would disconnect the mobile network antenna and reconnect to reestablish LTE. Other than that occurring a few times in the beginning I haven't experienced a dropped call and the Internet has been stellar over the past three weeks. Not sure why this occurred in the beginning but it seems to have worked itself out. Good luck I'm loving my Passport.

    Posted via CB10
    11-03-14 09:59 AM
  4. rolojr1's Avatar
    We lose wifi calling going the unlocked route my friend. I don't need it where I am but hope one day they can make it available as they have encouraged customers to bring their own devices.

    Posted via CB10
    11-03-14 10:02 AM
  5. messier338's Avatar
    I work in NY and NJ area, I am getting full bars and 4GLTE all the time at both locations.
    No disconnection or drop calls issues so far with OS .1418, voice calls are real clear and loud just like my old Iphone 5 and no problem with voicemail also. WIFI calling is not working but I don't use it much.
    Try test it with a new sim card.
    11-03-14 01:21 PM
  6. rolojr1's Avatar
    I'm also from the NY/ NJ area great service here.

    Posted via CB10
    11-03-14 02:44 PM
  7. Helvitis's Avatar
    I'm in Chicago and I haven't had any issues yet

    Posted via CB10
    11-03-14 02:50 PM

Similar Threads

  1. Nobex and Rad.io not connecting
    By whofrank in forum BlackBerry 10 Apps
    Replies: 4
    Last Post: 12-05-14, 12:34 PM
  2. My passport let me down last night
    By mikedolo in forum BlackBerry 10 OS
    Replies: 80
    Last Post: 11-07-14, 05:14 PM
  3. Scrolling while swiping on the BlackBerry Passport
    By kleinhev in forum Ask a Question
    Replies: 5
    Last Post: 11-04-14, 04:43 AM
  4. Blackberry passport White
    By igorochek in forum BlackBerry Passport
    Replies: 10
    Last Post: 11-03-14, 01:31 PM
  5. (glitch?) Enable keyboard scrolling in CB10 on the Passport!
    By d987654321 in forum BlackBerry Passport
    Replies: 3
    Last Post: 11-03-14, 12:55 PM
LINK TO POST COPIED TO CLIPBOARD