1. xueyaotianxia's Avatar
    I just did a soft reset and problem solved! To do a soft reset you just simply hold the power button for 10 seconds until the phone reboot itself...it will not erase your data. It worked for me.

    Mia san mia!
    02-20-15 11:46 AM
  2. Bla1ze's Avatar
    It worked for me.
    For now. That's not a fix.
    Legal Eagle and LazyEvul like this.
    02-20-15 11:50 AM
  3. fanisk's Avatar
    I don't have this issue after closing and reopening the app.

    Sent from my BlackBerry Passport
    02-20-15 03:17 PM
  4. 63MM's Avatar
    Worked for me as well. On two different passports.

    Posted via CB10
    02-20-15 03:33 PM
  5. robtanz's Avatar
    Worked for me too. No problem since

    Posted via CB10
    02-20-15 03:36 PM
  6. KorChi_JapThai's Avatar
    Probably it will come bAck.

    BlackBerry Passport 10.3.1.2267
    02-20-15 03:59 PM
  7. berry78's Avatar
    For sure will come back, tested

    Posted via CB10
    02-20-15 04:08 PM
  8. tdaye's Avatar
    It will come back. Its been there in all the 10.3.1 leaks on the Passport. I've had the issue for weeks.

    Posted via CB10
    02-20-15 04:10 PM
  9. KorChi_JapThai's Avatar
    That thing has been done for many times, tested and not a fixed.

    BlackBerry Passport 10.3.1.2267
    02-20-15 04:15 PM
  10. TheBirdDog's Avatar
    I still haven't received the Passport official update. Unlocked from shopblackberry and on Virgin Mobile Canada.
    Hearing that the official update had a few bugs such as this makes me feel a little less impatient. Hopefully round 2 of the update will roll out soon enough and maybe I'll get it then.
    Does anyone know if the official update was pulled for the Passport?

    Posted via my BlackBerry Passport
    02-20-15 04:47 PM
  11. junny89's Avatar
    I did a hard reset - volume buttons pressed together.
    Haven't come back once.

    Posted via CB10
    02-20-15 04:52 PM
  12. anon(2325196)'s Avatar
    I have not seen any flickering whatsoever. It's an urban myth.

    Posted via CB10
    02-20-15 05:28 PM
  13. blackbird666's Avatar
    Look in a Mirror and before you complete saying flickity flick flick three times, your screen will flicker once again!



     Passport SQW100-1 / 10.3.1.2267
    02-20-15 05:30 PM
  14. Bonnie Bonzai's Avatar
    I still haven't received the Passport official update. Unlocked from shopblackberry and on Virgin Mobile Canada.
    Hearing that the official update had a few bugs such as this makes me feel a little less impatient. Hopefully round 2 of the update will roll out soon enough and maybe I'll get it then.
    Does anyone know if the official update was pulled for the Passport?

    Posted via my BlackBerry Passport
    I have the same set up as you and after hearing about the bugs, it makes me much less concerned about not getting the Passport update. I was told on another forum that the passport update was delayed until March due to the screen flicker problem...... although some have it anyhow.

    Posted via CB10
    02-20-15 05:36 PM
  15. TheBirdDog's Avatar
    To be honest, I was probably over excited about it anyhow... The keyboard shortcuts will be awesome to have but Blend is a much bigger feature for those getting 10.3 for the first time and we already have that. I'm actually not disappointed that we'll have a more Passport specific update. With the different devices that the lineup includes now, it will make sense that they are updated separately from here on out. Z3, Z10 and Z30 are similar, as are Q10 and Q5, but then there is the Classic and the Passport which are all fairly different in OS functionality.

    BlackBerry has their work cut out for them to keep every device fully and individually optimized.

    Posted via my BlackBerry Passport
    02-20-15 08:56 PM
  16. thymaster's Avatar
    I haven't either and I'm trying my best to replicate the flickering problem so I can help contribute to the community by finding a solution. However, I'm still baffled why I didn't encountered any problem after the update. There must be something quite simple that we overlooked or an easy fix we haven't found yet.

    I have not seen any flickering whatsoever. It's an urban myth.

    Posted via CB10
    02-21-15 03:42 AM
  17. k66473's Avatar
    I turned off the battery saving mode and enjoying more than 15 hours non flickering. Please try your self and feed back the result.

    Posted via CB10
    02-21-15 03:51 AM
  18. whatsever's Avatar
    I really start to think it could be a gpu driver problem, because pp is the only one who has this problem


    Posted via CB10
    02-21-15 04:14 AM
  19. CyberMan2013's Avatar
    I haven't either and I'm trying my best to replicate the flickering problem so I can help contribute to the community by finding a solution. However, I'm still baffled why I didn't encountered any problem after the update. There must be something quite simple that we overlooked or an easy fix we haven't found yet.
    Sometimes it could take days or weeks for the flickering to show up. It seems to happen more frequently with a large number of simultaneous apps open. Besides the flickering there's evidence that the "new" quad core architecture and aggressive soc power saving features haven't quite been mastered yet by BlackBerry. An example of this is when I'm playing music using Neutron and Waze makes an announcement, the music speeds up. That never happened on my Z10.

    The flickering is strange. It seems as if it's half of the backlight array that turns off and then strobes at a high frequency as there is keyboard or touchscreen scrolling taking place. It manifests in different ways as well though, e.g. Green flickering in the camera app; action bar disappearing then flickering when you scroll; sometimes the top half of the screen flickers while the bottom half remains lit; sometimes the bottom half of the screen flickers while the top half of the screen remains lit. To me it also likes to happen when you take the phone out from your pocket from an otherwise idle state. Or just when an app launches. Only native apps though. Have never seen any flickering on any Android app I've used. I've seen it in the hub when composing an email to mclewey about the flickering. It also happened in bbm and probably in other apps too. Most frequently in the camera app. I saw it immediately after first boot after installing 10.3.2072. I've been running 10.3.1.2072, 2243, 2267 since they all came out.

    Those are my observations so far.

    Posted via CB10
    02-21-15 09:03 AM

Similar Threads

  1. Upadated to 10.3.1...having problems with camera app
    By kamal lyall in forum Ask a Question
    Replies: 5
    Last Post: 02-20-15, 11:18 PM
  2. 10.3 hub is white, how to go back to black?
    By bracque in forum BlackBerry 10 OS
    Replies: 5
    Last Post: 02-20-15, 02:28 PM
  3. Am I The Only One Who Loves The New Update (OS10.3.1)?
    By joshua_sx1 in forum BlackBerry Z10
    Replies: 5
    Last Post: 02-20-15, 01:03 PM
  4. How do I connect to Control4?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 02-20-15, 12:15 PM
  5. Why after updating my Z30 to 10.3 the sound is so low?
    By Gheorghe Olah in forum Ask a Question
    Replies: 2
    Last Post: 02-20-15, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD